OpenWrt 19.07.0 first stable release

Yeah I installed the following packages: wireguard , luci-proto-wireguard , luci-app-wireguard

1 Like

Related: 19.07 Upgrade renders Wireguard Client Inoperable

1 Like

Upgraded to 19.07 (openwrt-19.07.0-ar71xx-generic-archer-c60-v2-squashfs-sysupgrade.bin) again after that restart my router, now it works fine
at that moment I upgraded to 19.07 I must have restarted my router that I didn't
it's my bad
Thank you my friends

1 Like

TP-Link TL-WR902AC does not seem to be available at

It is still available in

Does that mean it is stuck with the older kernel and no support?

Yesterday, after a few hours working with the internet, I wasn't able to go to router setting on luci web and it showed (can not open this page) like out of memory then I had to return to previous version 18.06 and config my router again
I had this problem before when I upgraded from 18.06 to 19.07 and had to downgrade to 18.06 version again

My router : TP-Link Archer C60 V2

Thank You

No, it means that your device wasn't ported to the newer driver yet. It has nothing to do with the kernel.

You can either wait and use the ar71xx until someone port it, or do it yourself if you know how.

1 Like

Several MT76 machines had problems regarding MAC address retrieval, and now pull the MAC from the correct locations in the EEPROM, resulting in new MACs.
If you look at the commit history for your routers base (ATH79, ramips, etc.) you might see changes in the DTS files where this was cleaned up.

1 Like

can't install 6to4:

root@DavidSummers:~# opkg install 6to4
Installing 6to4 (12-2) to root...
Collected errors:
 * opkg_install_pkg: Package size mismatch: 6to4 is 1834 bytes, expecting 1837 bytes
 * opkg_install_cmd: Cannot install package 6to4.

Is there a problem?

Type opkg update and try to install again.

I believe it's because RPS/XPS is enabled by default - see output from my device: [18.06.4] speed fix for BT HomeHub 5a

It's easy to test: echo 0 wherever it's not 0, ie echo 0 > /sys/class/net/eth0/queues/rx-0/rps_cpus

Also check Software and hardware offload in firewall settings (not sure if they work), but together with rps i get 1Gbps NAT with only 1 out of 4 cpus saturated

Thanks for a great release!

This release brought ieee80211r fast roaming to archer a7 v5 APs(ath79) and it just works.

Used "ct-htt" firmware, but didn't test others since this worked for me:

opkg remove wpad-basic ath10k-firmware-qca988x-ct && \
   opkg install wpad-openssl ath10k-firmware-qca988x-ct-htt

Roaming configuration is simple, everything you need is on the shot below.
Choose your value for "Mobility Domain" and use it on all APs, select non-overlapping channels for each AP (not pictured)

Same in /etc/config/wireless

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'public name'
        option key 'secret key'
        option ft_psk_generate_local '1'
        option ieee80211r '1'
        option mobility_domain '1907'
        option ft_over_ds '1'
        option ieee80211w '1'
        option encryption 'psk2+ccmp'

Upgraded my TD-W8970 from 18.06 and it's working very good, including DSL part.
Thanks to all the developers involved.
The only thing I can't get to work is acme(Let's encrypt) script, my domain can't be verified via http, the latest acme script version installed from repo.

Are you sure we are talking about the same thing? Your next post is talking about the ath10k firmware, which means you aren't using a mt7621 device. I am experiencing issues with hardware flow offload not working, which is a mt7621 device only.

Though I must say your results intrigue me. Only loading 1 CPU core for gigabit NAT is definitely very good! What performance are you seeing without the RPS/XPS tweak?

Yup opkg update solved the problem. Did you update something, my last update was only a day or two ago.

Didn't bring up 6to4 though, will need to look into it when I get home. I guess its the script /lib/netifd/proto/ that brings up 6to4 ipv6? If so I'll run it by hand and check what errors I get ...

On Monday I updated my TRENDnet TEW-692GR from 18.06.05 to this stable release... so far so good.

without realizing there was a difference between ar71xx and ath79 (which I still don't know exactly the difference is.. lol) I installed the ar71xx build on my Tp-link Archer C7 v2 (fresh config). Everything appears to be functioning well.. seems a bit slower.. but that could be cause I'm using unbound as my primary DNS-Forwarder with dnsmask for local traffic.

Anyways, would it make a difference if I upgraded to the ath79 image at this point? Could I do so using sysupgrade and KEEP my settings?


You need to not save settings when switching between targets. If you have too much settings and your router is currently working well then you can wait for the next release to switch.

1 Like

I've noticed that ath79 runs faster internet than ar71xx on my Archer C7 V2. If you are up to it, you could flash the ath79 without keeping settings and reenter your configuration.

1 Like

i use ath10k for AP, but toying around with mt7621 for a rounter, see comment in performance related thread: [18.06.4] speed fix for BT HomeHub 5a

Installed in a wrt1900acs with sysupgrade from 18.06.4 without problems.