OpenWrt 18.06-rc1 doesn't obtain ipv6 address

I have OpenWRT 18.06-rc1 installed on a Netgear R6220, and am trying to get IPv6 to work.
The problem is that OpenWRT doesn't obtain an IPv6 address from my ISP (comcast). If I connect my laptop (running Archlinux) directly to the modem, then I do get an IPv6 address on the laptop, and sites like test-ipv6.com say it works.
Rebooting OpenWRT didn't help. Reconnecting the WAN6 interface via LUCI, I only get the following in the system log:

Sun Jul  8 15:25:45 2018 daemon.notice netifd: Interface 'wan6' is now down
Sun Jul  8 15:25:45 2018 daemon.notice netifd: Interface 'wan6' is setting up now

And on the ssh-command line of the router I get

root@OpenWrt:~# ifstatus wan6
{
	"up": false,
	"pending": true,
	"available": true,
	"autostart": true,
	"dynamic": false,
	"proto": "dhcpv6",
	"device": "eth0.2",
	"data": {		
	}
}

What else can I try? Any help getting IPv6 working is appreciated!
Here is my /etc/config/network:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdbd:fff6:fdf8::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device 'lan_dev'
	option name 'eth0.1'
	option macaddr 'XX:XX:XX:XX:XX:11'

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'dhcp'

config device 'wan_dev'
	option name 'eth0.2'
	option macaddr 'XX:XX:XX:XX:XX:10'

config interface 'wan6'
	option ifname 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 6t'
	option vid '1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6t'
	option vid '2'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option vid '3'
	option ports '2 3 6t'

config interface 'srvlan'
	option proto 'static'
	option ifname 'eth0.3'
	option ipaddr '192.168.3.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

If you run an ubus call network.interface dump, do you see a wan_6 (not wan6) interface?

I only see a wan6 interface. These are the interfaces I see:

root@OpenWrt:~# ubus call network.interface dump | grep interface
"interface": [
"interface": "lan",
"interface": "loopback",
"interface": "srvlan",
"interface": "wan",
"interface": "wan6",

I had the same problem on a D-Link DIR-860L B1 with 18.06-rc1 but had no time troubleshoot :frowning: Went back to 17.01.4 and all is fine.

I finally got around to some experiments using old snapshots I have in my backups. IPv6 stopped working sometime between Feb 10 and May 12. Unfortunately, I don't have any snapshots between these two dates,and I'm a little hesitant to compile on my own... any help appreciated. I'd like to do a reproducible build of the release first.

Snapshot r5669-a367645 from Jan 2: IPv6 works.

Snapshot r6038-13e8d54 from Feb 10: IPv6 works.

Snapshot r6878-4045080 from May 12: IPv6 doesn't work.

Release 18.06.0 from July 30: IPv6 doesn't work.

(I tested these without doing any custom configuration.)

OK, so I did bisection to find that hardware NAT offload is the culprit:

$ git bisect good
There are only 'skip'ped commits left to test.
The first bad commit could be any of:
424a9ae128bd2045cd4bfd6e3229f2529d150a25
bfed38254076d576914251689a2e1f85d514783d
We cannot bisect more!

Where is the proper place to report this bug? Here?

I too am not getting any ipv6 from comcast with 18.06.1 My hardware is an apu2.

Please consider making another thread.

I added confirmation to https://bugs.openwrt.org/index.php?do=details&task_id=1763