Openwrt 18.06 can't ping devices on the network

hope someone can help as I'm going crazy here and I can't figure it out

I got this BT home hub 5 a with openwrt 18.06 installed
I can power the router and connect to it via wire or wireless
for the moment I don;t have it connected as a modem as the DSL hasn't switched yet

so I've connected the router on my existing network
I have 2 switches with several devices connected
as my gateway is I changed the default address of the openwrt router to so that can be on the same network

I thought I could reach it and configure it while still using my existing network
seemed pretty straight forward to me

but no. I can't reach the IP unless I connect directly to the router or the wifi
and if I do then I lose connectivity with every other device on the network :expressionless:

can anyone think what could be the issue?

how come I cant reach any device on the network even though they are on the same subnet?
I just can't explain it or find out what's wrong with it

please help


oh here is the network file

config globals 'globals'
        option ula_prefix 'fdae:3f1e:c0f0::/48'

config atm-bridge 'atm'
        option payload 'bridged'
        option nameprefix 'dsl'
        option vci '38'
        option vpi '0'
        option encaps 'vc'

config dsl 'dsl'
        option annex 'a'
        option tone 'av'
        option ds_snr_offset '0'
        option xfer_mode 'ptm'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr ''
        option netmask ''
        option ip6assign '60'
        option delegate '0'

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr 'c8:91:f9:1e:b4:8c'

config interface 'wan'
        option proto 'pppoe'
        option ifname 'dsl0.101'
        option ipv6 'auto'
        option keepalive '0'

config device 'wan_dev'
        option name 'dsl0'
        option macaddr 'c8:91:f9:1e:b4:8d'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '10'
        option ports '0 1 2 4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 6t'

 config interface 'vlan10'
        option proto 'none'
        option stp '1'
        option auto '1'
        option ifname 'eth0.1'
        option type 'bridge'

I've tried to add the vlan10 as the switches are all on vlan10 (although that shouldn't make any difference as that;s only for the switches to use)
but nothing seems to work

I only want to use this router as a normal device - no complex
and I want to be able to reach any device on the network when I am connected to this router via wifi

can you spot anything I'm doing wrong?

thank you in advance for any help



so I still have the same problem but I discovered something different

setup is still the same the Main router (that gives me internet) 2 switches, several devices wired connected to the switches - and the OpenWRT router connected via a cable one of to the switch

I connected with my laptop to an extra port on the OpenWRT router using a cable
I got an IP from the main router and I could connect to the internet.
nevertheless I couldn't reach the OpenWRT router IP address :thinking:

however, with the same laptop I connected also to the Wifi of the openwrt and I got an address from it
now I can connect to the openWRT router via the wifi but not from the wired connection

this is becoming even more puzzling to me
it seems that the wired interfaces are working as a normal switch but preventing to communicate with the actual openwrt router
while the wifi is directly connected to it you can :expressionless:

hopefully someone more knowledgeable than me on the openwrt software can figure this out
yet I can't find out how on the same subnet this is not working - what could prevent the traffic to pass

thank you


You assigned all the LAN ports to VLAN 10, but ...

... the lan interface is still on VLAN 1. This breaks the connection between the wired ethernet ports and the OpenWrt system.

In addition, the lan interface conflicts with the vlan 10 interface:

because eth0.1 cannot be a member of two bridges at the same time. One of the interfaces (lan, vlan10) will not work.

I suggest to revert the switch config to VLAN 1 and also to remove the vlan10 interface. Once basic connectivity works, you can add more VLANs and ask if you have further questions. In this case we might need some more details about the VLAN configuration of the other switches.

If your main router is serving DHCPv4, make sure there is only one server on your LAN.
For example, to disable OpenWrt's DHCPv4 server:

uci set dhcp.lan.ignore='1'
uci commit dhcp

When posting config files, please use the </> button to show them as preformatted text. This ensures that the indentation is preserved and a monospace font is used.

1 Like

Until you get DSL working, set up the router as a dumb AP. A dumb AP has only one network: LAN. (The default WAN related stuff can be left in place, it won't do anything without DSL connected).

No need to set up any other VLANs. You can leave the Ethernet switch and port in default configuration so that all four ports are LAN. It is important to turn off the DHCP server which by default runs on the LAN interface so it does not conflict with the main router.

In order for the OpenWrt OS itself to have Internet access (to install packages or fetch NTP time) it is necessary to add gateway and dns options to the LAN section of /etc/config/network. These would point to the IP of your main router. Take them out later when the OpenWrt device is the main router.

1 Like

thank you for the suggestion
I removed the vlans and now seems to be working as expected :slight_smile:
hopefully everything will work once the VDSL gets switched over :slight_smile:

thanx again for your quick reply

I need to learn how this new openwrt works as it seems that you can mess it up very quickly

will keep you updated as if it doesn't work I would need your help yet again :smiley:
thank you


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.