Openwrt-18.06.5, avm_fritzbox-4040, WIFI-Problem


Openwrt 18.06.05 on a Fritzbox4040 Device, Problems with WIFI.

I am happy that I got the Open WRT on a Fritzbox440 according to the instructions in the Kuketz blog.
Then I clamped the part behind my Fritzbox7490 and started with the setup.
There are now problems with the WLANS on the Fritzbox4040.

The Lan works fine at first.

Then I set up the WLAN so far, see in the receiving devices also the spanned WLAN networks. Sometimes you can also connect, but you can't get Internet access (probably no Internet access available, please connect to another network).

After such attempts, the LAN will no longer work.

If I switch off the WLAN in Open WRT under "Wireless" and also deactivate the WLAN under "Interfaces", the LAN will also work again after a restart (disconnect power).

The Fritzbox7490 ( does the WAN for the Fritzbox4040 (
In the Fitzbox7490 the two routes and are set up.

In the Open WRT the LAN Gateway temporarily works perfectly (until the WLAN is switched on).

The WLAN gateway works somehow, it is visible in the end devices, but a connection to the Internet cannot be established.

I can still say that I haven't activated DHCP anywhere and only use fixed IP addresses.
In the interfaces under DHCP server the check mark is set to "Ignore Interface".

I have already replaced all cables.

Can someone give me a hint if one of the many settings, some of which I don't know properly, is not working properly or what's going on?

Welcome :slight_smile:

It would help us help you if you posted screenshots of the relevant config pages and the link to the blog post you mentioned. I have a 4040 running 18.06.4, so I can compare the settings.

Sorry, but I'am a new user and I cant load more than 1 Picture.
Email possible ?

If you are comfortable with using the terminal (ssh or telnet), we could extract the configuration that way too.

Otherwise, inefficient as it might be, you could perhaps try and post ONE picture per message and multiple messages. Crude but it should work, I guess.

As your network is IPv4 only be sure you have disabled the IPV6 DHCP servers under the IPv6 tab. The checkbox does not do that.

1 Like

I look at all interfaces to the IP6 Services, they are all disabled.

Hmm, ok, maybe next time a screenshot would be preferable to a photo: much easier to read.

Remove the default gw on the LAN interface: this is not sent to connected devices.

Anyhow, a few more questions:

  1. disabling DHCP is an explicit choice, ja?
  2. if so, is the default gw set in the end devices?
  3. what is the firewall policy?
  4. is masquerading active on the outgoing connection?

With "default gw" you mean the entry at IP4 gateway at Interfaces-LAN?

The switched off DHCP is so needed, because otherwise many devices would have to be converted to DHCP. I would also prefer fixed IP4 addresses instead of DHCP.

lan lan-wan accept accept accept
wan wan-reject reject accept reject
wifi wifi-wan accept accept accept

Maquerading - all unchecked, MSS Clamping all unchecked


Thing is, DHCP also gives the default gw to the clients.

You have to check Masquerade and MSS on the WAN zone so that LAN can NAT forward out to the Internet.

1 Like

I have cleared the IP4 Gateway field in the "LAN" interface and activated the Masquerading and MSS Clamping checkboxes in the "WAN" firewall.

The behavior of the device did not change, the same error still occurs.

On the Lan the Internet is reachable with the Fritzbox4040 switched on.
After switching on the WLAN, the SSID is visible in the wireless network, but the connection to the Internet does not work.
Then the Internet on the LAN will not work anymore, or only when the Fritzbox has been restarted.

Sorry, I assumed you had LAN and WIFI bridged and in the same firewall zone.
If this is not the case, then simply removing the default gw from the "lan" definition isn't enough: remove it also from the "wifi" config.

Thank you, that worked!
In the firewall no checkboxes are activated anymore, and in both interfaces (WIFI and LAN) the IP4 gateways are empty.

A first test showed that both LAN and WLAN are finally usable. The WLAN can also be turned on and off and everything still works.

In the coming days I will check all this more closely.

My thanks go to you for your quick help.

1 Like

You're welcome :slight_smile:
Once you're satisfied with your checks, please edit the subject of this thread (adding "[solved]" at the beginning). I see you have already ticked the solution box, that's good.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.