OpenWrt 18.06.5 Archer C5 V2 back to stock

Hi, i just want to go back to the official tplink version, please help me. I can't install the factory version because it says:

It appears that you are trying to flash an image that does not fit into the flash memory, please verify the image file!

  • Checksum
    MD5: 41e3c129043ad2126f14a6dc0a84bef5
    SHA256: 49cc73f683cc3b8fd63820e6f0f8ae172b85cadff2dd17efa413358d8e0eefe5
  • Size: 9.77 MB (2.00 MB available)
  • Note: Configuration files will be erased.

My network is very slow and i just want to go back to the official version.
Please help and thanks.

The factory version is for installing OpenWrt the first time over the vendor's firmware.
You need to follow the procedure from here.

1 Like

i tried to recover via TFTP Recovery with tftpd32 but it won't work, i did exactly what it says, i tried rename the firmware to ArcherC5v2_tp_recovery.bin and tried ArcherC5v1_tp_recovery.bin too but it won't recognize it.

dump your tftp traffic/server log... to confirm the name.... let me see what i have laying around...

serverip :
filename: 16:01:49.368029 IP > nuc.tftp:  35 RRQ "ArcherC5v2_tp_recovery.bin" octet
power on holding WPS/reset

fwiw... this device always says the image is too large... even when it is ok... ( but do your own math... ) but ... i'd be using tftp for stock anyway...

do you have any suggestions? i would like to use openwrt too if i can config my wi-fi, because now it's incredible bad, from ~300mb on mobile to 0.5mb. oh yea, and internet via cable, from ~1GB to ~500Mb

if you need proper wifi... use factory. test tftp from a normal client... and try with different switch ports or a switch in the middle... from memory it is a little fussy...

on my tftp server log it won't show nothing when i do that, it won't start

sounds like your issue is likely cabling or your power on / activation technique...

i got the ethernet cable straight into my pc and the wps is flickering and nothing happen with tftp

so i set the IPv4 ip address to and i have this folder C:\Users\Denis\Desktop\Archer_C5_V2.0_150908 with this in it ArcherC5v2_tp_recovery.bin, i'm sellecting current directory from my Tftpd32 by Ph. Jounin, i got the cable into the pc and then i power off the router, and after that, im holding the WPS/Reset button and and power on the router, the wps is flickering, than is steady and after that the power on is flickering and than steady

if you dont have a spare switch a crossover would also be worth a try.

i got an huawei hg8245h with optical fiber cable that is connected to the router via ethernet cable into the network port

i tried switching all the port on the router, nothing shows it's only moving himself server interface from the ip (Intel(R) Ethernet Connection (2) I219-V) to the ip (software loopback interface 1)

ipconfig /all

i changed IPv4 Address to auto now because if i put it my network won't work, you understand

It's still running OpenWrt so you get the network. To use TFTP recovery you have to static IP the PC at Also the standard Windows Firewall and third party firewalls will block a TFTP server from working, so you have to turn those off while you are doing TFTP recovery.

ok, so i did a simple flash for the firmware and it worked, now my wifi is good and my network works well but i have this version of firmware:
0.0.0 Build 20191105 Rel. 0 and i can't update it, i don't think that a big problem, but if anyone can help me, it's welcome

Error code: -25533
Error occurred, please try again.
Error code: 18005
Upgrade unsuccessfully because the version of the upgraded file was incorrect. Please check the file name.

If TP-Link firmware is not accepting an upgrade to other TP-Link firmware it is probably because the region code does not match.