OpenWrt 18.06.0 release


The OpenWrt community is proud to announce the first release of the OpenWrt 18.06 stable version series. It incorporates over 4000 commits since branching the previous LEDE 17.01 release and has been under development for well over a year.

With this release, the re-merged OpenWrt project attempts to define a baseline for future development based on the technological modernization and refined release processes done by the former LEDE project.

Some selected highlights of this release since the previous LEDE 17.01 and OpenWrt Chaos Calmer 15.05 versions are:

  • Linux kernel updated to version either 4.9.111 or 4.14.52, depending on the architecture
  • Updated toolchain:
    • musl libc 1.1.19
    • uClibc-ng 1.0.30
    • glibc 2.26+
    • gcc 7.3.0
    • binutils 2.29.1
  • Updated Linux kernel:
    • Kernel 4.9.111 for ar7, ar71xx, arc770, at91, brcm2708, brcm63xx, ixp4xx, lantiq, layerscape, mpc85xx, orion, rb532 and uml
    • Kernel 4.14.52 for apm821xx, archs38, armvirt, ath25, bcm53xx, brcm47xx, cns3xxx, gemini, imx6, ipq40xx, ipq806x, kirkwood, malta, mediatek, mvebu, mxs, octeon, octeontx, omap, oxnas, pistachio, ramips, sunxi and x86
    • Backported network flow offloading support for targets using the
      4.14 Linux kernel
  • Network userland:
    • IPv6 related fixes in DHCPv6 client and servers
    • Support for user DHCPv6 client options in sent packets
    • DHCP forced renew support (RFC6704) in odhcpd
    • Firewall support for conntrack helper setup and better ipset integration
    • Introduced support for configuring GRE, GRE-TAP, VETH, VTI, VXLAN
    • CAKE v20180716 includes tc filter classification making ingress prioritisation easier
    • Cake & sqm-scripts updated representing state of the art mitigations for bufferbloat
    • Wireguard VPN v20180625 with MIPS optimisations and flow-offload compatibility
  • System userland:
    • Improvements in system upgrade procedure
    • Bugfixes in the process manager, system message bus, embedded webserver and the configuration management library
  • Platform and Driver Support
    • Dropped adm5120, adm8668, au1000, mcs814x, omap24xx, ppc40x, ppc44x, xburst and zynq targets
    • Added Spectre and Meltdown mitigations as well as microcode loading support to x86
    • Rebased oxnas target on top of upstream Kernel 4.14 support
    • Updates and new device support across all targets
  • Web interface:
    • New auto-rollback functionality to revert configuration changes when access to the router is lost
    • Better support for displaying virtual interfaces and low level configuration errors
    • Security improvements

For a detailed list of changes since 18.06.0-rc2, see

For a complete list of changes since branching the previous old stable
LEDE 17.01 release refer to

Known issues:

  • Support for a hardware-bug workaround needed for devices having an AT8032 ethernet phy accidentally got dropped. Hence devices with that ethernet chip may experience connectivity issues. At least ubnt-loco-m-xw and most likely other single-port ubnt devices are affected.
    [fix merged, queued for 18.06.1]
  • Using ip4ip6 tunnel interface as a fallback interface accepting ip4-in-ip6 tunneled packets from any remote address doesn't work.
    [fix merged, queued for 18.06.1]
  • Support for PCIe on ox820 is broken, results in missing USB3 support on Shuttle KD20
    [driver needs more work]
  • Images for some device became too big to support a persistent overlay, causing such models to lose configuration after a reboot.
    If you experience this problem, please report the affected device and consider downgrading to LEDE 17.01.5 or using the Image Builder to pack a smaller custom image.
  • Some devices, such as the Netgear R6100, may lack 5GHz wireless AC support.
    Investigation is ongoing and a fix is expected for 18.06.1. Affected users shall downgrade to LEDE 17.01.5 for the time being and wait for the first service release.
  • Devices using the mt76 wireless driver may experience stability issues on 2.4GHz
  • The legacy at91 and legacy ath25 (formerly “atheros”) targets failed to build due to image size constraints and are not part of the release.
  • A GUI bug prevents selecting and scrolling text in the system and kernel log pages. To solve, either upgrade “luci-theme-bootstrap” using opkg or switch to another theme.
    [fix merged, queued for 18.06.1]
  • Any outstanding issues reported at

For latest information about the 18.06 series, refer to the wiki at:

To download the v18.06.0 images, navigate to:

With the release of OpenWrt 18.06, the old OpenWrt 15.05 series is marked end of life and will not get any support any more, not even for severe security problems. LEDE 17.01 will still get some security
support for a limited time. We encourage everyone to upgrade to OpenWrt 18.06 to get the best support.

As always, a big thank you goes to all our active package maintainers, testers, documenters, and supporters.

Have fun!

The OpenWrt Community


CONGRATULATIONS! :tada::tada::tada:


Thanks for all the hard work!!! <3

1 Like

I'm using OpenWrt/LEDE 17.01.5 on 1 of my 1900ac(s) (vlan. openvpn, openssh, dnscrypt and my custom scrips)

+1 setup :slight_smile:

Can I use "sysupgrade -c linksys-wrt1900ac-squashfs-sysupgrade.bin" from 18.06.0?

I have the same hardware and used luci to upgrade from 17.01.3, everything seems fine, you still have to re-install all those packages though.


Excellent news, my sincere thanks to the team.

I loaded 18.06.00 on my TP-LINK TL-WR741ND v4 just an hour ago.

It works, 84KB remaining free after my additional 10k of startup and sched configurations are added.

1 Like

No kmod-fs-exfat package in repo. Is it possible to get it anywhere except self-compiling?

Currently no.
By current defaults, the buildbot system does not build patented stuff anymore, and exfat falls into that category.

As kmods are tightly tied to the kernel version and options, compatibility requires exactly same version.

In theory, somebody might compile a compatible kmod with the release SDK and place it available (like eduperez has done for new mwlwifi versions), but so far nodoby has done that.

regarding exfat, detailed explanation can be found in Exfat package for 4.14? (build patented)

1 Like

thats a biggie and will hit a lot of people. should be in the know issuses (maybe in bold)

1 Like

That also affects multimedia stuff around ffmpeg

About the exfat driver, there's a new(er) driver that probably should replace the current one however I can't figure out how to get it to report exfat as exfat instead of sdfat.

If someone knows the solution feel free to reply in

1 Like

above is a wish for the release 18.06 docs: mention that patented stuff is not available anymore in the release download repo and needs to be built by the users themselves. Same goes also for master snapshots, of course.

Affected stuff is e.g. exfat file system, some ffmepg-related multimedia packages, etc.

kmod-sit don't worked!

Thu Aug  2 16:28:48 2018 kernel: [2363628.104336] sit: non-ECT from with TOS=0xf
Thu Aug  2 16:28:48 2018 kernel: [2363628.115230] sit: non-ECT from with TOS=0xa
Thu Aug  2 16:28:48 2018 kernel: [2363628.218472] sit: non-ECT from with TOS=0x1
Thu Aug  2 16:28:48 2018 kernel: [2363628.226370] sit: non-ECT from with TOS=0x5
Thu Aug  2 16:28:48 2018 kernel: [2363628.234014] sit: non-ECT from with TOS=0xa
Thu Aug  2 16:28:48 2018 kernel: [2363628.245159] sit: non-ECT from with TOS=0xa
Thu Aug  2 16:28:48 2018 kernel: [2363628.251850] sit: non-ECT from with TOS=0xa
Thu Aug  2 16:28:48 2018 kernel: [2363628.359123] sit: non-ECT from with TOS=0xe
Thu Aug  2 16:28:48 2018 kernel: [2363628.392724] sit: non-ECT from with TOS=0xa
Thu Aug  2 16:28:48 2018 kernel: [2363628.404445] sit: non-ECT from with TOS=0xb

Fix it!
I'll be waiting for 18.06.1

Can we have table which ar7xxx platforms migrated to ath79 kernel 4.14 thx!

In this release? None so far.

Thx sorry I thought it was done.

Are you sure it doesn't work? It works for me, but gives a lot of logging noise. First hit on Google: "Kernel update 4.4.132 enables log_ecn_error in sit module by default now, syslog spam". So a simple
echo N > /sys/module/sit/parameters/log_ecn_error
in /etc/rc.local solved the issue.

Do you mean: "Could you fix that, please?"


I'd like to think he didn't want to be offensive and he's English is just bad.

Do you mean: "his English"?

1 Like

I felt this is my lucky friday the third and I made a sysupgrade on a Netgear R7800 from 17.01.4 to 18.06 and checked 'keep settings'. The white LED is blinking slowly and that's it, not getting an IP.

Lucky me I got a second R7800 with 17.01.5 ;- )