Openvpn with windscribe

Here are my logs and config, i can connect to windscibe i used this tutorial (below) but it kills my internet nothing works once connected.

Logs - https://pastebin.com/Z9TJDnXV

Config - https://pastebin.com/HYJfsvKp

any help would be great

thank you

Replace option comp_lzo 'yes' with option compress 'lzo' in your 'openvpn' config.

Code 22 error is specific to OpenWRT 18.x

Still not letting me connect to the internet after it starts

Please help

Tue Sep 11 14:07:40 2018 OpenVPN 2.4.5 arm-openwrt-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [MH/PKTINFO] [AEAD]
Tue Sep 11 14:07:40 2018 library versions: OpenSSL 1.0.2p  14 Aug 2018, LZO 2.10
Tue Sep 11 14:07:40 2018 Outgoing Control Channel Authentication: Using 512 bit message hash 'SHA512' for HMAC authentication
Tue Sep 11 14:07:40 2018 Incoming Control Channel Authentication: Using 512 bit message hash 'SHA512' for HMAC authentication
Tue Sep 11 14:07:40 2018 TCP/UDP: Preserving recently used remote address: [AF_INET]107.161.86.131:53
Tue Sep 11 14:07:40 2018 Socket Buffers: R=[163840->163840] S=[163840->163840]
Tue Sep 11 14:07:40 2018 UDP link local: (not bound)
Tue Sep 11 14:07:40 2018 UDP link remote: [AF_INET]107.161.86.131:53
Tue Sep 11 14:07:40 2018 TLS: Initial packet from [AF_INET]107.161.86.131:53, sid=035bc5cb 69ff9044
Tue Sep 11 14:07:40 2018 WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this
Tue Sep 11 14:07:40 2018 VERIFY OK: depth=1, C=CA, ST=ON, L=Toronto, O=Windscribe Limited, OU=Operations, CN=Windscribe Node CA
Tue Sep 11 14:07:40 2018 VERIFY KU OK
Tue Sep 11 14:07:40 2018 Validating certificate extended key usage
Tue Sep 11 14:07:40 2018 ++ Certificate has EKU (str) TLS Web Server Authentication, expects TLS Web Server Authentication
Tue Sep 11 14:07:40 2018 VERIFY EKU OK
Tue Sep 11 14:07:40 2018 VERIFY OK: depth=0, C=CA, ST=ON, O=Windscribe Limited, OU=Operations, CN=Windscribe Node Server 4096
Tue Sep 11 14:07:40 2018 WARNING: 'link-mtu' is used inconsistently, local='link-mtu 1602', remote='link-mtu 1550'
Tue Sep 11 14:07:40 2018 WARNING: 'cipher' is used inconsistently, local='cipher AES-256-CBC', remote='cipher AES-256-GCM'
Tue Sep 11 14:07:40 2018 WARNING: 'auth' is used inconsistently, local='auth SHA512', remote='auth [null-digest]'
Tue Sep 11 14:07:40 2018 Control Channel: TLSv1.2, cipher TLSv1/SSLv3 ECDHE-RSA-AES256-GCM-SHA384, 4096 bit RSA
Tue Sep 11 14:07:40 2018 [Windscribe Node Server 4096] Peer Connection Initiated with [AF_INET]107.161.86.131:53
Tue Sep 11 14:07:42 2018 SENT CONTROL [Windscribe Node Server 4096]: 'PUSH_REQUEST' (status=1)
Tue Sep 11 14:07:42 2018 PUSH: Received control message: 'PUSH_REPLY,dhcp-option DNS 10.115.122.1,redirect-gateway def1,rcvbuf 256000,sndbuf 256000,route-gateway 10.115.122.1,topology subnet,ping 5,ping-restart 60,ifconfig 10.115.122.142 255.255.254.0,peer-id 144,cipher AES-256-GCM'
Tue Sep 11 14:07:42 2018 OPTIONS IMPORT: timers and/or timeouts modified
Tue Sep 11 14:07:42 2018 OPTIONS IMPORT: --sndbuf/--rcvbuf options modified
Tue Sep 11 14:07:42 2018 Socket Buffers: R=[163840->327680] S=[163840->327680]
Tue Sep 11 14:07:42 2018 OPTIONS IMPORT: --ifconfig/up options modified
Tue Sep 11 14:07:42 2018 OPTIONS IMPORT: route options modified
Tue Sep 11 14:07:42 2018 OPTIONS IMPORT: route-related options modified
Tue Sep 11 14:07:42 2018 OPTIONS IMPORT: --ip-win32 and/or --dhcp-option options modified
Tue Sep 11 14:07:42 2018 OPTIONS IMPORT: peer-id set
Tue Sep 11 14:07:42 2018 OPTIONS IMPORT: adjusting link_mtu to 1625
Tue Sep 11 14:07:42 2018 OPTIONS IMPORT: data channel crypto options modified
Tue Sep 11 14:07:42 2018 Data Channel: using negotiated cipher 'AES-256-GCM'
Tue Sep 11 14:07:42 2018 Outgoing Data Channel: Cipher 'AES-256-GCM' initialized with 256 bit key
Tue Sep 11 14:07:42 2018 Incoming Data Channel: Cipher 'AES-256-GCM' initialized with 256 bit key
Tue Sep 11 14:07:42 2018 TUN/TAP device tun0 opened
Tue Sep 11 14:07:42 2018 TUN/TAP TX queue length set to 100
Tue Sep 11 14:07:42 2018 do_ifconfig, tt->did_ifconfig_ipv6_setup=0
Tue Sep 11 14:07:42 2018 /sbin/ifconfig tun0 10.115.122.142 netmask 255.255.254.0 mtu 1500 broadcast 10.115.123.255
Tue Sep 11 14:07:42 2018 /sbin/route add -net 107.161.86.131 netmask 255.255.255.255 gw 172.16.18.20
Tue Sep 11 14:07:42 2018 /sbin/route add -net 0.0.0.0 netmask 128.0.0.0 gw 10.115.122.1
Tue Sep 11 14:07:42 2018 /sbin/route add -net 128.0.0.0 netmask 128.0.0.0 gw 10.115.122.1
Tue Sep 11 14:07:42 2018 Initialization Sequence Completed


config openvpn 'Windscribe_VPN'
	option nobind '1'
	option client '1'
	option compress 'lzo'
	option reneg_sec '0'
	option dev 'tun'
	option persist_tun '1'
	option persist_key '1'
	option ca '/etc/openvpn/ca.crt'
	option auth_user_pass '/etc/openvpn/userpass.txt'
	option enabled '1'
	option log '/var/log/openvpn.log'
	option port '53'
	option verb '3'
	option auth 'SHA512'
	option cipher 'AES-256-CBC'
	option remote_cert_tls 'server'
	option tls_auth '/etc/openvpn/ta.key'
	option mute_replay_warnings '1'
	option tls_client '1'
	option tls_version_min '1.2'
	option key_direction '1'
	list remote 'us-central.windscribe.com'
	option proto 'udp'

While connected to winscribe can you ping a website like google.com?

in the diagnostics i can ping google.com and here. Do you think its a firewall thing?

please ping using computer. Open command prompt if using windows and try to ping google.com.

sorry about that... no its just "Request timed out"

Reading your OpenVPN.log the tunnel has come up. But why your not able to use the internet is puzzling.
It could be a firewall issue as you mentioned.

anyway of turning the firewall off or on and allow everything, to see if its that?

Someone may be able to help if you post the contents of /etc/config/firewall/ and /etc/config/network/

I setup my firewall using the GUI. Not much of a user of putty when setting up my router.


config defaults
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	option network 'lan'

config zone
	option name 'wan'
	option output 'ACCEPT'
	option masq '1'
	option mtu_fix '1'
	option network 'wan wan6'
	option input 'REJECT'
	option forward 'REJECT'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option src_ip 'fc00::/6'
	option dest_ip 'fc00::/6'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config include
	option path '/etc/firewall.user'

config include 'miniupnpd'
	option type 'script'
	option path '/usr/share/miniupnpd/firewall.include'
	option family 'any'
	option reload '1'

config zone
	option input 'ACCEPT'
	option output 'ACCEPT'
	option name 'VPN'
	option masq '1'
	option network 'VPN_TUN'
	option forward 'ACCEPT'

config forwarding
	option dest 'lan'
	option src 'VPN'

config forwarding
	option dest 'VPN'
	option src 'lan'



config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdc3:0d70:6435::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option ifname 'eth1'
	option _orig_ifname 'eth1'
	option _orig_bridge 'false'
	option proto 'pppoe'
	option username ''
	option password ''
	option ipv6 'auto'
	option peerdns '0'
	option dns '208.67.222.222 208.67.220.220'

config interface 'wan6'
	option ifname 'eth1'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 5'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6'

config interface 'VPN_TUN'
	option proto 'none'
	option ifname 'eth0'


I have the same issue too! Can't recieve anything, only transmit pockets
VPN

Hey I solved it by installing "DD wrt" but try and set your DNS to Google DNS reboot and should start working see link below

https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316658

uci set network.VPN_TUN.ifname='tun0'
uci commit network
service network restart; sleep 5; service openvpn restart

Hey, I solved it too! The problem was in same subnets for wan and lan (192.168.1.0/24)

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.