OpenVPN Server and LuCi GUI

I've just set up an OpenVPN server following this guide:

Why can't I see it in the GUI (LUCI) under VPN > OpenVPN? I'm sure it's running, as shown by service openvpn info

Did you reboot and cleared your browser cache?

1 Like

Hi again @egc and thanks for your help. Not yet. I can't reboot for now. I'll let you know if it fixes.

I confirm that the VPN server is not visible even opening the GUI after the reboot (no cached)

Is 'luci-app-openvpn' installed?
Look under System>Software>Installed Tab.

If it is, it usually doesn't appear due to some formatting error.

1 Like

Hi, sorry for the late reply. I confirm that I already have luci-app-openvpn (git-24.039.01512-5b2bc99)

I created the server.conf following this official guide There should not be errors, I guess.

Look in /etc/config/openvpn for a line similar to this.

config openvpn 'server'
	option config '/etc/openvpn/server.conf'

Option config 'location of server.conf' file.

Add it to your the openvpn file if it's missing.

See if that solves it.

I can't try because I have switched to Wireguard, but I think that it should be the reason why I couldn't see the entry in LuCi.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.