OpenVpn router tp-link tl-wr940n v6

Hello I have installed openwrt on Router Tp-Link TL-WR940N V.6.
activated the connection from wifi and Lan output I cannot connect it to the Telecom router as a VPN router.
Now doing a test from Diagnostic Navigate, I created the openvpn as in the guides but it does not obscure me the IP is always that of the telephone company.
there is a figurative guide instead of telnet!

Where's this ?

on the router, or on the clients ?

Note, this device will probably have terrible performance running VPN.

the vpn I configured it on a router and a surfshark with its configuration file, it does not exit the router with a different ip and even if I connect with a smartphone in wifi the ip remains unchanged

surely it is the game of ports and firewalls that I did not understand well how to set them since I can not connect it with the lan cable to the main router, my intention was to connect the vpn router wr940n on the tim router with the lan to wap cable but i can't get it to surf, so now it is connected via wifi wifi.

sounds to me they (unintentionally) share the same subnet 192.168.1

the router Tim is but the rauter openwrt that I have prepared I pointed the lan on

same subnet = fail, if you connect LAN (tim) -> WAN (tplink)

in fact tp-link and Tim
but the wan never goes and then anyway now I connected via wifi on the Tim router but I can't change the ip with the vpn

problem is, it's harder to set up the VPN if the traffic doesn't go through the router, but via it.

I also installed the VPN configured with the credentials and everything you need with the file: (openvpn_udp.ovpn) and then the text file (Cred.txt) and inserted under the folder / etc / openvpn /

well, this still apply OpenVpn router tp-link tl-wr940n v6 - #9 by frollic

In a case like this where the OpenVPN client is not also the network's main router, it would need a different setup. Either have a vpnuser network on the client router, or make routes in the main router to send the endpoints' Internet traffic to the VPN machine.

I really can't expect OpenVPN working at all with 32 MB RAM though. You need better hardware.

in fact I find myself in difficulty in configuring the paths to start it is already all installed including server and key of the vpn surfshark

but then why the blue wan port if I connect Tim's router you can't get it to work I have to use wifi connection between the routers

You've already been told why it doesn't work.

solved now the vpn works and changes the ip I remembered that the tp-link even with the original firmware does not allow you to change the ip of the router while openwrt makes you change it but the tp-link hardware I understood that it works with a subnet, so I put the router with qul'ip and now it works I only have the wifi to operate now with masked ip

guys i did night but now my vpn is finally online and especially lan and wifi router

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.