Openvpn recent update 2.4.2 doesn't work with LZO compression

Hi all
I have noticed that somewhere in the recent past, the openvpn-openssl has been upgraded from 2.4.0 to 2.4.2 (openSSL is still 1.0.2k)
Well with the new version I am unable to run a tunnel, tried with x64, arm65, Android beta
The connection is established just fine, no error in the log, but no data pass on the tunnel.
The problem is with the LZO compression, it must be disabled in order to get the tunnel working
Has anything changed that shall reflect some config file change as well?
bye

Not what you asked, but I'm using openvpn-mbedtls and I have LZO enabled.

I'm having the same problem too, it won't work unless I get rid of comp-lzo in my config file

Hi all
the things are getting quite weird
I moved to openvpn-mbedtls, then for some days it work with comp-lzo then usually I get a disconnection and I have to disable comp-lzo.... It works again for some day until I get disconnection and I have to re-enable comp-lzo
The symptoms are the classic of compression mismatch. The connection and TLS autentication is ok, but payload is completely screwed up, including the certificates information exchage.
Does anyone experienced this problem?
Bye

This is my server config file. As you can see i have enabled LZO compression. I use openvpn-openssl and it works just fine. I have routing enabled in client config (which client i want to route through my vpn server) Just the thing is it did not work with this android openvpn https://play.google.com/store/apps/details?id=net.openvpn.openvpn&hl=en
But it worked like a charm on this android app https://play.google.com/store/apps/details?id=de.blinkt.openvpn&hl=en

mode server
tls-server
port 1194
proto udp
dev tun
ca /etc/openvpn/ca.crt
cert /etc/openvpn/server.crt
key /etc/openvpn/server.key
dh /etc/openvpn/dh2048.pem
tls-auth /etc/openvpn/ta.key 0
auth 'SHA256'
cipher 'AES-256-CBC'
tls-version-min 1.0
server 10.8.0.0 255.255.255.0
comp-lzo yes
persist-key
persist-tun
verb 3
mute 20
keepalive 10 120
log-append /tmp/ovpn.log

Last update of openvpn-ssl seems has solved the issue
It works with Android also
Bye

Do you know any andorid app which works with tap bridging openvpn server?
I could not find.

OpenVPN for Android should support it, but you need rooting since tun is not allowed in normal user mode

I have nexus. I have always rooted my phone :smiley:
I do not need tun i need tap mode support from android app.

Sorry I typed the other way around, tap is not supported in non root
Check here:
https://vimeo.com/117085412
But I don't have any clue if it really works