Openssh-sftp-server not working

i've been using the openssh sftp server for a while, it's the first package i install every time i upgrade my lede version so i considered it quite stable :slight_smile:
but recently i've upgraded my 7800 lede (i use hynman builds, as always) and after having installed the sftp server i can't connect to the router
i get a "Received unexpected end-of-file from SFTP server" from filezilla and a "server returned status 127" from winscp
so i tried going back from 82something to 7350 (that i had already used!!) and i can't connect anyway
i really dont know how to debug dropbear - if this is up to it! - so i'm asking your help :slight_smile:
thanks a lot

Unable to reproduce. Worked out of the box with 18.06.1
Suggest that you turn on Debug and Logging in Filezilla and share the output.

Installing openssh-sftp-server (7.7p1-1) to root...
Configuring openssh-sftp-server.
|Status:|Connecting to ...||---|---|
|Status:|Connected to |
|Status:|Retrieving directory listing...|
|Status:|Listing directory /root|
|Status:|Directory listing of "/root" successful|

1 Like

Also possible that either or both the user's shell and home directory don't exist.

well i tried from one of my raspberries to scp-connect to the router, and i got an error linked with server's key.
I suspect it's something linked with the nginx package (with ssl). Can it be?
I'll trying flashing again the firmware and then starting from the sftp server to see if is there any overlapping between packages..
Thanks for confirming that there is nothing new on the package :slight_smile:

mmm still problems.

root@RUTTO:~# opkg install openssh-sftp-server Installing openssh-sftp-server (7.9p1-2) to root... Downloading Configuring openssh-sftp-server.

i see a different version of the sftp server (i'm on master, is this relevant?)

This is the log "filezilla" side, i can't see anything wrong:

|Comando:|open "root@rutto" 22|
|Trace:|Connecting to port 22|
|Trace:|We claim version: SSH-2.0-FileZilla_3.36.0|
|Trace:|Server version: SSH-2.0-dropbear|
|Trace:|Using SSH protocol version 2|
|Trace:|Doing ECDH key exchange with curve Curve25519 and hash SHA-256|
|Trace:|Host key fingerprint is:|
|Trace:|ssh-rsa 2048 64:c3:5b:d9:de:3a:4b:8b:59:f0:f0:ac:3d:ab:13:8f NUXPFF7qP5JQqjFr+5OD9Zyb+tsYEaLs/SiF+lvLHOQ=|
|Comando:|Conferma nuova chiave host: Una volta|
|Trace:|Initialised AES-256 SDCTR client->server encryption|
|Trace:|Initialised HMAC-SHA-256 client->server MAC algorithm|
|Trace:|Initialised AES-256 SDCTR server->client encryption|
|Trace:|Initialised HMAC-SHA-256 server->client MAC algorithm|
|Comando:|Pass: *********|
|Trace:|Sent password|
|Trace:|Access granted|
|Trace:|Opening session as main channel|
|Trace:|Opened main channel|
|Trace:|Started a shell/command|
|Stato:|Connected to rutto.lan|
|Errore:|Received unexpected end-of-file from SFTP server|

Lede side, i can't see any error in logread

Thu Oct 25 21:21:45 2018 dropbear[6642]: Child connection from
Thu Oct 25 21:21:45 2018 authpriv.notice dropbear[6642]: Password auth succeeded for 'root' from
Thu Oct 25 21:21:45 2018 dropbear[6642]: Exit (root): Exited normally

but i feel i miss something.. is there a sftp server listening?

Please describe how you set up ECDH key exchange with curve Curve25519 on client and server

The fact that the exchange has proceeded through password authentication strongly suggests that encryption is working. Does dropbear support sftp? I've always replaced dropbear with the OpenSSH server so I can't comment or verify.

Sadly, i have totally no idea :frowning:
it used to work just "opkg installing" the package openssg-sftp-server
nothing more
nothing less
What did i miss this time?

isn't the openssh sftp server the one i installed?