OpenDNS ignored?

Yesterday I configure the router (17.1.4 Acher C7v2) with OpenDNS and Gogle on WAN interface, here is the config:

config interface 'wan'
	option ifname 'eth0'
	option proto 'dhcp'
	option peerdns '0'
	option dns ''

But when testing config (DHCP client on LAN side) with this page, 23/5000
I see that I'm not using OpenDNS. Maybe I'm resolving with google ( and and list order is ignored by Lede? How can I test what DNS I'm using?


That only works if your clients use the LEDE router as a DNS; by default, LEDE will announce itself as a DNS for the DHCP clients, but most Android devices ignore that information, and use always Google's DNS. If that is the case here, then you have to redirect all DNS traffic, and send it to the LEDE device.

Thanks for the reply.
Clients are configured to use router as DNS, but check page is still failing.
I didn't know Android devices uses Google DNS directly, but I tested from my Ubuntu laptop and it fails too.

I'll try to do a packet capture on WAN interface and look where DNS packet are going to.

Try to enable "Strict order" for dnsmasq. That should make sure the DNS servers are queried in the order you specified in the config file.