Only 2.4GHz band works on Linksys WRT32X

I am new to OpenWRT. I have a Linksys WRT 32x. I installed the firmware from the list found on the site. I can access Wi-Fi, however, I can only get the 2.4 band to work and not the 5G bands. radio 0 and 2 are in-op. They don't show up on any Wi-Fi scans.

Marvell 88W8964 802.11nac
Channel: ? (5.000 GHz) | Bitrate: ? Mbit/s

Marvell 88W8964 802.11bgn
Channel: 6 (2.437 GHz) | Bitrate: 72.2 Mbit/s

Marvell 88W8887 802.11bgnac
Channel: ? (? GHz) | Bitrate: ? Mbit/s

is there a package that I can add to make these radios operable? with the factory firmware, the 5g was working with my devices.

Thank you for your assistance!

Disable radio2 88W8887. It is quite separate (and probably originally not meant for actual usage).

Make sure to select legal wifi channels for radio0.

Check you system log for error messages after you run "wifi up" on ssh console. Maybe you have selected something invalid in wifi config for radio0 or its wifi networks.

1 Like

use putty to ssh into console?

is "wifi up" the command at the console?

1 Like

Yes / whichever ssh terminal you like.

1 Like

Thank You! I will try that!

1 Like

I was able to ssh into console. Typed "wifi up". I also disabled radio2. Selected the proper country code. Checked for log error messages. rechecked and played with different configs for both radio's 0 & 1. I still can't get radio 0 to show up on a scan. I changed the two radio SSID's to SSID name 2.4g and 5g respectively. Radio 0 is 5g and radio 1 is 2.4g.

There are radio icons next to the radio names on the wireless overview

image radio1

radio1 is the radio that is working, 2.4GHz band. The icon is different.
had to remove 2 icons, new user, will upload in a reply

On device configuration screens it says both wireless networks are enabled.
This maybe true, but the 5 GHz network is not showing up.

Any thoughts?

radio 0 and radio 2 have this icon next to them.

I solved it.

at command line ran, used "opkg" to update and do upgrades.

then, adjusted the settings (thank you hnyman!)

Found that the channel setting "auto" doesn't work well, and needed to set to a specific channel (that was stable, 157) and to a width (80mhz) that it liked, as well as make sure it was the correct country (it was).

Found that not all the settings are proper or liked by the router hardware that are offered by the firmware possibly as an explanation?

Then as the documentation explained, waited for the signal, weather channel link?

This is new to me, so thank you. hope this helps someone else.

Just a thought, but how many more “I used ‘auto’ channel setting and it didn’t work” threads do we need before something gets mentioned in the wiki or an FAQ. Same thing for DFS.

Maybe Luci needs a change to drop this option.

nice :slight_smile: what is DFS by the way just so I know hahaha

Help please.

So I installed OpenWrt 18.06.4 r7808-ef686b7292 to linksys wrt 32X, the luci interface looks fine.

I haven't done any demon tweaks, just added SSL in luci.

I'm in London so the router is set to GB (out of the box it was DE but I don't want to breach any regulations).

After a solid week of reading openwrt and other documentation, I found this thread.

After reconfiguring the wifi countless times, I have managed to get a wireless N signal up on radio1 channel 11 (2462 MHz) width 20 MHz.

The coverage on openwrt router is shown on a wifi analyzer as dwarfed by my old TP-Link on stock firmware.

I daren't experiment with radio1 any more because I need at least 1 WiFi up.

The 5 GHz channel on Radio0 did come up briefly at one stage but I didn't note the settings because I wasn't expecting such problems, now it's dead 0% and I believe I have tried every possible setting, including auto.

Radio2 is also reporting dead 0% and I have read various posts to the effect that it is (a) redundant and can be removed, (b) has no ariel, and (c) is required by the 5GHz channel to scan weather networks & ensure regulatory compliance, so I left it on, dead.

Can you offer any advice please?

Can someone please recommend specific settings for my situation to gain optimum performance from this router?

If you are flash openwrt from oem firmware,and first launch,you should do a reset,and then,all will be well,at least in my condition,the problem has be solved.