Onhub TP-LINK TGR1900 future support?

could you please point me to the link for the ath10k-firmware-qca988x firmware? I tried updating using the luci interface but it says the pkg I used is not compatible with the architecture. I would like to get the mesh running

Hi

I found it the from the link below

However it has issues

  1. Mesh performance is really poor
  2. AP is rebooted randomly.

So it is not pratical to use these firmwares

Hopefully someone will come up with better solutions to create mesh

Thank you

HI

Thank you for your response. I found another file at https://openwrt.org/docs/techref/instructionset/arm_cortex-a7_neon-vfpv4

However, I have 2 onhubs and the specs are exactly the same. This firmware worked on one by upload through luci and mesh was enabled. I did not remove the ath10k-firmware-qca988x-ct However, on the other onhub, on upload it gives the error "ath10k-firmware-qca988x-ct already present on root". If I remove the latter, the ath10k-board-qca988x which is already installed also gets removed and then I cannot install ath10k-firmware-qca988x . Still playing around with these to see if I can get it installed. Would you like to try the firmware from the above link and see if it improves your mesh performance?

were you able to get the boot process video together? also i just had an aneurism trying to read your code on github so if anyone knows where i can find a link to an iso i can just flash to disk utility and get this router up and running again that would be much appreciated

jkjkjk im meming about aneurysm oop tsym

stonics has given an image above and the complete process. There is a boot video ealier which can be followed for the first 3.5 minutes or so

Could somebody help with TP-Link Onhub (TGR1900)?

When I try to:

ssh root@192.168.1.1 -C "dd if=/dev/zero bs=512 seek=7552991 of=/dev/mmcblk0 count=33 && \
dd if=/root/openwrt-ipq806x-chromium-tplink_onhub-squashfs-factory.bin of=/dev/mmcblk0"

I always get:

33+0 records in
33+0 records out
dd: error writing '/dev/mmcblk0': No space left on device
1025+0 records in
1024+0 records out

Please help

I was having trouble with that in a different way. I used WinSCP to transfer the file (openwrt-ipq806x-chromium-tplink_onhub-squashfs-factory.bin) to the /tmp folder on the device and then in ssh (using putty) just sent the command:

dd if=/dev/zero bs=512 seek=7552991 of=/dev/mmcblk0 count=33 &&
dd if=/tmp/openwrt-ipq806x-chromium-tplink_onhub-squashfs-factory.bin of=/dev/mmcblk0

and it worked for me. If I remember correctly the last two in and outs are 256 or so not 1024,1025.

I do the same from Linux terminal, but output the same on two different TP-Link onhub.

Could you install and run lsblk and send me the output from it? This will list the storage devices and the amount of space that it has. There are 2 flash chips in the onhub, one of which is used by the bootloader and not writeable normally.

ssh into the onhub as root

opkg update
opkg install lsblk
lsblk

here you go:

root@OpenWrt:~# lsblk
NAME      MAJ:MIN RM  SIZE RO TYPE MOUNTPOINTS
loop0       7:0    0  3.4G  0 loop /overlay
sda         8:0    1 58.6G  0 disk 
├─sda1      8:1    1  128M  0 part 
└─sda2      8:2    1  3.4G  0 part /rom
mtdblock0  31:0    0    8M  0 disk

That's not what I get.

NAME         MAJ:MIN RM  SIZE RO TYPE MOUNTPOINTS
loop0          7:0    0  3.4G  0 loop /overlay
mtdblock0     31:0    0    8M  0 disk 
mmcblk0      179:0    0  3.6G  0 disk 
├─mmcblk0p1  179:1    0  128M  0 part 
└─mmcblk0p2  179:2    0  3.4G  0 part /rom
mmcblk0boot0 179:16   0    2M  1 disk 
mmcblk0boot1 179:32   0    2M  1 disk 

Idk why but I can't write into mmcblk0

The output from @dadogroove is what I would expect. mmcblk0 is the writeable flash module. Not sure why it is not visible for you. Could you flash back to the stock firmware from google and try to install openwrt again? The instructions for factory reset are there in the wiki too.

Maybe do a factory reset as described on the hardware page and try again.

Hi I have tried the non-ct one from the link. Pretty much same result, poor wifi throughput performance and random reboot

Thank you

Poor throughput will not get better until both cpus are working. It is mentioned above that 1 of the cpus is disabled. This is still very much a work in progress.

I fixed the multi-CPU issue a while back, so I've pushed my latest to Github again. It also improves compatibility with the non-ct driver (note: driver, not firmware), since the calibration data only worked with the CT driver before. As far as I know, this is what will eventually be committed to the official tree.

I'm less sure about mesh issues, although I do believe I've had better luck with the non-ct driver and firmware. At least, my mesh (ASUS OnHub + Google WiFi) gets the same Internet throughput as my non-Openwrt mesh does.

1 Like

Thanks. Making a new build now to try. When I've upgraded using the generated sysupgrade file, the configurations are not saved even if I select them to be saved. Once I upload my saved configuration file it all comes back. Is this just how it is for now? Thanks for all the work on this.

I've had trouble too, so I updated the setup to use a 3-partition layout in the latest, where the 3rd partition stores the configuration data (and other writable storage). Hopefully this approach is less susceptible to sysupgrade loss/corruption. It also should obviate the need for the resize2fs instructions that somebody else wrote up.

The 2-partition setup should be able to work too, but I haven't spent much time learning/debugging the openwrt sysupgrade process, and it feels like its block (i.e., not raw NAND flash) storage support is a bit weak.

Ok. No joy then. Will stick with a wired AP. Thank you