Onemore IPTV issue

Hello,

I'm using Croatian telecom as ISP in Croatia
they have a setup with vlan 100 as internet access and vlan 1500 as iptv access.
I use apu3c4 so x86 version of openwrt, version 19.07.7

This is my config:
NETWORK:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '192.168.100.1'
	list dns '192.168.100.50'
	list dns '192.168.100.25'
	option delegate '0'

config interface 'GUEST'
	option ifname 'br-lan.10'
	option proto 'static'
	option ipaddr '192.168.10.1'
	option netmask '255.255.255.0'

config interface 'IOT'
	option ifname 'br-lan.20'
	option proto 'static'
	option ipaddr '192.168.20.1'
	option netmask '255.255.255.0'

config interface 'WAN'
	option ifname 'eth0.100'
	option proto 'pppoe'
	option password 'XXXX'
	option ipv6 'auto'
	option username 'XXXX@htnet-dsl'

config interface 'IPTV'
	option ifname 'eth0.1500 eth2.1500'
	option proto 'none'
	option igmp_snooping '1'
	option type 'bridge'

IGMPROXY:

config igmpproxy
	option quickleave 1

config phyint
	option network IPTV
	option zone wan
	option direction upstream
	list altnet 0.0.0.0/0

config phyint
	option network LAN
	option zone lan
	option direction downstream

Nothing for IPTV in firewall

Anyway - i had no luck setting up iptv. internet works flawlessly.

setup is on apu:
ONT is connected to eth0
LAN is connected to eth1
IPTV is connected to eth2

Thanks in advance

(i'm new in openwrt but seasoned linux user)