One Port Pass Through to ISP Router

Never mind, bought a 5€ switch no need to lost hours with endless useless configs

Delete Please

I tried add

    config interface 'TV'
    option proto 'none'
    option device 'lan3'

Remove the lan3 from config a give an manual IP to the TV in the ISP Router Range

None works

Bridge wan and lan3.

2 Likes

That makes sense delete every config for test and try this

config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option packet_steering '1'

config interface 'wan'
option device 'wan'
option proto 'dhcp'
option 'ifname' 'eth0'
option 'bridge' 'br-wan'

config interface 'wan6'
option device 'wan'
option proto 'dhcpv6'

config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '168.192.2.1'
option netmask '255.255.255.0'
option ip6assign '60'
option ipv6 '0'

config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'

config interface 'TV'
option 'type' 'bridge'
option 'ifname' 'eth0 eth3'
option 'proto' 'none'
option 'bridge' 'br-wan'

config device
option name 'br-TV'
option type 'bridge'
list ports 'lan3'

make a device br-wan and include wan and lan3 as its ports.

config device
    option name 'br-wan'
    option type 'bridge'
    list ports 'wan'
    list ports 'lan3'

Remove lan3 from any other bridges or interfaces so it is used only for the wan bridge.
Change the Device of the wan (and wan6 if applicable) network interface(s) from wan to br-wan. There is no need to create a new interface. The TV packets should switch by hardware between the two ports and there is no need for OpenWrt to process anything TV related.
If TV does not work it is possible the TV box uses VLANs to communicate with the ISP modem or ONT. This can be investigated by looking for other people's experience with the particular ISP or sniffing the packets that the TV box sends.

3 Likes
  • You failed to remove the old wan config
  • You never setup br-wan to be DHCP client
  • You attempted to add lan3 to an additional bridge named wan6 - this is incorrect
1 Like

Delete this:

Change the device in these two stanzas to br-wan

1 Like

Your br-wan is correct. Remove br-wan6. Both IP families can go through the same bridge. This is done by making br-wan the Device of Interfaces wan and wan6.

In the above, change both devices from wan to br-wan.

1 Like