Odhcpd failed to send to ff02::1

I have IPv6 disabled on my devices and my system log seems to be getting spammed with messages like:

Tue Aug 31 16:48:47 2021 daemon.err odhcpd[1138]: Failed to send to ff02::1%lan@br-main.1 (Permission denied)
Tue Aug 31 16:53:39 2021 daemon.err odhcpd[1138]: Failed to send to ff02::1%lan@br-main.1 (Permission denied)
Tue Aug 31 16:53:55 2021 daemon.err odhcpd[1138]: Failed to send to ff02::1%lan@br-main.1 (Permission denied)
Tue Aug 31 16:54:11 2021 daemon.err odhcpd[1138]: Failed to send to ff02::1%lan@br-main.1 (Permission denied)
Tue Aug 31 16:54:27 2021 daemon.err odhcpd[1138]: Failed to send to ff02::1%lan@br-main.1 (Permission denied)

Googling showed several hits but I didn't find a root cause. Any thoughts are appreciated.

  • This suggests to delete the IPv6 ULA-Prefix from /etc/config/network but that has no effect. Still getting the spammed messages.
/etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'

config device
	option name 'br-main'
	option type 'bridge'
	list ports 'eth0'
	option ipv6 '0'

config interface 'lan'
	option proto 'static'
	option ipaddr '10.9.7.1'
	option netmask '255.255.255.0'
	option device 'br-main.1'

config interface 'wan'
	option proto 'dhcp'
	option peerdns '0'
	option delegate '0'
	list dns '1.1.1.1'
	list dns '1.0.0.1'
	option device 'br-wan'

config bridge-vlan
	option device 'br-main'
	option vlan '1'
	list ports 'eth0'

config bridge-vlan
	option device 'br-main'
	option vlan '3'
	list ports 'eth0:t'

config device
	option name 'br-main.1'
	option type '8021q'
	option ifname 'br-main'
	option vid '1'
	option ipv6 '0'

config device
	option name 'br-main.3'
	option type '8021q'
	option ifname 'br-main'
	option vid '3'
	option ipv6 '0'

config device
	option type 'bridge'
	option name 'br-wan'
	list ports 'eth1'
	option ipv6 '0'

config interface 'guest'
	option proto 'static'
	option device 'br-main.3'
	option ipaddr '172.16.1.1'
	option netmask '255.255.255.0'
	list dns '1.1.1.1'
	list dns '1.0.0.1'

config interface 'wg0'
	option proto 'wireguard'
	option private_key 'xxx'
	option listen_port '51820'
	list addresses '192.168.9.1/24'

config wireguard_wg0
	option description 'me'
	option public_key 'xxx'
	list allowed_ips '192.168.9.2/32'
	option route_allowed_ips '1'
	option preshared_key 'xxx'

config device
	option name 'wg0'
	option ipv6 '0'

config device
	option type 'bridge'
	option name 'br-guest'
	list ports 'br-main.3'
	option ipv6 '0'

config interface 'LXCGUEST'
	option device 'br-guest'
	option proto 'static'
	option ipaddr '10.0.4.1'
	option netmask '255.255.255.0'
	option auto '0'

config device
	option name 'eth0'
	option ipv6 '0'

config device
	option name 'eth1'
	option ipv6 '0'

2 Likes

Do you want to disable DHCPv6, then maybe you shouldn't run odhcpd?

2 Likes

Yes, pure IPv4 here. I thought odhcpd was the dns server for both IPv4 and IPv6. If I disable it, what do you recommend to server up IPv4?

Dnsmasq is used for IPv4. And it's odhcpd-ipv6only that's installed by default and not odhcpd which supports both protocols.

4 Likes

Thanks. Disabling it solved this issue.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.