NWA50AX Pro eth0 disconnections

Hello,
I'm experiencing a bug similar to this:

I tried with:

ethtool -s eth0 autoneg off speed 1000 duplex full

but if I disable autoneg the link becomes half duplex...

1 Like

@rainkinz can you confirm that in your case the link stays full duplex after disabling autoneg? Are you on 23.05.03 ?

Hi @Documibozu,

It actually reports half duplex after doing autoneg off:

root@Office:~# ethtool -s eth0 autoneg off speed 1000 duplex full
root@Office:~# ethtool eth0
Settings for eth0:
        Supported ports: [ ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
                                2500baseT/Full
        Supported pause frame use: Symmetric Receive-only
        Supports auto-negotiation: Yes
        Supported FEC modes: Not reported
        Advertised link modes:  1000baseT/Full
        Advertised pause frame use: Symmetric Receive-only
        Advertised auto-negotiation: No
        Advertised FEC modes: Not reported
        Speed: 1000Mb/s
        Duplex: Half
        Port: Twisted Pair
        PHYAD: 5
        Transceiver: external
        Auto-negotiation: off
        MDI-X: Unknown
        Current message level: 0x000000ff (255)
                               drv probe link timer ifdown ifup rx_err tx_err
        Link detected: yes

But full duplex with autoneg on:

root@Office:~# ethtool -s eth0 autoneg on speed 1000 duplex full
root@Office:~# ethtool eth0
Settings for eth0:
        Supported ports: [ ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
                                2500baseT/Full
        Supported pause frame use: Symmetric Receive-only
        Supports auto-negotiation: Yes
        Supported FEC modes: Not reported
        Advertised link modes:  1000baseT/Full
        Advertised pause frame use: Symmetric Receive-only
        Advertised auto-negotiation: Yes
        Advertised FEC modes: Not reported
        Speed: Unknown!
        Duplex: Half
        Port: Twisted Pair
        PHYAD: 5
        Transceiver: external
        Auto-negotiation: on
        MDI-X: Unknown
        Current message level: 0x000000ff (255)
                               drv probe link timer ifdown ifup rx_err tx_err
        Link detected: no

Thanks, after a reboot the AP seems to be stable with autoneg on.
Better hope it's not a cable fault 'cause it's a 15mt cable in a wall conduit :cold_sweat:

1 Like

I doubt it is. I have tried several cables and get disconnects unless I do:

ethtool -s eth0 autoneg off speed 1000 duplex full

Which sadly seems to also set it to half duplex.

Sadly I can confirm that every 4-6 hours eth0 has a glitch and the cable is not the problem (tried with a proven cable of only 1mt length).
Now i'll try to test @rainkinz solution for some days and check if it's stable.

@rainkinz sorry to bother you again.
I don't want to giveup on full duplex and I'm doing some tests.
So a little question: are you powering your AP with POE or are you using the 12volt plug?
Thanks again