NTP issues on a dumb AP configuration

Does anybody else run this as an AP and have issues with the system time not getting synced with the main router / NTP servers? I've been pretty happy with stability and performance in general but have had a few wifi connection issues. When I log into the device the system time always seem to be a few days behind and I need to sync it manually to get it back on track.

Have you checked your setup with:

Especially gateway and DNS settings?

1 Like

I've followed the guide but set mine up as dhcp client and give it a fixed ip address in the main router. DNS and gateway uses defaults as advertised via dhcp.

I guess the unused 'wan' port is also configured as dhcp client and maybe that causes confusion? I've deleted 'wan' for now and will keep an eye on things to see if it still causes issues.

No issues here on many devices.

Yea, I assume thos means you edited the LAN interface to DHCP client- that works.

As long as I didnt connect anything to WAN, I've never had to delete the Interface to use the gateway on LAN.

Glad you got it working.

I've just checked the time on my AP and it had drifted by 3 days so the issue persists. I've now changed my router to advertise NTP via dhcp using 'advanced settings' DHCP-options:

 42,192.168.1.1

and then set my AP to use NTP as advertised by DHCP. I'll check in a few days to see if this helps.

If you run the following from your AP, do you see any errors?

/usr/sbin/ntpd -dnN -p 192.168.1.1

It should execute four times and then pause. You can CTRL+C at that point.

So far with dhcp advertised time I've not seen any drift on my AP but I'll keep an eye on it over the next few days.

When I execute your command I just get a whole bunch of timed out queries.

ntpd: timed out waiting for 192.168.1.1, reach 0x00, next query in 2s

I have this issue as well on my access points, and when executing the ntpd command I also got

ntpd: sending query to 192.168.0.1
ntpd: timed out waiting for 192.168.0.1, reach 0x00, next query in 2s

image

Screenshot from 2023-05-06 13-58-21

My config is dumb AP, added main router IP (192.168.1.1) and all works fine:

ntpd: sending query to 192.168.1.1
ntpd: reply from 192.168.1.1: offset:-0.004850 delay:0.003834 status:0x24 strat:2 refid:0xc1cc72e9 rootdelay:0.023270 reach:0x01

Hope this helps

1 Like

Is there an ntpd on 192.168.0.1 ?

1 Like

I'm glad it seems to be working for you still. Though I still suspect something is not quite right with your NTP connectivity.

Option 42 in DHCP only says "Hey, here is the server to which your NTP client can speak 'NTP'..." But according to your ntpd query, 192.168.1.1 appears to be either 1) not running an NTP service or 2) is running an NTP service, but is unreachable due to, perhaps, a firewall block. (??)

May be worth doing more investigation on your side to get that sorted, especially if you truly intend for your main router to be serving up NTP.

A few things you could try to help isolate the issue would be to check the result of this command:
/usr/sbin/ntpd -dnN -p 0.openwrt.pool.ntp.org

Also, confirm the "Provide NTP server" box is checked on your Time Synchronization settings on your router (192.168.1.1). Can be confirmed with:

# uci show system.ntp
system.ntp=timeserver
system.ntp.enabled='1'

I also had this issue however Netgate 2100-MAX provides authenticated NTP services so I had to just delete the auto populated information and add in the main router/firewalls ip address that fixed it.

This way my firewall can still manage Authenticated NTP and it syncs up