Nslookup failing with "Can't find google.com Parse error"

Hello all,

I am facing a problem where nslookup is failing with a "Can't find google.com Parse error" can anyone please enlighten me what is the reason to this.

Dnsmasq service is turned on.

/etc/config/network output

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdd8:aa9a:f4f4::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option dns '8.8.4.4 8.8.8.8'

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr '78:a3:51:7a:c0:9a'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'
        option force_link '1'
        option peerdns '0'
        option dns '8.8.8.8'

config device 'wan_dev'
        option name 'eth0.2'
        option macaddr '78:a3:51:7a:c0:9b'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6t'

config interface '4g'
        option ifname 'eth1'
        option proto 'dhcp'
        option peerdns '0'
        option dns '8.8.8.8'

etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '0'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option localservice '0'
        option logqueries '1'
        list server '8.8.4.4'
        list server '8.8.8.8'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra 'server'
        list dhcp_option '8.8.8.8,8.8.4.4'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'
nslookup openwrt.org
nslookup openwrt.org 127.0.0.1
nslookup openwrt.org 8.8.8.8
nslookup openwrt.org 1.1.1.1
head -n -0 /etc/resolv.* /tmp/resolv.*
root@LEDE:~# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
64 bytes from 8.8.8.8: seq=0 ttl=110 time=385.880 ms
64 bytes from 8.8.8.8: seq=1 ttl=110 time=375.100 ms

--- 8.8.8.8 ping statistics ---
2 packets transmitted, 2 packets received, 0% packet loss
round-trip min/avg/max = 375.100/380.490/385.880 ms
root@LEDE:~#
root@LEDE:~#
root@LEDE:~# nslookup openwrt.org
Server:         8.8.8.8
Address:        8.8.8.8#53

Name:      openwrt.org
Address 1: 192.168.1.1
*** Can't find openwrt.org: Parse error
root@LEDE:~#
root@LEDE:~#
root@LEDE:~# nslookup openwrt.org 127.0.0.1
;; connection timed out; no servers could be reached

root@LEDE:~# nslookup openwrt.org 8.8.8.8
Server:         8.8.8.8
Address:        8.8.8.8#53

Name:      openwrt.org
Address 1: 192.168.1.1
*** Can't find openwrt.org: Parse error


root@LEDE:~# nslookup openwrt.org 1.1.1.1
Server:         1.1.1.1
Address:        1.1.1.1#53

Name:      openwrt.org
Address 1: 192.168.1.1
*** Can't find openwrt.org: Parse error
root@LEDE:~#
root@LEDE:~#
root@LEDE:~# head -n -0 /etc/resolv.* /tmp/resolv.*
==> /etc/resolv.conf <==
nameserver 8.8.8.8

==> /tmp/resolv.conf <==
search lan
nameserver 127.0.0.1

==> /tmp/resolv.conf.auto <==
# Interface 4g
nameserver 8.8.8.8
# Interface lan
nameserver 8.8.4.4
nameserver 8.8.8.8

It's either wrong MTU, or the ISP uses DNS hijacking.

You have the following options:

In addition, you can provide custom DNS with DHCP.

dnsmasq is configured and running

head -n -0 /etc/resolv.* /tmp/resolv.*
==> /etc/resolv.conf <==
nameserver 8.8.8.8

==> /tmp/resolv.conf <==
search lan
nameserver 127.0.0.1

==> /tmp/resolv.conf.auto <==
# Interface 4g
nameserver 8.8.8.8
# Interface lan
nameserver 8.8.4.4
nameserver 8.8.8.8

A ping request to 8.8.8.8 is fine but the one to google.com doesnot go through rather it sends to the local br.lan interface ... so its like
when I do a traceroute to 8.8.8.8 I could see the hops etc but when I do the same to google.com its going to the br.lan interface which is 192.168.1.1 and then stopping there itself ... can you please tell me what is happening here ?

And also please see this, do you see anything unusual

/etc/init.d/dnsmasq restart
udhcpc: started, v1.26.2
udhcpc: sending discover
udhcpc: no lease, failing

Same for nslookup .... it goes to 192.168.1.1

root@LEDE:~# nslookup openwrt.org
Server:         8.8.8.8
Address:        8.8.8.8#53

Name:      openwrt.org
Address 1: 192.168.1.1
*** Can't find openwrt.org: Parse error

This looks like an obsolete version.
Can you upgrade to the latest stable OpenWrt release?