Not sure why my Linksys WRT3200ACM Wi-Fi range is worse than my old TL-WR1043ND v1

I've been using a TL-WR1043ND v1 with OpenWRT installed for years. It was configured as a bridged access point. My only complaint from it was the lack of 5GHz but I can't really blame it for that since it's so old.

So I decided to upgrade to the Linksys WRT3200ACM since it has good support with OpenWRT. I've configured it exactly the same as the previous router. It's in the exact same spot.

Unfortunately, the Wi-Fi range is really bad. The 5GHz radio cuts out with just one thin wall, which I can live with. The main problem is that even the 2.4GHz radio cuts out in places where I use to get nearly full bars with the TL-WR1043ND v1.

I am in the UK so TX power is limited by law, but I doubt this is the culprit since both routers were configured to comply.

I've had a look through the forum and know not to use the third radio. I have the 'Marvell 88W8964' running 5GHz (13 dBm), the 'Marvell 88W8964' running 2.4GHz (20 dBm) and the 'Marvell 88W8887' disabled. There is some cogestion in my area, but no amount of changing to quieter channels seems to help. I'm running OpenWrt 19.07.3 r11063-85e04e9f46.

Not sure why it's underperforming so much? Tempted to revert to stock to see if it's a hardware or OpenWRT issue.

Just tried to set the 5GHz radio to channel 100 as reccomended on some other threads and rebooted. The radio wouldn't even switch on. Tried to revert the settings to how they were previously set and even after a reboot it's still saying it's not associated.

I've seen some rumblings on the forums and elsewhere that there are issues with the UK variant of the WRT3200ACM. Is this correct?

if you have the euro version of the device set, leave contry code to france.
from the web interface, delete the firmmware and driver of the radio number tree, set channel 100 and reboot. remember that dfs channels need a bit of time to come up.

Is the firmware and driver for radio 3 "kmod-mwifiex-sdio" and "mwifiex-sdio-firmware"?

yes right that

That managed to get the 5GHz radio to 26dBm (though I kept the country code to GB), but the 2.4GHz is at 20dBm is that the expected power?

yes that is normal.
for 5ghz you should get 27 dbm

You cannot override the settings taken from embedded power table, may as well not set

cat /sys/kernel/debug/ieee80211/phy0/mwlwifi/info

power table loaded from dts: no

Not sure if your replying to bricco1981 or me. Yes, "power table loaded from dts" is set to "no" on my router.

You cannot override the settings taken from the embedded data, so pointless to set the CC (which can actually end up causing you grief, especially in conjunction with the 3rd radio (which appears you have removed)), or the radio TX power which will be ignored. In the EU maybe this might help, depending on your client CC...

anyway i was never a fun of this 2.4ghz radio, i'm an ath9k fun, but the 5ghz radio is working very well on wrt 3200 acm

It's odd. I've found that 2.4GHz is better at night than day. Starting to wonder if it might be interference from my neigbours, there's about 13 different access points competing on 2.4GHz. 5GHz is great, but not so great when your walls are made of stone.

Definitely wish I had checked the driver used. Is there a list of ath9k devices supported by OpenWRT?

your old tplink is an ath9k device, but the problem with ath9k is not for high speed internet.
i still don't care, i have one mwlwifi device, one ath10k device, one mt76 device, and over 20 ath9k devices.

We have multiple devices and a recent WRT3200ACM UK also. Found the 5 Ghz radio to be excellent with connection speeds following scans with wifi analyser app we set it on channel 116 there was nothing else close on that channel. Very stable. If in the same room then essentially 880+Mbps upstairs 350-500Mbps.

Much faster than the Archer A7 1750 V5 which is in a different part of the property.

Are you running the official 19.07.3 or one of David's builds?


1 Like

I'm running the official builds but I've not tested David's builds yet.

I tried both and the official build works perfectly so decided to stick with that.