Not getting max download speed

I just installed LEDE Reboot 17.01.4 on my Archer C2600 and everything seems to be working fine except I'm only getting about half of my expected download speed from my ISP. Before I was getting close to 300Mb/s and now I'm only getting about 150Mb/s. Is this a known bug?

Wired or wireless?

Are you using SQM?

Wired. Not using SQM. I ran this from the router itself.

root@LEDE:/usr/lib/OpenWrtScripts# sh betterspeedtest.sh -t 30
2018-01-07 06:08:05 Testing against netperf-west (ipv4) with 5 simultaneous sessions while pinging gstatic (30 seconds in each direction)
................................
Download: 147.45 Mbps
Latency: (in msec, 29 pings, 0.00% packet loss)
Min: 11.575
10pct: 13.134
Median: 17.615
Avg: 25.788
90pct: 30.545
Max: 178.281
...............................
Upload: 21.62 Mbps
Latency: (in msec, 28 pings, 0.00% packet loss)
Min: 60.622
10pct: 77.323
Median: 99.506
Avg: 100.541
90pct: 121.655
Max: 150.573
root@LEDE:/usr/lib/OpenWrtScripts#

Let's see what your network config looks like...

cat /etc/config/network

To confirm, you installed the stable release from here...

https://lede-project.org/toh/views/toh_fwdownload?dataflt[Model*~]=c2600

...and you used the squashfs-factory.bin to go from stock to LEDE.

While you're at it, run dmesg also and let's see what that looks like as well.

Yeah I installed lede-17.01.4-ipq806x-C2600-squashfs-factory.bin.

root@LEDE:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd0a:3aeb:f7aa::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '10.10.1.1'

config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'
        option peerdns '0'
        option dns '208.67.222.222 208.67.220.220'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 6'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 0'

dmesg - https://pastebin.com/Zu13PynL

Do you have a cable modem bridged to the C2600?

Is DHCP turned off on the modem?

Yeah I have the ARRIS SURFboard SB6190 DOCSIS 3.0 Cable Modem. I don't believe it has DHCP at all.

There has been some discussion on the forums about C2600 performance...

https://forum.openwrt.org/search?q=c2600

Thanks a lot for the help. Is there a list of good wireless routers for OpenWRT/LEDE? I push a decent amount of traffic so I want it to be powerful.

See this video on putting an ARRIS cable modem in bridge mode...may not be possible with a SURFboard SB6190 DOCSIS 3, but look for similar settings.

There is this...

https://lede-project.org/toh/views/toh_available_864_ac-wifi

1 Like

Thanks again.

In addition to the link posted by jwoods:

I have the C2600 and a 250/250 connection, it's doing full speed (through wireless) without even breaking a sweat. I'm also seeing record numbers with the OpenSSL speed test. This is easily one of the more powerful routers out there if not the latest and greatest.

https://altibox.speedtestcustom.com/result/3ac501c0-f3b1-11e7-878d-c13435a5e357

Mem: 95652K used, 385604K free, 6036K shrd, 5852K buff, 24612K cached
CPU: 0% usr 4% sys 0% nic 55% idle 0% io 0% irq 38% sirq

I am even measuring 54Mbps upload through OpenVPN with my iPhone.

There, now you can go back to troubleshooting the actual problem instead of thinking about getting a new router.

1 Like

Ok sweet thanks. I wonder what it could be. What build are you using?

I'm building the latest from git with gcc7 and -O2. Compiler optimizations shouldn't count for such difference but I guess it's worth trying a development snapshot to get a more recent kernel.

I was going to flash a snapshot because I heard the rebooting bug is fixed. I'll try that. I'm getting close to 200 now but before I was getting 300+. I've tested at different times of day and made sure there is no real load on the router.

How did you pull that info? Is there a command?

The command is top

1 Like