Not getting IP Address for ISP

Hi

I am based in New Zealand and just installed OpenWRT on a x86-64 (22.03.5 build) fanless PC with four Intel NICs. Three of them are configured for LAN and one for WAN. I am new to openwrt and not that technical so please bear with me.

The ISP Fibre Configuration is listed here -

and I made changes to the network config file using the NZ example listed here - https://openwrt.org/docs/guide-user/network/wan/isp-configurations

The issue is that the WAN interface does not get an IP address allocated from the ISP (I am checking this from the web interface under Network UI

I do have an exiting Fritz box that does work so there is no issue with the Fibre connection that I have had for several years.

Below is my network config. Is it right for the config required by the ISP as per the URL? What other troubleshooting steps should I take. I can use CLI but prefer LUCI interface. Should I being something in the System Log from LUCI saying that WAN interface had a IP address assigned or failed to receive one?

config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fdf5:78dd:d6d8::/48'

config device
option name 'br-lan'
option type 'bridge'
list ports 'eth1'

config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
option delegate '0'

config interface 'lan2'
option proto 'static'
option device 'eth2'
option ipaddr '192.168.2.254'
option netmask '255.255.255.0'

config interface 'lan3'
option proto 'static'
option device 'eth3'
option ipaddr '192.168.3.254'
option netmask '255.255.255.0'

config interface 'wan'
option proto 'dhcp'
option device 'eth0'

config interface 'wan6'
option proto 'dhcpv6'
option device 'eth0'
option reqaddress 'try'
option reqprefix 'auto'

config device
option type '8021q'
option ifname 'wan'
option vid '10'
option name 'wan.10'
option ipv6 '1'

try cloning the wan MAC address of the Fritz, and putting it on the new routers wan port.

You need to change both interfaces wan and wan6 to use the device wan.10

Thanks . So the actual network interface allocated to wan is eth0 so if I change that to wlan.10 how do I specify which network port to use for WAN or do I change
option name 'wan.10' to
option name 'eth0’

You would use eth0.10

2 Likes

Yes. In x86, there is no switching-- VLANs are created directly on the eth port. To do this in the GUI, edit the wan interface and pull down the Device box and scroll all the way down then type eth0.10 where it says "custom" in the text box at the bottom. Make sure to press enter don't just click away. Repeat with wan6. When you get to wan6, eth0.10 should be one of the choices in the list.

1 Like

Thanks All. It is working now. I have documented the network config for others who are based in NZ and trying to connect to a ISP using Fibre on a x86-64 openwrt platform. Note my WAN interface device is 'eth0'

config interface 'wan'
option proto 'dhcp'
option device 'eth0.10'

config interface 'wan6'
option proto 'dhcpv6'
option reqaddress 'try'
option reqprefix 'auto'
option device 'eth0.10'

config device
option name 'eth0.10'
option type '8021q'
option ifname 'eth0'
option vid '10'

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.