Not able to install on Google Wifi router

Hi all,

I'm trying to install OpenWRT on my Google Wifi routers, following this guide:

I tried many times but was not able to get the router to boot from USB. Everything went as described by the instructions until I plug in the USB and press SW7 the second time, in my case, after press the button, the router rebooted (light went off) then came back as (light pulse purple), I guess it's in the official developer mode. I can't ssh to the router.

I tried 2 USB drives, both can be used to reset the router when flashed the official recovery image so I guess they are not the problem.

My model is AC-1304 (FCC ID: A4RAC-1304), which is mentioned in the guide so I assume it's supported?

The guide didn't mention how to prepare the USB drive so I used dd, tried dd if=[img file] of=/dev/diskX first, then tried the command for writing image to eMMC from the guide (replaced the eMMC device path with my USB device path). Both didn't work and the symptoms were the same (as mentioned above). The image was downloaded from the link provided in the guide, the MD5 checksum is a790c16b2b514be5e3bdd541c3a1ce40.

Two things I noticed:

  1. According to the guide, when release the reset button, the light should flash orange for 3 seconds then breathe orange and amber. In my case, it only breathe orange and amber if a USB drive is plugged into the USB hub, otherwise, it simply flash orange (after 3 seconds, the light flashes slower).

  2. In the guide, there are 6 connectors on the router PCB, mine only has 5, note that the light blue cable connector is missing.

Any thoughts?


The problem is that the USB drive HAS TO be prepared using the OnHub recovery utility, the same chrome app used to create the recovery USB. Choose "local image" from the top right gear menu then select the openwrt bin file. I was able to complete the installation this way.

I feel this information is critical for first time user like myself, not sure why it's not mentioned in the guide. I'll try to update the wiki later (if I have permission to do so).


Finally found the answer I was looking for. Thank you for making it clear that you have to prepare the USB in that way first.

This NEEDS to be on the wiki! Thank you!

Feel free to update Applying for OpenWrt wiki account - #332 by mikesum32