NoobQ how to change LAN IP address

super noob here, been struggling for hours and I just can't get it going.
I wanted to make use of my old router as a wireless receiver/bridge for LAN connection direct to my pc, I had it going for years until just now it doesn't anymore, so I tried resetting the router and reconfigure the settings again, until I hit this, I can't change the Ipv4 address using lucl.
the default is as usual, but then it'd conflict with the modem's so I tried changing them, but lucl stuck after I changed it to any number whether 168.2.1 or 168.100.1. I can't access the router again whether I go to 168.1.1 or the one I set it to.
people said I need to run etc/config/network or something but I'm on Windows, and someone said I can edit the etc/Init.d/network or something but when I scroll down the file it has no ip address out in any line where I can minorly change, I have no idea of how to "restart" or "run" the thing after I edit the file either as I'm complete noob on WinSCP.
or was I in the frong file and should've opened the /etc/config/network instead?
there is an address there, I edited the address there to something else other than 168.1.1 but lucl still goes to 1.1

On top of all this, pulpstone lucl keep on looping back to login screen asking me to enter password over and over now, I can't even edit any setting in it.

im a confused noob, can anyone help me... slowly?
past ref that kinda guide me somewhere but ended without any detail and how to do anything

@Sp12er, welcome to the community!

  • Did you see a big red button that said "Apply Unchecked"?
  • If so, did you press it?
  1. If you are not comfortable on the web GUI, you can login via SSH and edit /etc/config/network to alter the LAN IP section - then run /etc/init.d/network reload
    2, You can also backup the router's config, edit the same network file, re-compress it and then restore it to the router - when it reboots, it will have a new LAN subnet and IP

no, there's no prompt that come up asking me whether to apply it or not, the menu just reload and it just stuck in there, I can't access the config using 1.1 nor the new address.
second part, that's the thing, I don't understand what it means to login via SSH, at all.
third so using winscp I download the whole root file system? or only the ones in config/ init.d folders?
how do I replace the default files that's in the reseted router with the edited one?

I'm not sure what version of openwrt the router is using either, I just inherited the thing from a friend years ago, a vodafone/huawei Hg553 I think is the model. haven't flashed it since I received it.

No you do not download the whole file system (lack of Wiki knowledge here), if you don't choose:

  • You log into the web GUI and download the whole backup as a compressed file under System > Backup Firmware / Flash :bulb: - edit the file, replace it in the compressed file and restore the config in whole
  • Or yes, you can use SCP and only download/edit /etc/config/network - then upload it back and reboot
  • Look at the bottom line of the Overview page - or the line that says "Firmware Version".
  • You don't have to double post.