Noob\(ish) help needed setting up openwrt on a raspberry pi 5 with a sixfab 5g modem kit (for rpi 5)


I got a raspberry pi 5, and a sixfab 5g modem kit for it.

I installed openwrt to the pi 5 from here:

Fwiw I am currently connected to the pi via ethernet, and the internet via the pi's wireless card without any trouble.

I guessed that I might be able to connect to the sixfab modem using qmi. I searched for 'qmi' in the pi's web interface: system > software page and installed the packages that were available: qmi-utils, kmod-usb-net-qmi-wwan, luci-proto-qmi, libqmi, and uqmi.

I then went to Network > Interfaces > Add new interface. I named the interface, then selected QMI Cellular for 'Protocol'. Then 'create device'.

I was hoping that openwrt would automatically know the modem device I wanted/needed to use, but nothing came up.


Can I create a data connection using qmi? If I can how can I find out what modem device I need to use? (I think I know the rest of the settings).

I am not 100% sure what qmi actually is. Does its use mean I don't need a driver for the sixfab 5g modem kit anyway? If I need something other than simply to use qmi can somebody tell me what I need - or at least give me a good point in the right direction)?

Thanks in advance for any help!

start by installing the official image from

since it's a snapshot, read

Yes I did that and could not connect over the web interface.

I read that the snapshot image did not contain luci, but apparently it did.

This is not relevant to my problem, thank you for your reply anyway. I very much welcome any reply that will address my post. Thanks in advance.

yes, that's what the links tells you about snapshots.

it doesn't, but you didn't install an official image.

cool, in that case:

It appears you are using firmware that is not from the official OpenWrt project.

When using forks/offshoots/vendor-specific builds that are "based on OpenWrt", there may be many differences compared to the official versions (hosted by Some of these customizations may fundamentally change the way that OpenWrt works. You might need help from people with specific/specialized knowledge about the firmware you are using, so it is possible that advice you get here may not be useful.

You may find that the best options are:

  1. Install an official version of OpenWrt, if your device is supported (see
  2. Ask for help from the maintainer(s) or user community of the specific firmware that you are using.
  3. Provide the source code for the firmware so that users on this forum can understand how your firmware works (OpenWrt forum users are volunteers, so somebody might look at the code if they have time and are interested in your issue).

If you believe that this specific issue is common to generic/official OpenWrt and/or the maintainers of your build have indicated as such, please feel free to clarify.

1 Like

it doesn't, but you didn't install an official image.

I literally just told you that I did install the official image, but I couldn't get to the web interface.

In the 'installed packages' the snapshot lists 'luci' amongst the packages installed, however, apparently it is not installed.

As I said.

The thread title clearly contains the word 'noob'. I need the web interface, so I cannot use the snapshot you suggest.

Again, thanks for your input but you are not helping at all, quite the contrary. I am very happy for you to move on to other threads and hopefully somebody else will chime in who has information that might be useful.


you have to "request build" (click the tiny arrow) to get an image with luci included.

That is NOT official OpenWrt.

This is official OpenWrt:


So I built/installed an official openwrt image with luci.

If anybody can help with my original problem that would be very much appreciated.

Thanks very much for the replies so far.

start a new thread, imho.

don't forget to add the output from lsusb when you post.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.