No wireless tab on x86 laptop

I'm trying to set up a simple OpenWRT wireless router on my laptop
I got it working and I can log in to the web interface but there's no wireless tab under Network
after some googling, I figured I had to install the drivers manually
I have athw8x wifi driver on my laptop
I tried to install ath9k but I still don't have wifi
I also tried to add the interface manually in the /etc/config/network and this is what I have right now

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
 
 
config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.30'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '192.168.1.1'
        option dns '8.8.8.8'
        
config interface 'wlan'
        option ifname 'wlan0'
        option type 'bridge'
        option force_link '1'
        option bridge_empty '1'
        option proto 'static'
        option ipaddr '192.168.1.2'
        option netmask '255.255.255.0'
        option gateway '192.168.1.1'
        option dns '8.8.8.8'

I just copied the wlan interface from here
and that gave me the wlan interface but still no wireless tab
I also don't have this folder /etc/config/wireless
sorry, I am new to this, all I really care about is to have proper QoS for gaming without having to buy an expensive router.

Run a wifi reconf and it should detect the settings and recreate the file.
https://openwrt.org/docs/guide-user/network/wifi/basic?s[]=wifi&s[]=conf#regenerate_configuration

that command did nothing.
I also tried iw list and it shows nothing, like not even an error message or anything it's just empty.
so I guess it still doesn't detect my wireless network card?
how can I fix this?

Your mentioned athw8x does reference a windows driver.
So you should figure out which card do you have installed...

Check dmesg for the kernel log if it gets at least detected.
You can also install pciutils and check with lspci for available pci devices.

If it really is an ath9k card, there is a build option for ath9k "Support chips used in PC OEM cards". This needs to be selected to use pluggable cards like in laptops (versus the ath9k chips in routers that are built into the CPU chip or soldered to the board). I don't know if the x86 builds enable it by default.

after running the lspci command it detects Qualcomm Atheros QCA9565/AR9565
so which kernel would that be?

seems like there are some people here and here that have the same issue
a user said that

OpenWrt by default does not compile support for laptop cards

is that so?
but it does have driver support so it should be supported, right?
is there any way to get around that limitation?
all I need is QoS for gaming

For sure ath9k.

There is no output in the kernel log?

dmesg | grep ath

this is the output from the kernel log dmesg command





dmesg | grep ath command gives me this output:

usbcore: registered new interface driver ath9k_htc

I did a factory reset and I reinstalled all the ath9k packages and still no wireless
please note that this time I didn't add the "wlan" interface manually
because I want it to regenerate everything from it's own
it should do it by default, right?

You can ssh from another computer instead of using the laptop screen. This will allow you to cut and paste text.

There should be more messages from the ath / ath9k kmod indicating the card has been detected and driver attached to it. Likely this driver is not compiled for your card.

Once the driver is attached, iw list will give a non-null result and this is used by the bootup scripts to auto-generate an /etc/config/wireless file.

ssh is a nice feature, but I still don't know what to do here?
is the ath9k not the correct driver for my network card?
do you need any more info to help me?
is there some kind of generic driver that works for most cards to at least get it to work?

kernel log does mention 2 cards being
this one:

[   10.438413] e1000: Intel(R) PRO/1000 Network Driver - version 7.3.21-k8-NAPI
[   10.439574] e1000: Copyright (c) 1999-2006 Intel Corporation.
[   10.442037] igb: Intel(R) Gigabit Ethernet Network Driver - version 5.4.0-k
[   10.443178] igb: Copyright (c) 2007-2014 Intel Corporation.
[   10.448827] e1000e: Intel(R) PRO/1000 Network Driver - 3.2.6-k

and that one:

[   10.458899] r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
[   10.636141] r8169 0000:01:00.0 eth0: RTL8106e at 0xffffc90000049000, 74:86:7a:5e:a4:2f, XID 04900000 IRQ 43
[   11.460202] r8169 0000:01:00.0 eth0: link down
[   13.083102] r8169 0000:01:00.0 eth0: link up

but for some reason, they are both ethernet?

Those are all wired Ethernet drivers. e1000e and igb are for Intel chips which your laptop does not have. Your RTL8106e chip seems to be working properly, but realize it is not a gigabit chip.

that's fine because my internet is nowhere near gigabit speeds
this is from Windows 10



in compatible ids I have the same id for ath9k card which is:

PCI\VEN_168C&DEV_0036&REV_01

Does windows drivers affect OpenWrt in anyway?
because maybe I could try a different windows driver if that would help

Try install kmod-owl-loader package & reboot.