No wifi networks in scan option

Hello all
I need your advice
I have installed OpenWrt on my router
I have another router at home and I am trying to connect through WiFi to the OpenWrt system on the home router
But when I try to search for Wi-Fi networks, no network appears in the search, knowing that I am surrounded by several Wi-Fi networks!

Attach the content of your network file

root@OpenWrt:/etc/config# cat network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdab:35c1:38dd::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '10.71.71.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        list dns '8.8.8.8'
        list dns '1.1.1.1'
        list dns '8.8.4.4'

config device
        option name 'eth0.2'
        option macaddr '74:da:88:f2:6c:b2'

config interface 'wan'
        option proto 'dhcp'
        option preedns '0'
        option device 'eth0.2'
        option type 'bridge'

config interface 'wan6'
        option device 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '2 3 4 5 0t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 0t'

config interface 'wwan'
        option proto 'dhcp'

The content of the wireless file

root@OpenWrt:/etc/config# cat wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'pci0000:00/0000:00:00.0'
        option band '5g'
        option short_gi_40 '0'
        option cell_density '0'
        option channel 'auto'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option mode 'ap'
        option ssid 'OpenWrt'
        option network 'lan wwan'
        option encryption 'psk2'
        option key 'aabbccdd'

The screenshot does not show what you stated.

The AP needs a non-DFS channel set.

This likely should be wwan only.

3 Likes

i edited it to wwan

sorry can you explain what mean non-DFS

my screenshot that when i search on wifi network but no network appears
Knowing that I have many nearby networks that broadcast at various frequencies

:disappointed_relieved:

and

1 Like

big thanks sir but No wifi network appears!
Knowing that I have many nearby networks that broadcast at various frequencies

Set your country code to ensure it will use all channels that are legal in your country. When the radio is configured with a client, it will seek that AP and lock to its channel, regardless of the channel setting. Until then it should be as @lleachii said, set to a specific non-DFS channel that is legal in your country to optimize blind scanning.

When you intend to use the "Join Network" button it is best to start with a default configuration and let the join script set everything up. Click this button only once from a default configuration, after that if you want to change to a different AP do it manually. Or install travelmate to assist with changing APs often.

Put custom DNS servers in the wwan section not lan.

3 Likes

i did ! but still the problem

and i have tp-link AC1900 2.4+5GH but in interface But in the wireless settings, I can't find the 2.4GHz frequency options
Only 5 GHz (see photo)

I tried to enter the 2.4 frequency in the settings file through ssh, but the wifi signal stops because the frequency does not exist!
What do you think is the solution

I think there are several listed as that. Which model, version and chipset is it exactly?

Run iw dev to see if both radios (phy) are detected.

If not there is some problem with the 2.4 GHz driver-- examine the system log starting from boot time.

If iw dev shows both radios I would rm the /etc/config/wireless file and reboot to let the wireless configuration rebuild.

1 Like

i run it

its AC1900 A9 V.6 TP-LINK

and how can i fix that ? i bought router before 2 days ago its new

Unsupported Functions: WiFi 2.4GHz

The 2.4 chip is not supported. This model will operate only on 5 GHz with OpenWrt.

You'll have to replace this with a different model to use 2.4. It looks relatively simple to TFTP recover it back to stock firmware then return it to the store.

2 Likes

big thanks to you sir for helping ..

Indeed, this is the reason that was preventing the networks from appearing, and I verified this using another router now that I have installed OpenWrt
I have all networks !

Accept my sincere love and thanks

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.