No wifi connection without internet

Hello everyone, I'm new and not very experienced with OpenWRT, I managed to install Openwrt on a Fritz 4020, I realized one thing though: if there is no internet connection the SSID is not blown up and therefore it is not possible to connect to the router via wifi in the absence of internet connection. Is this behavior normal? Is it possible to fix it?

Thanks

This is not normal behaviour. What have you modified in the configuration of the router? Did you add travelmate by any chance?

Please run the following commands (copy-paste the whole block) and paste the output here, using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have

ubus call system board; \
uci export network; uci export wireless
 "kernel": "5.15.134",
        "hostname": "OpenWrt",
        "system": "Qualcomm Atheros QCA956X ver 1 rev 0",
        "model": "AVM FRITZ!Box 4020",
        "board_name": "avm,fritz4020",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.0",
                "revision": "r23497-6637af95aa",
                "target": "ath79/generic",
                "description": "OpenWrt 23.05.0 r23497-6637af95aa"
        }
}
package network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd98:d67f:4b12::/48'

config device
        option name 'eth1'
        option macaddr 'xxx'

config interface 'wan'
        option device 'eth1'
        option proto 'dhcp'

config interface 'wan6'
        option device 'eth1'
        option proto 'dhcpv6'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config device
        option name 'eth0.1'
        option macaddr 'xxx'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 0t'

config interface 'wwan'
        option proto 'dhcp'

package wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/ahb/18100000.wmac'
        option band '2g'
        option cell_density '0'
        option channel 'auto'
        option htmode 'HT20'

config wifi-iface 'wifinet1'
        option device 'radio0'
        option mode 'sta'
        option network 'wwan'
        option ssid 'Vodafone-Bread'
        option encryption 'psk2'
        option key 'xxx'
        option disabled '1'

config wifi-iface 'wifinet2'
        option device 'radio0'
        option mode 'ap'
        option ssid 'AlcatrazMusicService'
        option encryption 'psk2'
        option key 'xxx'
        option network 'lan'

config wifi-iface 'wifinet3'
        option device 'radio0'
        option mode 'sta'
        option network 'wwan'
        option ssid 'BreadS21'
        option encryption 'psk2'
        option key 'xxx'

You have a wifi client configured, which explains the behaviour.
Install travelmate package which deals with this problem.

2 Likes

Yes I have 2 wifi clients configured that I use to go on the internet using existing wifi networks, but when these networks are not present the router no longer blows up the SSID

I installed travelmate but it doesn't work the same. Travelmate creates an interface and if I add stations, they are configured as clients

Each radio can only be tuned to a single channel. If one radio is a STA and an AP at the same time, both must be tuned to the same channel. So, until the STA can connect to an upstream AP, it does not have a defined channel, and neither does the AP.

Thanks, there is a solution for this?

The standard solution is to use travelmate... what is exactly that does not work for you?

I installed Travelmate by creating a new interface (wizard) and I created a new station. If the router no longer hears the station (STA) I don't see the WIFI (AP) anymore either. So even with travelmate same problem

this is my travelmate interface

This has been fixed in travelmate 2.1.2-1 (see https://github.com/openwrt/packages/commit/ce20f8d88be4fefaae15b06d18eef1639e992cd8)