No switch and no wireless menu OpenWrt 22.03.4


I made an firmware update from OpenWrt 19 to OpenWrt 22.03.4 on my Netgear Nighthawk X6 R8000.
Now, I have no wireless and switch menu as before...
How, can I get it back?


You also have SQM and mwan3 on the menu.

  • Perhaps you can explain how those got installed, but wireless didn't?
  • Try an image from the downloads site?

I used an imagebuilder and added some packets while building. This packets are:
PACKAGES="kmod-usb-net-rndis usb-modeswitch luci-ssl luci-app-mwan3 tc iptables-mod-ipopt luci-app-sqm luci-app-opkg openvpn-openssl luci-app-openvpn"

After that I also tried the standard firmware image ( from the website, same behavior (without mwan3 and SQM) occurs.

View of the standard OpenWrt Firmware 22.03.4 network menu:

When you ran the updates, did you keep settings?

No, I don't keep any settings

My suggestions here are to try to establish if something went wrong with your specific device, or if/when something broke in the firmware...

What happens if you roll back to 19.07.10 (just as a test; do not keep settings)? Do the menus come back?

Then, if you roll foward to 21.02.6 (again not keeping settings), do you see the missing menus?

Now, move to 22.03.3 (this is one minor service release behind the current, don't keep settings when updating) and check those menus. If you're still good there, go ahead and upgrade to 22.03.4.

I roll back to 19.07.1 without keep settings.
--> The switch menu is back but no wireless menu!

I roll forward to 19.07.3 without keep settings.
--> The switch menu is back but no wireless menu!

My guess is that your wireless hardware is not working properly -- could be the radios themselves and/or the factory calibration data that has been damaged.

I'm sure that others may be able to help troubleshoot a bit farther.

Has there someone an idea for the wireless hardware issue?

verify it works using a fw from the manufacturer.

1 Like

Now it works!
Flash an old stock firmware (R8000-V1.0.3.32_1.1.21.chk) from Netgear.

Wireless works now.
Then load the latest Openwrt firmware image 22.03.5 and the wireless works again.

Thanks to all!

1 Like

Remember that you upgraded from 19.07 to 22.03, which is not officially supported. You might have a conflict of settings. Anyway you have done what is necessary. Good work.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.