No SSH on Google Ac-1304

I cant write the flash to emmc bcause I can ping the device but nmap shows that ssh is not running on the device...

https://downloads.openwrt.org/snapshots/targets/ipq40xx/chromium/openwrt-ipq40xx-chromium-google_wifi-squashfs-factory.bin

Any idea on this as I was going to use this device to host an rtl dongle ...

Please allow at least two more positive responses before you act..

Is this your launching pad Wiki?

Been reading the horror storys of the standard packages including, breaking things.

wpad-basic-wolfssl libustream-wolfssl

So I removed them as they would fail to build on the page.. and replaced them with and got a success.
wpad-openssl libustream-openssl

OpenWrt Firmware Selector

ath10k-board-qca4019 ath10k-firmware-qca4019-ct base-files busybox ca-bundle dnsmasq dropbear e2fsprogs firewall4 fstools kmod-ath10k-ct kmod-fs-ext4 kmod-fs-f2fs kmod-google-firmware kmod-gpio-button-hotplug kmod-leds-gpio kmod-nft-offload kmod-usb-dwc3 kmod-usb-dwc3-qcom kmod-usb3 libc libgcc logd mkf2fs mtd netifd nftables odhcp6c odhcpd-ipv6only opkg partx-utils ppp ppp-mod-pppoe procd procd-seccomp procd-ujail swconfig uboot-envtools uci uclient-fetch urandom-seed urngd wpad-openssl libustream-openssl

so I did that but it only gives me an upgrade file I cant get the kernel to install :stuck_out_tongue: thanks for the help, I am working on a project and this form factor works perfectly

also where is ssh package at ?

ok so i got a custom firmware to boot

image

but it still wont let me ssh in ...

Fill in my blanks:

  • Can't use LuCi ~ Web Interface? Prebuilt snapshot images do not come with any web interface or GUI.
  • Can't use uci ~ command, Putty, Terminal?

Did you notice?

Points of interest:

Yellow: SW7, Developer Mode switch
Red: Write-Protect screw
White button (on side of case, not pictured): reset button

A. I have it to boot the firmware...
B. It shows up in by DHCP list as openwrt
C. When trying to ssh to the device from windows with putty it wont connect.
D. NMAP does not show that any ports are open on the device when scanned
E. this was done with stock and custom software images

Dropbear is part of any OpenWrt image. The Ip your screen shot takes this one or more levels past an initial install, as the default OpenWrt Image would put you on 192.168.1.1 for ssh access.
Did you start/follow the Wiki?

Yes... but I got to the point to commit the image to the onboard memory via ssh and could not get to it.

Procedure:

  1. Hold the Reset button (front of case)

  2. Connect power to the device

  3. After about 16 seconds, the LED should blink orange; you may now release the Reset button

  4. Press SW7

  5. Device will blink purple and restart

  6. Wait a few seconds for the device to finish restarting, when it will start blinking purple again

  7. Plug in USB stick containing OpenWrt

  8. Press SW7

  9. LED should turn off, and device should boot your USB image

10. To program your image to the main flash, SSH to the device and run the following:

Clobber secondary GPT at end of eMMC dd if=/dev/zero bs=512 seek=7634911 of=/dev/mmcblk0 count=33 ## Copy USB image directly to eMMC dd if=/dev/sda of=/dev/mmcblk0 bs=1M ## Ideally, we might add a GPT repair step, so primary and alternate are intact, but this isn't strictly necessary.


Misunderstood the thread by title after install; thinking you had successfully flashed OpenWrt.
Your stuck at step 10 assuming the previous steps were followed correctly.

The wiki was last edited by @bnorris who removed a deprecated section: "Supporting activities".

Perhaps this user has some insights from whom you could gain assistance.

Thanks for looping me in. This is unlikely to be your problem, but note that I've fielded some confusions/issues from other users at: Google WIFI - can't make flashed OpenWrt permanent - dd error

I plan to make some Wiki updates eventually...

To your problem: if the system is up and requesting DHCP addresses from your uplink, then that sounds like you're booting OK, and the remaining SSH problems sound more like a general OpenWrt problem.

Dumb question (since I've also hit these things as a new user): are you trying to SSH via your WAN-side link/address, or via a LAN connection? Upthread, you show a DHCP address of 192.168.88.30 -- that sounds like your WAN address, and by default, OpenWrt's SSH configuration does not allow SSH via the WAN port. You'd need to connect to the LAN port, and SSH to 192.168.1.1.

looks like i got it working

my gotchas:

A. Flash to 4gb drive factory.bin with rufus...
B. connect ethernet to lan
C. set machine to 192.168.1.20 on usb ethernet and ping 192.168.1.1 -t (windows)
D. ssh into 192.168.1.1 after ping is working
E. Install putty, and from the putty directory copy pscp.exe to C:\windows\system32
F. open and run cmd.exe
G. From the other post what worked for me is ...

There is probably a better way of doing this but I finally got it to work. Once I was booted into OpenWRT on the USB drive I used SCP to copy the factory.bin file from my workstation to the USB drive then I used dd to write the .bin file to the flash. I'm on a windows box so I used pscp.exe to get the file to the USB drive.
`.\pscp.exe -scp .\openwrt-ipq40xx-chromium-google_wifi-squashfs-factory.bin root@192.168.1.1:/`
then when connected over SSH I ran
`dd if=/openwrt-ipq40xx-chromium-google_wifi-squashfs-factory.bin of=/dev/mmcblk0`
followed by
`dd if=/dev/zero bs=512 seek=7634911 of=/dev/mmcblk0 count=33`
then I rebooted.

Blockquote

on side note

does this look right with a 4gb emmc? or am I mistaken ?

image