No output on UART, TP-Link 940n V6

Hi, I am using a Tp-Link 940n V6 and I have connected headers to the uart pins.

The pins are not marked so I found out the ground and vcc and connected UART (cp2102) and tried swaping the other two pins for TX/RX but I am not getting any output. baud is set to 115200.

I also checked the voltage on the TX/RX pins and its identical so I am confused.

Any tips on how to make it work.

VCC should never be connected.

Short your RX/TX and see if the serial works, you should see your own typing in your serial terminal sw (putty ?)

yeah I didnt touch the VCC... Okay I will short the RX/TX and see if that gives out anything but if the RX is working on its own should it not give anything I type ?

some u-boots have disabled RX, and won't accept any input.

it's usually an u-boot parameter, but you need to get into the device, to be able to change it.

okay then atleast I should be able to see the output from my RX ... right ? I mean to say I connected UART TX to both the pins on the board of which I am not sure which one is RX and TX and I tried sending something and the terminal shows nothing in return. That does the same thing as shorting the terminals right ? please tell me if my understanding is correct

And can you please explain me if its disabled then how do I get into the device ?

Generally yes, but since it's a TP-Link, they might have done something with the PCB, and
you might have to do some soldering, to get output.

It's the u-boot that's disabled, once you booted you could (at least in theory) modify the
param from the OS, assuming you're able to logon.

Shorting the RX and TX pins doesn't involve the router, you just connect them to each other,
to verify the USB<>serials functionality.

There's a lot of useful info provided in https://openwrt.org/toh/tp-link/tl-wr940n
According to the wiki, some versions of your router need PCB soldering for
serial to work, but it's not required for installation.

It's however a 4/32 device, and not a very good unit for openwrt, but
there are tiny 19.07 images for it in OpenWrt 19.07.1 ath79 tiny LuCI

Would be nice if you could post PCB photos of your v6, so they could be added to the wiki.

1 Like

Okay understood, I checked the serial chip how you asked me to, its working fine. the pcb has a cover so cant see the soc etc can you please share me the link of where its described, which part to solder to get the UART working.

it's in the wiki.

but you have the v6, there are only photos up to v4.

1 Like

Yeah just checked.. Well what is the concept behind shorting these points ? Like is there any tutorial to understand that conceptually ? So then maybe I can implement for my board

it's just an electrical PITA to make it harder to access the boot loader, there's no deeper meaning to it :wink:

1 Like

On my C50 v4.2, it refuses to boot if the Rx and Tx lines are reversed.