No LAN ports when setting up VLANs

Hi,
I'd like to set up multiple VLANs. I tried to follow this guide. However if I go to Network >> Interfaces >> Devices, I don't have any lan ports (network devices), so I can't bridge them together.

Guide pictures:


My router:

my_dsa1
my_dsa2

How can I create lan ports?

lan ports are hardware, the router either has them or not.
Which router is this?

This is a TP-Link WR1043ND router, but I tried DSA with another router (TL-WR841ND) and this one is affected.

This is not a DSA router.... it is based on the ath79 target which only has one router that is now DSA enabled. Therefore, you should be using swconfig for this device.

1 Like

With or without DSA don't forget that you need two different boxes that manage the same VLANs
This may be :

LAN Switch 1 with VLAN's Managed <-> - LAN switch 2 with VLAN's Managed
OpenWrt with VLAN managed <-> LAN switch with VLAN's Managed
OpenWrt 1 with VLAN's Managed <-> OpenWrt 2 with VLAN's Managed

Both sides must use the same VLAN numbers
For example VLAN.1 & VLAN.100

2 Likes