No ipv6 on vlan

Hi i see that this problem is allready asked a couple of times.
But i cannot get ipv6 working at the same time on my lan and vlan.
can anybody help me out?
my ips is ziggo netherlands.
This are my network settings:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd13:4033:badd::/48'
	option packet_steering '1'

config device
	option name 'eth0'
	option macaddr 'd2:19:17:fd:c5:5a'

config interface 'wan'
	option device 'eth0'
	option proto 'dhcp'
	option peerdns '0'
	list dns '8.8.8.8'
	list dns '8.8.4.4'
	list dns '1.0.0.1'
	list dns '1.1.1.1'

config interface 'wan6'
	option device 'eth0'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix 'auto'
	option peerdns '0'
	list dns '2001:4860:4860::8888'
	list dns '2001:4860:4860::8844'
	list dns '2606:4700:4700::1111'
	list dns '2606:4700:4700::1001'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth1'

config device
	option name 'eth1'
	option macaddr 'd2:19:17:fd:c5:5b'

config interface 'lan'
	option proto 'static'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option device 'eth1.2'

config device
	option type '8021q'
	option ifname 'eth1'
	option vid '3'
	option name 'eth1.3'

config interface 'VLAN3'
	option proto 'static'
	option device 'eth1.3'
	option ipaddr '192.168.3.1'
	option netmask '255.255.255.0'

config device
	option type '8021q'
	option ifname 'eth1'
	option vid '2'
	option name 'eth1.2'

There's no ip6assign on VLAN3.

ifstatus wan6 etc can be used to see if prefixes exist and are being delegated properly.

1 Like

@mk24 Really a noob here on ipv6. So this could be just me setting it up wrong . I have the IP6assign to 61 for VLAN3 now but no ipv6 adresses are given to VLAN3.
This are the setting on LAN.



And this are the settings for VLAN3



Hope this gives some information what i am doing wrong

When i type ifstatus wan6

this is the result:

root@OpenWrt:~# ifstatus wan6
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 407,
        "l3_device": "eth0",
        "proto": "dhcpv6",
        "device": "eth0",
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [

        ],
        "ipv6-address": [
                {
                        "address": "2001:1c06:1c00:0:94df:bdc2:c5f7:68a7",
                        "mask": 128,
                        "preferred": 3191,
                        "valid": 3191
                }
        ],
        "ipv6-prefix": [
                {
                        "address": "2001:1c06:1c01:c000::",
                        "mask": 56,
                        "preferred": 3191,
                        "valid": 3191,
                        "class": "wan6",
                        "assigned": {
                                "lan": {
                                        "address": "2001:1c06:1c01:c000::",
                                        "mask": 60
                                },
                                "VLAN3": {
                                        "address": "2001:1c06:1c01:c010::",
                                        "mask": 61
                                }
                        }
                }
        ],
        "ipv6-prefix-assignment": [

        ],
        "route": [
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::201:5cff:feaa:6846",
                        "metric": 512,
                        "valid": 1799,
                        "source": "2001:1c06:1c01:c000::/56"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::201:5cff:feaa:6846",
                        "metric": 512,
                        "valid": 1799,
                        "source": "2001:1c06:1c00:0:94df:bdc2:c5f7:68a7/128"
                }
        ],
        "dns-server": [
                "2001:4860:4860::8888",
                "2001:4860:4860::8844",
                "2606:4700:4700::1111",
                "2606:4700:4700::1001"
        ],
        "dns-search": [

        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [
                        "2001:b88:1002::10",
                        "2001:b88:1202::10",
                        "2001:730:3e42:1000::53"
                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {
                "passthru": "0017003020010b8810020000000000000000001020010b88120200000000000000000010200107303e4210000000000000000053"
        }
}

Why have you picked 61?

That is the issue on my side i think :grinning: i searched and thought this was the right way.
I think i could need some guidance :kissing_smiling_eyes:

so to sum it all up this is what i have done so far:

started from scratch with openwrt on my nanopi R4S.

nothing changed still no ipv6 on Vlan3.

on another topic @slh advised me to take a good look at:
Make sure to use ip6hint and ip6assign and set up odhcpd for your additional interfaces.

ip6assighn is related to my prefix i presume.
odhcpd i have no cleu what to do with this.
ip6hint no idea what the correct settings are.

i now have the following setup:

network:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd97:781c:cad1::/48'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth1'

config device
	option name 'eth1'
	option macaddr 'da:96:6e:0e:99:43'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '64'
	option ip6hint '0'

config device
	option name 'eth0'
	option macaddr 'da:96:6e:0e:99:42'

config interface 'wan'
	option device 'eth0'
	option proto 'dhcp'

config interface 'wan6'
	option device 'eth0'
	option proto 'dhcpv6'

config device
	option type '8021q'
	option ifname 'eth1'
	option vid '2'
	option name 'eth1.2'

config device
	option type '8021q'
	option ifname 'eth1'
	option vid '3'
	option name 'eth1.3'

config interface 'VLAN2'
	option proto 'static'
	option device 'eth1.2'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'
	option ip6assign '64'
	option ip6hint '0'

config interface 'VLAN3'
	option proto 'static'
	option device 'eth1.3'
	option ipaddr '192.168.3.1'
	option netmask '255.255.255.0'
	option ip6assign '64'
	option ip6hint '0'

dhcp:

onfig dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option localservice '1'
	option ednspacket_max '1232'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option dhcpv6 'server'
	option ra 'server'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

config dhcp 'VLAN2'
	option interface 'VLAN2'
	option start '100'
	option limit '150'
	option ra 'server'
	option dhcpv6 'server'
	option leasetime '12m'

config dhcp 'VLAN3'
	option interface 'VLAN3'
	option start '100'
	option limit '150'
	option ra 'server'
	option dhcpv6 'server'
	option leasetime '12m'

firewal:


config defaults
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option synflood_protect '1'

config zone
	option name 'lan'
	list network 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'

config zone
	option name 'wan'
	list network 'wan'
	list network 'wan6'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config zone
	option name 'VLAN2'
	option input 'ACCEPT'
	option output 'ACCEPT'
	list network 'VLAN2'
	list network 'WG0'
	option forward 'ACCEPT'

config zone
	option name 'VLAN3'
	option input 'ACCEPT'
	option output 'ACCEPT'
	list network 'VLAN3'
	option forward 'ACCEPT'

config rule
	list proto 'udp'
	option src '*'
	option src_port '5353'
	list dest_ip '224.0.0.251'
	option dest_port '5353'
	option target 'ACCEPT'
	option name 'allow mDNS'

config redirect
	option dest 'lan'
	option target 'DNAT'
	list proto 'udp'
	option src 'wan'
	option src_dport '51820'
	option dest_port '51820'
	option name 'port 51820 - wireguard'
	option dest_ip '192.168.2.1'

config forwarding
	option src 'VLAN2'
	option dest 'wan'

config forwarding
	option src 'VLAN3'
	option dest 'wan'

config forwarding
	option src 'VLAN2'
	option dest 'lan'

config forwarding
	option src 'lan'
	option dest 'VLAN2'

ifstatus wan6:

root@OpenWrt:~# ifstatus wan6
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 2011,
        "l3_device": "eth0",
        "proto": "dhcpv6",
        "device": "eth0",
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [

        ],
        "ipv6-address": [
                {
                        "address": "2001:1c06:1c00:0:e9c5:aba4:6208:8e05",
                        "mask": 128,
                        "preferred": 604588,
                        "valid": 1209388
                }
        ],
        "ipv6-prefix": [
                {
                        "address": "2001:1c06:1c1d:cb00::",
                        "mask": 56,
                        "preferred": 604588,
                        "valid": 1209388,
                        "class": "wan6",
                        "assigned": {
                                "VLAN2": {
                                        "address": "2001:1c06:1c1d:cb00::",
                                        "mask": 64
                                },
                                "VLAN3": {
                                        "address": "2001:1c06:1c1d:cb01::",
                                        "mask": 64
                                },
                                "lan": {
                                        "address": "2001:1c06:1c1d:cb02::",
                                        "mask": 64
                                }
                        }
                }
        ],
        "ipv6-prefix-assignment": [

        ],
        "route": [
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::201:5cff:feaa:6846",
                        "metric": 512,
                        "valid": 1798,
                        "source": "2001:1c06:1c1d:cb00::/56"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::201:5cff:feaa:6846",
                        "metric": 512,
                        "valid": 1798,
                        "source": "2001:1c06:1c00:0:e9c5:aba4:6208:8e05/128"
                }
        ],
        "dns-server": [
                "2001:b88:1002::10",
                "2001:b88:1202::10",
                "2001:730:3e42:1000::53"
        ],
        "dns-search": [

        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {
                "passthru": "0017003020010b8810020000000000000000001020010b88120                                                                                                         200000000000000000010200107303e4210000000000000000053"
        }
}
root@OpenWrt:~#

Hope somebody with greater it skills then me can help me :grinning:

All your interfaces have IP hint 0. Set these to 1 for vlan1, 2 for Vlan 2 and 3 for Vlan 3...

Changed the ip6hint to:
LAN = 3
VLAN 2 = 2
VLAN 3 = 1

But the same happens.
When i am on VLAN 2 ipv6 adresses are handed out for the ipv6 lan-networks with ip6hint 3 and 2.
See screenshot

But when i am on VLAN3 no ipv6 adres only a ipv4 adres is handed

Okay got it fixed i now have ipv6 on all of my VLANs
eindelijk

Thank you ziggo community :smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.