No ipv6 on LAN hosts

Hi all,

I'm struggling to get ipv6 working on my internal LAN.

I have a Telenet DOCSIS 3.1 E-ROUTER (CV8560E) modem: ipv4 is bridged and ipv6 is routed.
Devices connected directly to this modem get an ipv6 address with a /64 subnet address.

Now I want to use OpenWrt as my own firewall. i'm running version 22.03.0-rc4, as this version support my hardware (NanoPi R4S).

It's a fresh installation. I only added 'relay' to the lan config.

My OpenWrt device gets ipv6 addresses on all interfaces:

However none of the devices connected to my OpenWrt device get an ipv6 address. I have tried all examples from the documentation and none is working.
Do I have to install additional packages? Only the default are installed.
Is the documentation not yet up to date for my version (22.03.0-rc4)?

Can somebody help me?

package network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdfa:82c6:9af4::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth1'

config device
        option name 'eth1'
        option macaddr '82:34:28:38:f0:46'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'eth0'
        option macaddr '80:34:28:38:f0:46'

config interface 'wan'
        option device 'eth0'
        option proto 'dhcp'

config interface 'wan6'
        option device 'eth0'
        option proto 'dhcpv6'

package dhcp

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'relay'
        option ra 'relay'
        option relay 'relay'
        list ra_flags 'none'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

package firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

head: /etc/firewall.user: No such file or directory

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1000
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 2a02:1811:e40e:1400:8234:28ff:fe38:f046/64 scope global dynamic noprefixroute
       valid_lft 232620sec preferred_lft 86383sec
    inet6 2a02:1811:e40e:1400::f510/128 scope global dynamic noprefixroute
       valid_lft 220582sec preferred_lft 53721sec
    inet6 fe80::8234:28ff:fe38:f046/64 scope link
       valid_lft forever preferred_lft forever
4: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 2a02:1811:e40e:1420::1/60 scope global dynamic noprefixroute
       valid_lft 226520sec preferred_lft 53720sec
    inet6 fdfa:82c6:9af4::1/60 scope global noprefixroute
       valid_lft forever preferred_lft forever
    inet6 fe80::8034:28ff:fe38:f046/64 scope link
       valid_lft forever preferred_lft forever
default from 2a02:1811:e40e:1400::f510 via fe80::6802:b8ff:fe77:c298 dev eth0  metric 384
default from 2a02:1811:e40e:1400::/64 via fe80::6802:b8ff:fe77:c298 dev eth0  metric 384
default from 2a02:1811:e40e:1420::/60 via fe80::6802:b8ff:fe77:c298 dev eth0  metric 384
2a02:1811:e40e:1400::/64 dev eth0  metric 256
unreachable 2a02:1811:e40e:1400::/64 dev lo  metric 2147483647
2a02:1811:e40e:1420::/64 dev br-lan  metric 1024
unreachable 2a02:1811:e40e:1420::/60 dev lo  metric 2147483647
fda6:4b0b:dbf4:2bba::/64 from 2a02:1811:e40e:1400::f510 via fe80::1e53:f9ff:fe0a:18ab dev eth0  metric 512
fda6:4b0b:dbf4:2bba::/64 from 2a02:1811:e40e:1400::/64 via fe80::1e53:f9ff:fe0a:18ab dev eth0  metric 512
fda6:4b0b:dbf4:2bba::/64 from 2a02:1811:e40e:1420::/60 via fe80::1e53:f9ff:fe0a:18ab dev eth0  metric 512
fdfa:82c6:9af4::/64 dev br-lan  metric 1024
unreachable fdfa:82c6:9af4::/48 dev lo  metric 2147483647
fe80::/64 dev eth0  metric 256
fe80::/64 dev br-lan  metric 256
local ::1 dev lo table local  metric 0
anycast 2a02:1811:e40e:1400:: dev eth0 table local  metric 0
local 2a02:1811:e40e:1400::f510 dev eth0 table local  metric 0
local 2a02:1811:e40e:1400:8234:28ff:fe38:f046 dev eth0 table local  metric 0
anycast 2a02:1811:e40e:1420:: dev br-lan table local  metric 0
local 2a02:1811:e40e:1420::1 dev br-lan table local  metric 0
anycast fdfa:82c6:9af4:: dev br-lan table local  metric 0
local fdfa:82c6:9af4::1 dev br-lan table local  metric 0
anycast fe80:: dev eth0 table local  metric 0
anycast fe80:: dev br-lan table local  metric 0
local fe80::8034:28ff:fe38:f046 dev br-lan table local  metric 0
local fe80::8234:28ff:fe38:f046 dev eth0 table local  metric 0
multicast ff00::/8 dev br-lan table local  metric 256
multicast ff00::/8 dev eth0 table local  metric 256
0:      from all lookup local
32766:  from all lookup main
4200000000:     from 2a02:1811:e40e:1420::1/60 iif br-lan lookup unspec unreachable
lrwxrwxrwx    1 root     root            16 Jun 10 09:20 /etc/resolv.conf -> /tmp/resolv.conf
-rw-r--r--    1 root     root            47 Jun 16 14:23 /tmp/resolv.conf
-rw-r--r--    1 root     root           181 Jun 16 14:23 /tmp/resolv.conf.d/resolv.conf.auto

/tmp/resolv.conf.d:
-rw-r--r--    1 root     root           181 Jun 16 14:23 resolv.conf.auto
==> /etc/resolv.conf <==
search lan
nameserver 127.0.0.1
nameserver ::1

==> /tmp/resolv.conf <==
search lan
nameserver 127.0.0.1
nameserver ::1

==> /tmp/resolv.conf.d <==
head: /tmp/resolv.conf.d: I/O error

==> /tmp/resolv.conf.d/resolv.conf.auto <==
# Interface wan
nameserver 195.130.131.5
nameserver 195.130.130.5
search telenet.be
# Interface wan6
nameserver 2a02:1800:100::45:1
nameserver 2a02:1800:100::45:2
search telenet.be
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 12056,
        "l3_device": "eth0",
        "proto": "dhcpv6",
        "device": "eth0",
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [

        ],
        "ipv6-address": [
                {
                        "address": "2a02:1811:e40e:1400::f510",
                        "mask": 128,
                        "preferred": 53720,
                        "valid": 220581
                },
                {
                        "address": "2a02:1811:e40e:1400:8234:28ff:fe38:f046",
                        "mask": 64,
                        "preferred": 86383,
                        "valid": 232620
                }
        ],
        "ipv6-prefix": [
                {
                        "address": "2a02:1811:e40e:1420::",
                        "mask": 60,
                        "preferred": 53720,
                        "valid": 226520,
                        "class": "wan6",
                        "assigned": {
                                "lan": {
                                        "address": "2a02:1811:e40e:1420::",
                                        "mask": 60
                                }
                        }
                }
        ],
        "ipv6-prefix-assignment": [

        ],
        "route": [
                {
                        "target": "2a02:1811:e40e:1400::",
                        "mask": 64,
                        "nexthop": "::",
                        "metric": 256,
                        "valid": 232620,
                        "source": "::/0"
                },
                {
                        "target": "fda6:4b0b:dbf4:2bba::",
                        "mask": 64,
                        "nexthop": "fe80::1e53:f9ff:fe0a:18ab",
                        "metric": 512,
                        "valid": 1715,
                        "source": "2a02:1811:e40e:1420::/60"
                },
                {
                        "target": "fda6:4b0b:dbf4:2bba::",
                        "mask": 64,
                        "nexthop": "fe80::1e53:f9ff:fe0a:18ab",
                        "metric": 512,
                        "valid": 1715,
                        "source": "2a02:1811:e40e:1400:8234:28ff:fe38:f046/64"
                },
                {
                        "target": "fda6:4b0b:dbf4:2bba::",
                        "mask": 64,
                        "nexthop": "fe80::1e53:f9ff:fe0a:18ab",
                        "metric": 512,
                        "valid": 1715,
                        "source": "2a02:1811:e40e:1400::f510/128"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::6802:b8ff:fe77:c298",
                        "metric": 384,
                        "valid": 1783,
                        "source": "2a02:1811:e40e:1420::/60"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::6802:b8ff:fe77:c298",
                        "metric": 384,
                        "valid": 1783,
                        "source": "2a02:1811:e40e:1400:8234:28ff:fe38:f046/64"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::6802:b8ff:fe77:c298",
                        "metric": 384,
                        "valid": 1783,
                        "source": "2a02:1811:e40e:1400::f510/128"
                }
        ],
        "dns-server": [
                "2a02:1800:100::45:1",
                "2a02:1800:100::45:2"
        ],
        "dns-search": [
                "telenet.be"
        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {
                "passthru": "001700202a0218000100000000000000004500012a0218000100000000000000004500020018000c0774656c656e657402626500001f00202a0218000100000200000000000000022a021800010000020000000000000003"
        }
}

can you try to put the LAN in server or hybrid mode?

1 Like

Change the dhcpv6 and ra service into server mode, disable the ndp proxy service. Set ra_flags M and O and enable SLAAC.


I started with a clean installation and modified the settings like requested above. It's still not working.
Clients on the LAN don't get an ipv6 address.

package network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdb2:8a25:e071::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth1'

config device
        option name 'eth1'
        option macaddr '82:34:28:38:f0:46'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'eth0'
        option macaddr '80:34:28:38:f0:46'

config interface 'wan'
        option device 'eth0'
        option proto 'dhcp'

config interface 'wan6'
        option device 'eth0'
        option proto 'dhcpv6'

package dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

package firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

head: /etc/firewall.user: No such file or directory
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1000
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 2a02:1811:e40e:1400:8234:28ff:fe38:f046/64 scope global dynamic noprefixroute
       valid_lft 232506sec preferred_lft 86269sec
    inet6 2a02:1811:e40e:1400::f510/128 scope global dynamic noprefixroute
       valid_lft 231871sec preferred_lft 65010sec
    inet6 fe80::8234:28ff:fe38:f046/64 scope link
       valid_lft forever preferred_lft forever
4: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 2a02:1811:e40e:1420::1/60 scope global dynamic noprefixroute
       valid_lft 237810sec preferred_lft 65010sec
    inet6 fdb2:8a25:e071::1/60 scope global noprefixroute
       valid_lft forever preferred_lft forever
    inet6 fe80::8034:28ff:fe38:f046/64 scope link
       valid_lft forever preferred_lft forever
default from 2a02:1811:e40e:1400::f510 via fe80::6802:b8ff:fe77:c298 dev eth0  metric 384
default from 2a02:1811:e40e:1400::/64 via fe80::6802:b8ff:fe77:c298 dev eth0  metric 384
default from 2a02:1811:e40e:1420::/60 via fe80::6802:b8ff:fe77:c298 dev eth0  metric 384
2a02:1811:e40e:1400::/64 dev eth0  metric 256
unreachable 2a02:1811:e40e:1400::/64 dev lo  metric 2147483647
2a02:1811:e40e:1420::/64 dev br-lan  metric 1024
unreachable 2a02:1811:e40e:1420::/60 dev lo  metric 2147483647
fd64:fad1:7064:aaa9::/64 from 2a02:1811:e40e:1400::f510 via fe80::1e53:f9ff:fe0a:18ab dev eth0  metric 512
fd64:fad1:7064:aaa9::/64 from 2a02:1811:e40e:1400::/64 via fe80::1e53:f9ff:fe0a:18ab dev eth0  metric 512
fd64:fad1:7064:aaa9::/64 from 2a02:1811:e40e:1420::/60 via fe80::1e53:f9ff:fe0a:18ab dev eth0  metric 512
fdb2:8a25:e071::/64 dev br-lan  metric 1024
unreachable fdb2:8a25:e071::/48 dev lo  metric 2147483647
fe80::/64 dev eth0  metric 256
fe80::/64 dev br-lan  metric 256
local ::1 dev lo table local  metric 0
anycast 2a02:1811:e40e:1400:: dev eth0 table local  metric 0
local 2a02:1811:e40e:1400::f510 dev eth0 table local  metric 0
local 2a02:1811:e40e:1400:8234:28ff:fe38:f046 dev eth0 table local  metric 0
anycast 2a02:1811:e40e:1420:: dev br-lan table local  metric 0
local 2a02:1811:e40e:1420::1 dev br-lan table local  metric 0
anycast fdb2:8a25:e071:: dev br-lan table local  metric 0
local fdb2:8a25:e071::1 dev br-lan table local  metric 0
anycast fe80:: dev eth0 table local  metric 0
anycast fe80:: dev br-lan table local  metric 0
local fe80::8034:28ff:fe38:f046 dev br-lan table local  metric 0
local fe80::8234:28ff:fe38:f046 dev eth0 table local  metric 0
multicast ff00::/8 dev br-lan table local  metric 256
multicast ff00::/8 dev eth0 table local  metric 256
0:      from all lookup local
32766:  from all lookup main
4200000000:     from 2a02:1811:e40e:1420::1/60 iif br-lan lookup unspec unreachable
lrwxrwxrwx    1 root     root            16 Jun 10 09:20 /etc/resolv.conf -> /tmp/resolv.conf
-rw-r--r--    1 root     root            47 Jan 18  2013 /tmp/resolv.conf
-rw-r--r--    1 root     root           181 Jun 17 13:45 /tmp/resolv.conf.d/resolv.conf.auto

/tmp/resolv.conf.d:
-rw-r--r--    1 root     root           181 Jun 17 13:45 resolv.conf.auto
==> /etc/resolv.conf <==
search lan
nameserver 127.0.0.1
nameserver ::1

==> /tmp/resolv.conf <==
search lan
nameserver 127.0.0.1
nameserver ::1

==> /tmp/resolv.conf.d <==
head: /tmp/resolv.conf.d: I/O error

==> /tmp/resolv.conf.d/resolv.conf.auto <==
# Interface wan
nameserver 195.130.131.5
nameserver 195.130.130.5
search telenet.be
# Interface wan6
nameserver 2a02:1800:100::45:1
nameserver 2a02:1800:100::45:2
search telenet.be
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 765,
        "l3_device": "eth0",
        "proto": "dhcpv6",
        "device": "eth0",
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [

        ],
        "ipv6-address": [
                {
                        "address": "2a02:1811:e40e:1400::f510",
                        "mask": 128,
                        "preferred": 65009,
                        "valid": 231870
                },
                {
                        "address": "2a02:1811:e40e:1400:8234:28ff:fe38:f046",
                        "mask": 64,
                        "preferred": 86268,
                        "valid": 232505
                }
        ],
        "ipv6-prefix": [
                {
                        "address": "2a02:1811:e40e:1420::",
                        "mask": 60,
                        "preferred": 65009,
                        "valid": 237809,
                        "class": "wan6",
                        "assigned": {
                                "lan": {
                                        "address": "2a02:1811:e40e:1420::",
                                        "mask": 60
                                }
                        }
                }
        ],
        "ipv6-prefix-assignment": [

        ],
        "route": [
                {
                        "target": "2a02:1811:e40e:1400::",
                        "mask": 64,
                        "nexthop": "::",
                        "metric": 256,
                        "valid": 232505,
                        "source": "::/0"
                },
                {
                        "target": "fd64:fad1:7064:aaa9::",
                        "mask": 64,
                        "nexthop": "fe80::1e53:f9ff:fe0a:18ab",
                        "metric": 512,
                        "valid": 1518,
                        "source": "2a02:1811:e40e:1420::/60"
                },
                {
                        "target": "fd64:fad1:7064:aaa9::",
                        "mask": 64,
                        "nexthop": "fe80::1e53:f9ff:fe0a:18ab",
                        "metric": 512,
                        "valid": 1518,
                        "source": "2a02:1811:e40e:1400:8234:28ff:fe38:f046/64"
                },
                {
                        "target": "fd64:fad1:7064:aaa9::",
                        "mask": 64,
                        "nexthop": "fe80::1e53:f9ff:fe0a:18ab",
                        "metric": 512,
                        "valid": 1518,
                        "source": "2a02:1811:e40e:1400::f510/128"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::6802:b8ff:fe77:c298",
                        "metric": 384,
                        "valid": 1668,
                        "source": "2a02:1811:e40e:1420::/60"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::6802:b8ff:fe77:c298",
                        "metric": 384,
                        "valid": 1668,
                        "source": "2a02:1811:e40e:1400:8234:28ff:fe38:f046/64"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::6802:b8ff:fe77:c298",
                        "metric": 384,
                        "valid": 1668,
                        "source": "2a02:1811:e40e:1400::f510/128"
                }
        ],
        "dns-server": [
                "2a02:1800:100::45:1",
                "2a02:1800:100::45:2"
        ],
        "dns-search": [
                "telenet.be"
        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {
                "passthru": "001700202a0218000100000000000000004500012a0218000100000000000000004500020018000c0774656c656e657402626500001f00202a0218000100000200000000000000022a021800010000020000000000000003"
        }
}

I'm starting to think the problem is with odhcpd:

Fri Jan 18 09:50:21 2013 daemon.err odhcpd[874]: Failed to send to ff02::1%lan@br-lan (Address not available)
Fri Jan 18 09:50:21 2013 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) 192.168.1.146 74:78:27:d9:8d:db
Fri Jan 18 09:50:21 2013 daemon.warn dnsmasq-dhcp[1]: Ignoring domain xxxxxxxx for DHCP host name BEWKS040
Fri Jan 18 09:50:21 2013 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan) 192.168.1.146 74:78:27:d9:8d:db BEWKS040

I now have only one pc connected to the LAN network.

Does it work if you restart the odhcpd service? What happens when you run ping ff02::1%br-lan on the command line, do you get an Address not available error as well?

ping ff02::1%br-lan
PING ff02::1%br-lan (ff02::1%4): 56 data bytes
64 bytes from fe80::8034:28ff:fe38:f046: seq=0 ttl=64 time=0.384 ms
64 bytes from fe80::8034:28ff:fe38:f046: seq=1 ttl=64 time=0.440 ms
64 bytes from fe80::8034:28ff:fe38:f046: seq=2 ttl=64 time=0.288 ms
64 bytes from fe80::8034:28ff:fe38:f046: seq=3 ttl=64 time=0.393 ms

restarting odhcpd didn't do anything.

Hm, seems the router is the only IPv6 host on the segment...

Is that one PC connected to the LAN network IPv6 capable? Does it have an IPv6 link local address? The ff02::1 is the all-nodes multicast address, when you ping it, you should get replies from all IPv6 hosts, not just from the bridge itself.

I did a 'reset to factory' of my modem and a reboot of the firewall;

# ping ff02::1%br-lan
PING ff02::1%br-lan (ff02::1%4): 56 data bytes
64 bytes from fe80::8034:28ff:fe38:f046: seq=0 ttl=64 time=0.338 ms
64 bytes from fe80::211:32ff:fe2f:4577: seq=0 ttl=64 time=0.739 ms (DUP!)
64 bytes from fe80::9259:afff:fe62:f457: seq=0 ttl=64 time=0.783 ms (DUP!)
64 bytes from fe80::7a8a:20ff:fe48:d315: seq=0 ttl=64 time=0.823 ms (DUP!)
64 bytes from fe80::7a8a:20ff:fe48:d28f: seq=0 ttl=64 time=0.852 ms (DUP!)
64 bytes from fe80::b674:400b:514b:77de: seq=0 ttl=64 time=0.887 ms (DUP!)
64 bytes from fe80::240:adff:feb1:2fc: seq=0 ttl=64 time=0.929 ms (DUP!)
64 bytes from fe80::7683:c2ff:fecc:1e66: seq=0 ttl=64 time=0.954 ms (DUP!)
64 bytes from fe80::3687:8625:b4bb:f85b: seq=0 ttl=64 time=0.987 ms (DUP!)
64 bytes from fe80::da6c:63ff:fe5d:7c58: seq=0 ttl=64 time=5.189 ms (DUP!)
64 bytes from fe80::10a5:6ee6:9104:291d: seq=0 ttl=64 time=19.615 ms (DUP!)
64 bytes from fe80::86:f3e4:d3c2:e6fd: seq=0 ttl=64 time=19.707 ms (DUP!)
64 bytes from fe80::ae67:84ff:fe04:71d6: seq=0 ttl=64 time=29.558 ms (DUP!)
64 bytes from fe80::1e53:f9ff:fe0a:18ab: seq=0 ttl=64 time=30.285 ms (DUP!)
64 bytes from fe80::7a8a:d36a:76a0:a4d: seq=0 ttl=64 time=38.759 ms (DUP!)
64 bytes from fe80::daeb:46ff:feb2:a873: seq=0 ttl=64 time=111.848 ms (DUP!)
64 bytes from fe80::4c79:795f:b8b:93a1: seq=0 ttl=64 time=132.056 ms (DUP!)
64 bytes from fe80::ae67:84ff:fe1d:b12: seq=0 ttl=64 time=257.956 ms (DUP!)
64 bytes from fe80::1079:de73:b6c6:2a64: seq=0 ttl=64 time=263.119 ms (DUP!)

It looks better now.

not sure but I think you need to configure some IPv6 on the LAN

I have

config interface 'lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.168.1'
        option ip6prefix '2a02:1807:3820:a01::/64'
        option ip6gw 'fe80::1'
        list ip6addr 'fe80::1/128'
        list ip6addr '2a02:1807:3820:a01::1/64'
        option device 'br-lan'

where for convenience I have a simple link local fe80::1 gateway address for LAN

Also, maybe behavior is 22.03.0-rc specific.

I do have now a working config:

/etc/config/network:

...
config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
...
config interface 'wan'
        option device 'eth0'
        option proto 'dhcp'

config interface 'wan6'
        option device 'eth0'
        option proto 'dhcpv6'
...

/etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'
        option rebind_protection '1'

config dhcp 'lan'
        option interface 'lan'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'
        option start '50'
        option limit '200'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'
1 Like

I do have now a working config

Can you, perhaps, for reference to help other users with same provider, modem and contract, summarize just the changes required to get your non-working config working?
Have a nice day

1 Like

Summary:
Provider: Telenet Belgium
Modem: CV8560E

Paste in mijn.telenet.be the correct mac address in the bridging field.

/etc/config/dhcp:

config dhcp 'lan'
        option interface 'lan'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

I had to reboot my modem en firewall to get it working.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.