No-ip.com doesn't show in DDNS list after install ddns-scripts-noip

Hello.
Could anyone help me on this?
My router: Redmi AC2100
Firmware Version: OpenWrt R20.9.15/hfy166 Ver.D201009 / LuCI Master (git-20.256.12360-1a54222)
Kernel Version: 5.4.68

I have setup DDNS with no-ip.com before and it works flawlessly. Recently, I have updated new version for the router and after that no-ip.com is missing in DDNS IPv4 list even I have installed ddns-scripts-noip

I also tried to revert to back up of its old version but the problem is still persisted.


I have searched all over the old topics but no one has the same error as me.
Thank you.

Hi,
I can't read your screens (too small). But, I wrote an little tutorial as I configured my OpenWRT. Look if it helps (I'm using Afraid). I don't remember if I tried it with noip and had no success.

OpenWRT - Add DDNS

  1. This document was based on the following document:
  2. http://ptspts.blogspot.com.br/2009/06/how-to-configure-dynamic-dns-dyndns.html
    Install packages (requires 68 KB):
    opkg update
    opkg install luci-app-ddns
  3. Restart the router.
  4. Open Services / Dynamic DNS.
  5. Enter a name for the service to be created and click the Add button (freedns_afraid).
  6. Configure the service:
    o Basic settings:
  7. Mark as enabled
  8. Inform the Hostname:
    yourDNS.ignorelist.com
  9. Select IP-V4-Address
  10. Select the provider afraid.org-keyauth
  11. Inform [String-PASSWORD]
    In freedns_afraid is a string that needs to be consulted in Dynamic-DNS / Direct URL
    ATTENTION: it is different for each Hostname in Affraid
    o Advanced settings:
  12. IP address source: Network
  13. Network: WAN
  14. DNS-Server: leave blank
  15. PROXY-Server: leave blank
  16. Log to syslog: Notice
  17. Enable Log to file
    o Timer settings:
  18. Check Interval: 10 minutes
  19. Force Interval: 72 horas
  20. Error Retry Counter: 0 (keep trying)
  21. Error Retry Interval: 60 seconds
    Save and apply
  22. Start the service by clicking Start
  23. Unused services can be removed

If you want to fix it up to work on a router not exposed on the internet, just edit it in the file:
vi /usr/lib/ddns/dynamic_dns_updater.sh
In line 125 approximately, after the get_local_ip line, include a line:
get_local_ip LOCAL_IP
LOCAL_IP=$(wget -qO - http://ipv4.icanhazip.com)
logger "================= This is my internet IP: " $LOCAL_IP
As the router is behind the firewall, it must have a local IP, which is captured by get_local_ip. We replaced the content using icanzip.

Best,
carliedu - São Paulo - Brazil

Click on the picture to make it bigger.

I have made this, but still couldn't read.
Now I had saved it to my notebook and opened it with Photos and enlarged it.

I remember that I had problems a few months ago, and gave up. I don't remember why.
I'm using Afraid and it works very well.

I could update it now through http GET method.
But it is still weird when the option doesn't appear like before.

I'm also using no-ip.com with the following packages:
"ddns-scripts_no-ip_com" and "luci-app-ddns"
Works as expected.

A curiosity.
Is your NOIP account free?
Have you to login and confirm every month?

It's the free one with monthly confirmation required.

I remembered why I don't use NOIP.
Is because this monthly confirmation.
Affraid works very well without confirmation.

In recent master, the package name has been changed to ddns-scripts-noip, which needs to be installed in addition to the basic ddns-scripts package.

1 Like