No internet with fresh install on Linksys WRT1900ACSV2 (AT&T)


I'm trying to use my Linksys WRT1900ACSV2 with AT&T's BGW210-700 gateway. I installed OpenWRT using this guide because I was getting poor performance out of the 2.4 GHz band using the stock firmware and another forum post for someone else's similar problem suggested OpenWRT would help.

After following the guide, I've setup 5 GHz and 2.4 GHz wifi, as well as ssh connectivity and a custom root password. Unfortunately, I don't get any internet access through 5 GHz, 2.4 GHz, or ethernet. My router was working with the BGW210-700 gateway using the stock drivers, and I didn't change any of its settings to my knowledge since installing OpenWRT.

Any help is appreciated! I am new and honestly have very little knowledge of OpenWRT, but I am a programmer. So fine with technical help. :slight_smile:

Here's some info that could be relevant:

Firmware version: OpenWRT 18.06.4 r7808-ef686b7292 / LuCI openwrt-18.06 branch (git-19.170.32094-4d6d8bc)
Kernel version: 4.14.131

My /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr ''
        option netmask ''

config globals 'globals'
        option ula_prefix 'fd6b:3c85:c455::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr ''
        option netmask ''
        option ip6assign '60'

config interface 'wan'
        option proto 'dhcp'
        option ifname 'eth1.2'

config interface 'wan6'
        option ifname 'eth1.2'
        option proto 'dhcpv6'

config switch
       option name 'switch0'
       option reset '1'
       option enable_vlan '1'

config switch_vlan
       option device 'switch0'
       option vlan '1'
       option ports '0 1 2 3 5t'

config switch_vlan
       option device 'switch0'
       option vlan '2'
       option ports '4 6t'

The WAN MAC address might have beem changed in OpenWrt

According to the WRT1900ACS device page, LAN is connected to eth1.1 and
WAN to eth0.2.

Please post the status of the OpenWrt router's WAN interface.
Can you ping from OpenWrt to the AT&T gateway or to an outside host (say

On the LuCI Interfaces page, under WAN (eth1.2), I see:

Protocol: DHCP client
Uptime: 0h 8m 17s
MAC: 60:38:E0:--:--:--
RX: 20.52 MB (6048 Pkts.)
TX: 750.63 KB (2974 Pkts.)
IPv4: 68.--.---.--/22

If there was some other status you wanted to see, I'll need a tip as to how to grab it.

I was able to ping without any packet loss, times about 6 ms for each set of 64 bytes.

Pinging the WAN IPv4 address listed above (afaik, that's the gateway's address) also reported no packet loss. Times about 0.05 ms.

Sometimes you just need to power cycle the modem/gateway so it can get the new mac of the router, worth a try (if you haven't already).

OK, since you can ping from the OpenWrt router itself, this is a sign that your internet connection works in principle.

Have you tried to ping from a client connected to the OpenWrt router?

Desktop connected directly to the OpenWrt router via ethernet successfully pings, as does my laptop connected to the 2.4 GHz wifi network.

On the 5 GHz wifi network, my laptop was complaining there's "No route to host" when trying to ping

Request timeout for icmp_seq 3
ping: sendto: No route to host

I tried power cycling both the gateway and the router previously. As far as I can tell, the MAC address of the router didn't change with the OpenWrt install.

You might post the output of cat /etc/config/wireless to see if there's anything unusual there (make sure to remove passwords).

Actually, I think I've fixed the issue.

Unchecking "Use DNS servers advertised by peer" under Interfaces > WAN and replacing the servers with either OpenDNS ( and or Cloudflare DNS ( and gets me to the internet across all the interfaces.

Thanks for your help everyone!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.