No Internet - Netgear R6120 on Australian FTTP (Fibre to the Premises) (IPoE)

Hi everyone

first of all, thank you for reading my post and trying to help, I appreciate it!
Now, regarding my issue...

I recently bought a Netgear R6120 and successfully flashed it with OpenWrt. The flash with nmrpflash took several attempts to succeed and unlike the OpenWRT flash instructions I used a different command:

sudo ./nmrpflash -i eth0 -f openwrt-ramips-mt76x8-netgear_r6120-squashfs-factory.img -T 1500

I performed this by quickly turning the connected netgear router on and off. It takes a few attempts to make it work, so patience is advised.
Then I connected it's WAN port (labelled "Internet") to the NBN gear ( NBN is an Australian company that build the broadband network in Australia) and connected my laptop via LAN port.

From my research, I understand the NBN gear is basically a modem that is built-in in every apartment that has FTTP. With my ISP-provided router I did not have to put in any login credentials, I just connect it to the NBN gear via WAN port and connect my laptop via LAN port to the router and it works out-of-the-box. My ISP is AussieBroadband.

However, with this setup I didn't get any internet connection and the NBN gear did not show a blinking yellow light (which indicates a working connection), it just stays green.

Attempts to resolve:
I figured out the default settings probably won't work with this setup, so I checked the for Australia (OpenWrt user guide) which does not list my connection type (NBN FTTP).

I read in the OpenWRT archived forum that one has to configure the WAN interface as DHCP client so I changed the setting via LuCI but that did not work for me.

Can anyone (perhaps Australian users with a similar setup) see what I'm doing wrong here?

i'm with aussiebroadband... and while their support has dropped a bit in the last 12 months they are still likely the best in the business so give them a call... unlike most ISP's they are usually happy to do their best with whatever gear you have... ( providing you know where to find the basic settings )...

off the top of my head... some of the fibre/FTTP gear runs over ppp... I run HFC/Arris which is raw dhcp... the other common issue is needing to call them or power off the NTD/modem for 15mins if you change the device / MAC you are connecting to the modem...

afaik... dhcp on wan is the default... I would have guessed that you need pppoe but if you say your laptop didn't need it then it would be the dissimilar mac issue...

the only other parameter that varies on most wired NBN links, vlan membership is usually on some ADSL/VDSL... and I doubt that's involved here...


Hi wulfy23

thank you for the swift response! Although your solution did not work for me (same result after disconnecting for 20 minutes), it pointed me in the right direction. The actual solution is to spoof the MAC address of the router provided by my ISP. I detail my solution below so whoever runs into this problem again will be able to solve it.

On Linux I ran the following command to find out the MAC address of my previous router (has to be run while it is connected obviously).

ip neigh

I copied the MAC address listed in the output in the line for

Then I disconnected my old router and set up my new router as described at the start.

Inside of LuCl, I went to Network -> Interfaces and then go to Edit -> Advanced Settings -> Override MAC address and inserted it.

My interface configuration is as follows:
LAN (br-lan) set to static address
WAN (eth0.1) set to DHCP client
WAN6 (br-wan6) set to DHCP client

And that's it, after the changes are applied, it should work :slight_smile:

I can't believe one has to resort to MAC spoofing to make this work, hope this post saves some time for other folks.

1 Like

glad it's resolved... the usual advice is 30 mins, I got a bit lazy with 15... seems that the 30mins is more certain... and yes, spoofing the mac for anybody who uses more than one router is the preferred solution...

people often stuff up connecting things... ( i did this once )... and connecting the NTD/modem directly to say... your network switch with all devices in your premises competing for the public ip... and spewing god knows what onto the line... is problematic for ISP's and your local network...

MAC learning mechanisms of LNS/NTD devices provide a basic means to isolate these configurations... but it would be nice of they had a blinking light to let you know of such a status...


I'll add information about Telstra FTTN settings to the wiki this evening.
It's very simple, but might as well document it for the benefit of down under.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.