No internet from router

Hi, so I’m pulling my hair out on this one…

I have a modem (zyxel EX5601-T1) in router mode:

Ip 192.168.1.1, mask 255.255.255.0
I have a static dhcp lease for my router (openwrt) behind it: 192.168.1.2

Router is a Netgear r7500 v1

When connecting my laptop to the modem everything works as expected.

When connecting my laptop to the router, internet works for a minute or two and then shuts down.

I have a freshly installed openwrt 24.10.0, only changed lan ip to 192.168.2.1.

Will post some configuration shortly.

Connect how?

Where?

1 Like

So configuration when internet is OK:

root@OpenWrt:~# uci export network
package network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fda5:7dd6:5a09::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

root@OpenWrt:~# uci export dhcp
package dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'
        option filter_aaaa '0'
        option filter_a '0'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

root@OpenWrt:~# uci export firewall
package firewall

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

root@OpenWrt:~# ip -4 addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
8: wan@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 192.168.1.2/24 brd 192.168.1.255 scope global wan
       valid_lft forever preferred_lft forever
15: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 192.168.2.1/24 brd 192.168.2.255 scope global br-lan
       valid_lft forever preferred_lft forever
root@OpenWrt:~# ip -4 ro li tab all
default via 192.168.1.1 dev wan  src 192.168.1.2
192.168.1.0/24 dev wan scope link  src 192.168.1.2
192.168.2.0/24 dev br-lan scope link  src 192.168.2.1
local 127.0.0.0/8 dev lo table local scope host  src 127.0.0.1
local 127.0.0.1 dev lo table local scope host  src 127.0.0.1
broadcast 127.255.255.255 dev lo table local scope link  src 127.0.0.1
local 192.168.1.2 dev wan table local scope host  src 192.168.1.2
broadcast 192.168.1.255 dev wan table local scope link  src 192.168.1.2
local 192.168.2.1 dev br-lan table local scope host  src 192.168.2.1
broadcast 192.168.2.255 dev br-lan table local scope link  src 192.168.2.1
root@OpenWrt:~# ip -4 ru
0:      from all lookup local
32766:  from all lookup main
32767:  from all lookup default
root@OpenWrt:~# ls -l  /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/* ; head -n -0
/etc/resolv.* /tmp/resolv.* /tmp/resolv.*/* ; \
>
lrwxrwxrwx    1 root     root            16 Feb  3 23:09 /etc/resolv.conf -> /tmp/resolv.conf
-rw-r--r--    1 root     root            47 May  3 07:37 /tmp/resolv.conf
-rw-r--r--    1 root     root            51 May  3 07:37 /tmp/resolv.conf.d/resolv.conf.auto

/tmp/resolv.conf.d:
-rw-r--r--    1 root     root            51 May  3 07:37 resolv.conf.auto
==> /etc/resolv.conf <==
search lan
nameserver 127.0.0.1
nameserver ::1

==> /tmp/resolv.conf <==
search lan
nameserver 127.0.0.1
nameserver ::1

==> /tmp/resolv.conf.d <==
head: /tmp/resolv.conf.d: I/O error

==> /tmp/resolv.conf.d/resolv.conf.auto <==
# Interface wan
nameserver 192.168.1.1
search home
root@OpenWrt:~# ping -c 3 8.8.8.8; ping -c 3 www.google.com
PING 8.8.8.8 (8.8.8.8): 56 data bytes
64 bytes from 8.8.8.8: seq=0 ttl=119 time=4.947 ms
64 bytes from 8.8.8.8: seq=1 ttl=119 time=4.792 ms
64 bytes from 8.8.8.8: seq=2 ttl=119 time=5.227 ms

--- 8.8.8.8 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 4.792/4.988/5.227 ms
PING www.google.com (142.250.179.164): 56 data bytes
64 bytes from 142.250.179.164: seq=0 ttl=119 time=4.682 ms
64 bytes from 142.250.179.164: seq=1 ttl=119 time=4.553 ms
64 bytes from 142.250.179.164: seq=2 ttl=119 time=4.606 ms

--- www.google.com ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 4.553/4.613/4.682 ms

Then I usually do a www.speedtest.net. Internet drops:

BusyBox v1.36.1 (2025-02-03 23:09:37 UTC) built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 24.10.0, r28427-6df0e3d02a
 -----------------------------------------------------
root@OpenWrt:~# ubus call system board
{
        "kernel": "6.6.73",
        "hostname": "OpenWrt",
        "system": "ARMv7 Processor rev 0 (v7l)",
        "model": "Netgear Nighthawk X4 R7500",
        "board_name": "netgear,r7500",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "24.10.0",
                "revision": "r28427-6df0e3d02a",
                "target": "ipq806x/generic",
                "description": "OpenWrt 24.10.0 r28427-6df0e3d02a",
                "builddate": "1738624177"
        }
}
root@OpenWrt:~# uci export network
package network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fda5:7dd6:5a09::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

root@OpenWrt:~# uci export dhcp
package dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'
        option filter_aaaa '0'
        option filter_a '0'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

root@OpenWrt:~# uci export firewall
package firewall

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

root@OpenWrt:~# ip -4 addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
8: wan@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 192.168.1.2/24 brd 192.168.1.255 scope global wan
       valid_lft forever preferred_lft forever
15: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 192.168.2.1/24 brd 192.168.2.255 scope global br-lan
       valid_lft forever preferred_lft forever
root@OpenWrt:~# ip -4 ro li tab all
default via 192.168.1.1 dev wan  src 192.168.1.2
192.168.1.0/24 dev wan scope link  src 192.168.1.2
192.168.2.0/24 dev br-lan scope link  src 192.168.2.1
local 127.0.0.0/8 dev lo table local scope host  src 127.0.0.1
local 127.0.0.1 dev lo table local scope host  src 127.0.0.1
broadcast 127.255.255.255 dev lo table local scope link  src 127.0.0.1
local 192.168.1.2 dev wan table local scope host  src 192.168.1.2
broadcast 192.168.1.255 dev wan table local scope link  src 192.168.1.2
local 192.168.2.1 dev br-lan table local scope host  src 192.168.2.1
broadcast 192.168.2.255 dev br-lan table local scope link  src 192.168.2.1
root@OpenWrt:~# ip -4 ru
0:      from all lookup local
32766:  from all lookup main
32767:  from all lookup default
root@OpenWrt:~# ls -l  /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/* ; head -n -0
/etc/resolv.* /tmp/resolv.* /tmp/resolv.*/* ;
lrwxrwxrwx    1 root     root            16 Feb  3 23:09 /etc/resolv.conf -> /tmp/resolv.conf
-rw-r--r--    1 root     root            47 May  3 07:37 /tmp/resolv.conf
-rw-r--r--    1 root     root            51 May  3 07:37 /tmp/resolv.conf.d/resolv.conf.auto

/tmp/resolv.conf.d:
-rw-r--r--    1 root     root            51 May  3 07:37 resolv.conf.auto
==> /etc/resolv.conf <==
search lan
nameserver 127.0.0.1
nameserver ::1

==> /tmp/resolv.conf <==
search lan
nameserver 127.0.0.1
nameserver ::1

==> /tmp/resolv.conf.d <==
head: /tmp/resolv.conf.d: I/O error

==> /tmp/resolv.conf.d/resolv.conf.auto <==
# Interface wan
nameserver 192.168.1.1
search home
root@OpenWrt:~# ping -c 3 8.8.8.8; ping -c 3 www.google.com
PING 8.8.8.8 (8.8.8.8): 56 data bytes

--- 8.8.8.8 ping statistics ---
3 packets transmitted, 0 packets received, 100% packet loss
ping: bad address 'www.google.com'

I connect my router to one of the lan ports of the modem, wan port on the router.
I changed lan ip to 192.168.2.1 in LuCi - Network - Interfaces - lan

When I restart the wan interface it only broadcasts DHCP, but never receives anything:

Sat May  3 08:00:08 2025 daemon.notice netifd: wan (9872): udhcpc: received SIGTERM
Sat May  3 08:00:08 2025 daemon.notice netifd: wan (9872): udhcpc: unicasting a release of 192.168.1.2 to 192.168.1.1
Sat May  3 08:00:08 2025 daemon.notice netifd: wan (9872): udhcpc: sending release
Sat May  3 08:00:08 2025 daemon.notice netifd: wan (9872): udhcpc: entering released state
Sat May  3 08:00:08 2025 daemon.notice netifd: wan (9872): Command failed: ubus call network.interface notify_proto { "action": 0, "link-up": false, "keep": false, "interface": "wan" } (Permission denied)
Sat May  3 08:00:08 2025 daemon.notice netifd: Interface 'wan' is now down
Sat May  3 08:00:09 2025 daemon.notice netifd: Interface 'wan' is setting up now
Sat May  3 08:00:09 2025 daemon.warn dnsmasq[1]: no servers found in /tmp/resolv.conf.d/resolv.conf.auto, will retry
Sat May  3 08:00:09 2025 daemon.notice netifd: wan (10655): udhcpc: started, v1.36.1
Sat May  3 08:00:09 2025 daemon.notice netifd: wan (10655): udhcpc: broadcasting discover
Sat May  3 08:00:12 2025 daemon.notice netifd: wan (10655): udhcpc: broadcasting discover
Sat May  3 08:00:15 2025 daemon.notice netifd: wan (10655): udhcpc: broadcasting discover

When doing /etc/init.d/network restart it works again. For a few minutes.

Does this occur without the static lease you created in the upstream router?

Can we see the logs after this?

There's nothing that seems apparent as a cause - are you undertaking any other steps after that?

Are you by any chance connecting the R7500 to the EXs LAN side 2.5GbE port ?

These are the logs after /etc/init.d/network restart:

Sat May  3 08:47:00 2025 daemon.notice netifd: Interface 'lan' is now down
Sat May  3 08:47:00 2025 daemon.warn odhcpd[10516]: No default route present, overriding ra_lifetime to 0!
Sat May  3 08:47:00 2025 daemon.err odhcpd[10516]: Failed to send to ff02::1%lan@br-lan (Network unreachable)
Sat May  3 08:47:00 2025 kern.info kernel: [ 6789.175501] br-lan: port 4(lan4) entered disabled state
Sat May  3 08:47:00 2025 kern.info kernel: [ 6789.176359] qca8k 37000000.mdio-mii:10 lan1: left allmulticast mode
Sat May  3 08:47:00 2025 kern.info kernel: [ 6789.179563] qca8k 37000000.mdio-mii:10 lan1: left promiscuous mode
Sat May  3 08:47:00 2025 kern.info kernel: [ 6789.186040] br-lan: port 1(lan1) entered disabled state
Sat May  3 08:47:03 2025 daemon.warn odhcpd[1382]: No default route present, overriding ra_lifetime to 0!
Sat May  3 08:47:03 2025 daemon.info dnsmasq[1]: read /etc/hosts - 12 names
Sat May  3 08:47:03 2025 daemon.err odhcpd[1382]: Failed to send to ff02::1%lan@br-lan (Network unreachable)
Sat May  3 08:47:03 2025 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 4 names
Sat May  3 08:47:03 2025 daemon.warn odhcpd[1382]: No default route present, overriding ra_lifetime to 0!
Sat May  3 08:47:03 2025 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 0 names
Sat May  3 08:47:03 2025 daemon.err odhcpd[1382]: Failed to send to ff02::1%lan@br-lan (Network unreachable)
Sat May  3 08:47:03 2025 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Sat May  3 08:47:14 2025 kern.info kernel: [ 6803.432750] qca8k 37000000.mdio-mii:10 lan2: left allmulticast mode
Sat May  3 08:47:14 2025 kern.info kernel: [ 6803.432794] qca8k 37000000.mdio-mii:10 lan2: left promiscuous mode
Sat May  3 08:47:14 2025 kern.info kernel: [ 6803.437995] br-lan: port 2(lan2) entered disabled state
Sat May  3 08:47:23 2025 kern.info kernel: [ 6812.642501] qca8k 37000000.mdio-mii:10 lan3: left allmulticast mode
Sat May  3 08:47:23 2025 kern.info kernel: [ 6812.642543] qca8k 37000000.mdio-mii:10 lan3: left promiscuous mode
Sat May  3 08:47:23 2025 kern.info kernel: [ 6812.647738] br-lan: port 3(lan3) entered disabled state
Sat May  3 08:47:30 2025 kern.info kernel: [ 6819.511160] qca8k 37000000.mdio-mii:10 lan4: left allmulticast mode
Sat May  3 08:47:30 2025 kern.info kernel: [ 6819.511202] ipq806x-gmac-dwmac 37400000.ethernet eth1: left allmulticast mode
Sat May  3 08:47:30 2025 kern.info kernel: [ 6819.516247] qca8k 37000000.mdio-mii:10 lan4: left promiscuous mode
Sat May  3 08:47:30 2025 kern.info kernel: [ 6819.523802] br-lan: port 4(lan4) entered disabled state
Sat May  3 08:47:32 2025 kern.info kernel: [ 6820.954237] qca8k 37000000.mdio-mii:10 lan4: Link is Down
Sat May  3 08:47:37 2025 daemon.notice netifd: Interface 'lan' is disabled
Sat May  3 08:47:37 2025 daemon.notice netifd: bridge 'br-lan' link is down
Sat May  3 08:47:37 2025 daemon.notice netifd: Interface 'lan' has link connectivity loss
Sat May  3 08:47:37 2025 daemon.notice netifd: Interface 'loopback' is now down
Sat May  3 08:47:37 2025 daemon.notice netifd: Interface 'loopback' is disabled
Sat May  3 08:47:37 2025 daemon.notice netifd: Network device 'lan4' link is down
Sat May  3 08:47:37 2025 daemon.notice netifd: Network device 'lo' link is down
Sat May  3 08:47:37 2025 daemon.notice netifd: Interface 'loopback' has link connectivity loss
Sat May  3 08:47:37 2025 daemon.notice netifd: wan (11744): udhcpc: received SIGTERM
Sat May  3 08:47:37 2025 daemon.notice netifd: wan (11744): udhcpc: unicasting a release of 192.168.1.2 to 192.168.1.1
Sat May  3 08:47:37 2025 daemon.notice netifd: wan (11744): udhcpc: sending release
Sat May  3 08:47:37 2025 daemon.notice netifd: wan (11744): udhcpc: entering released state
Sat May  3 08:47:37 2025 daemon.notice netifd: Interface 'wan6' is now down
Sat May  3 08:47:37 2025 daemon.warn dnsmasq[1]: no servers found in /tmp/resolv.conf.d/resolv.conf.auto, will retry
Sat May  3 08:47:37 2025 daemon.notice netifd: wan (11744): Command failed: ubus call network.interface notify_proto { "action": 0, "link-up": false, "keep": false, "interface": "wan" } (Permission denied)
Sat May  3 08:47:37 2025 daemon.notice netifd: Interface 'wan' is now down
Sat May  3 08:47:37 2025 daemon.info dnsmasq[1]: exiting on receipt of SIGTERM
Sat May  3 08:47:37 2025 kern.info kernel: [ 6826.408097] qca8k 37000000.mdio-mii:10 wan: Link is Down
Sat May  3 08:47:37 2025 daemon.err procd: Got unexpected signal 1
Sat May  3 08:47:37 2025 kern.info kernel: [ 6826.445255] ipq806x-gmac-dwmac 37200000.ethernet eth0: Link is Down
Sat May  3 08:47:37 2025 daemon.notice netifd: Interface 'wan' is disabled
Sat May  3 08:47:37 2025 daemon.notice netifd: Interface 'wan6' is disabled
Sat May  3 08:47:37 2025 daemon.notice netifd: Network device 'wan' link is down
Sat May  3 08:47:37 2025 daemon.notice netifd: Interface 'wan' has link connectivity loss
Sat May  3 08:47:37 2025 daemon.notice netifd: Interface 'wan6' has link connectivity loss
Sat May  3 08:47:37 2025 daemon.notice netifd: Network device 'eth0' link is down
Sat May  3 08:47:37 2025 daemon.info dnsmasq[1]: started, version 2.90 cachesize 1000
Sat May  3 08:47:37 2025 daemon.info dnsmasq[1]: DNS service limited to local subnets
Sat May  3 08:47:37 2025 daemon.info dnsmasq[1]: compile time options: IPv6 GNU-getopt no-DBus UBus no-i18n no-IDN DHCP no-DHCPv6 no-Lua TFTP no-conntrack no-ipset no-nftset no-auth no-cryptohash no-DNSSEC no-ID loop-detect inotify dumpfile
Sat May  3 08:47:37 2025 daemon.info dnsmasq[1]: UBus support enabled: connected to system bus
Sat May  3 08:47:37 2025 daemon.info dnsmasq[1]: using only locally-known addresses for test
Sat May  3 08:47:37 2025 daemon.info dnsmasq[1]: using only locally-known addresses for onion
Sat May  3 08:47:37 2025 daemon.info dnsmasq[1]: using only locally-known addresses for localhost
Sat May  3 08:47:37 2025 daemon.info dnsmasq[1]: using only locally-known addresses for local
Sat May  3 08:47:37 2025 daemon.info dnsmasq[1]: using only locally-known addresses for invalid
Sat May  3 08:47:37 2025 daemon.info dnsmasq[1]: using only locally-known addresses for bind
Sat May  3 08:47:37 2025 daemon.info dnsmasq[1]: using only locally-known addresses for lan
Sat May  3 08:47:37 2025 daemon.warn dnsmasq[1]: no servers found in /tmp/resolv.conf.d/resolv.conf.auto, will retry
Sat May  3 08:47:37 2025 daemon.info dnsmasq[1]: read /etc/hosts - 12 names
Sat May  3 08:47:37 2025 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 0 names
Sat May  3 08:47:37 2025 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 0 names
Sat May  3 08:47:38 2025 user.notice : Added device handler type: bonding
Sat May  3 08:47:38 2025 user.notice : Added device handler type: 8021ad
Sat May  3 08:47:38 2025 user.notice : Added device handler type: 8021q
Sat May  3 08:47:38 2025 user.notice : Added device handler type: macvlan
Sat May  3 08:47:38 2025 user.notice : Added device handler type: veth
Sat May  3 08:47:38 2025 user.notice : Added device handler type: bridge
Sat May  3 08:47:38 2025 user.notice : Added device handler type: Network device
Sat May  3 08:47:38 2025 user.notice : Added device handler type: tunnel
Sat May  3 08:47:39 2025 kern.info kernel: [ 6828.701580] ipq806x-gmac-dwmac 37200000.ethernet eth0: Register MEM_TYPE_PAGE_POOL RxQ-0
Sat May  3 08:47:39 2025 kern.info kernel: [ 6828.702464] dwmac1000: Master AXI performs any burst length
Sat May  3 08:47:39 2025 kern.info kernel: [ 6828.708752] ipq806x-gmac-dwmac 37200000.ethernet eth0: No Safety Features support found
Sat May  3 08:47:39 2025 kern.info kernel: [ 6828.724161] ipq806x-gmac-dwmac 37200000.ethernet eth0: IEEE 1588-2008 Advanced Timestamp supported
Sat May  3 08:47:39 2025 kern.info kernel: [ 6828.724355] ipq806x-gmac-dwmac 37200000.ethernet eth0: registered PTP clock
Sat May  3 08:47:39 2025 kern.info kernel: [ 6828.732122] ipq806x-gmac-dwmac 37200000.ethernet eth0: configuring for fixed/rgmii link mode
Sat May  3 08:47:39 2025 kern.info kernel: [ 6828.739331] ipq806x-gmac-dwmac 37200000.ethernet eth0: Link is Up - 1Gbps/Full - flow control off
Sat May  3 08:47:40 2025 kern.info kernel: [ 6828.781569] qca8k 37000000.mdio-mii:10 lan1: configuring for phy/internal link mode
Sat May  3 08:47:40 2025 kern.info kernel: [ 6828.857237] br-lan: port 1(lan1) entered blocking state
Sat May  3 08:47:40 2025 kern.info kernel: [ 6828.857273] br-lan: port 1(lan1) entered disabled state
Sat May  3 08:47:40 2025 kern.info kernel: [ 6828.861386] qca8k 37000000.mdio-mii:10 lan1: entered allmulticast mode
Sat May  3 08:47:40 2025 kern.info kernel: [ 6828.866559] ipq806x-gmac-dwmac 37400000.ethernet eth1: entered allmulticast mode
Sat May  3 08:47:40 2025 daemon.notice netifd: Interface 'lan' is enabled
Sat May  3 08:47:40 2025 daemon.notice netifd: Interface 'lan' is setting up now
Sat May  3 08:47:40 2025 kern.info kernel: [ 6828.879876] qca8k 37000000.mdio-mii:10 lan1: entered promiscuous mode
Sat May  3 08:47:40 2025 daemon.notice netifd: Interface 'lan' is now up
Sat May  3 08:47:40 2025 kern.info kernel: [ 6828.920088] qca8k 37000000.mdio-mii:10 lan2: configuring for phy/internal link mode
Sat May  3 08:47:40 2025 kern.info kernel: [ 6829.001180] br-lan: port 2(lan2) entered blocking state
Sat May  3 08:47:40 2025 kern.info kernel: [ 6829.001223] br-lan: port 2(lan2) entered disabled state
Sat May  3 08:47:40 2025 kern.info kernel: [ 6829.005254] qca8k 37000000.mdio-mii:10 lan2: entered allmulticast mode
Sat May  3 08:47:40 2025 kern.info kernel: [ 6829.014037] qca8k 37000000.mdio-mii:10 lan2: entered promiscuous mode
Sat May  3 08:47:40 2025 kern.info kernel: [ 6829.045692] qca8k 37000000.mdio-mii:10 lan3: configuring for phy/internal link mode
Sat May  3 08:47:40 2025 user.notice firewall: Reloading firewall due to ifup of lan (br-lan)
Sat May  3 08:47:40 2025 kern.info kernel: [ 6829.103422] br-lan: port 3(lan3) entered blocking state
Sat May  3 08:47:40 2025 kern.info kernel: [ 6829.103468] br-lan: port 3(lan3) entered disabled state
Sat May  3 08:47:40 2025 kern.info kernel: [ 6829.107574] qca8k 37000000.mdio-mii:10 lan3: entered allmulticast mode
Sat May  3 08:47:40 2025 kern.info kernel: [ 6829.130264] qca8k 37000000.mdio-mii:10 lan3: entered promiscuous mode
Sat May  3 08:47:40 2025 kern.info kernel: [ 6829.161039] qca8k 37000000.mdio-mii:10 lan4: configuring for phy/internal link mode
Sat May  3 08:47:40 2025 kern.info kernel: [ 6829.241587] br-lan: port 4(lan4) entered blocking state
Sat May  3 08:47:40 2025 kern.info kernel: [ 6829.241629] br-lan: port 4(lan4) entered disabled state
Sat May  3 08:47:40 2025 kern.info kernel: [ 6829.245647] qca8k 37000000.mdio-mii:10 lan4: entered allmulticast mode
Sat May  3 08:47:40 2025 kern.info kernel: [ 6829.255309] qca8k 37000000.mdio-mii:10 lan4: entered promiscuous mode
Sat May  3 08:47:40 2025 daemon.notice netifd: Interface 'loopback' is enabled
Sat May  3 08:47:40 2025 daemon.notice netifd: Interface 'loopback' is setting up now
Sat May  3 08:47:40 2025 daemon.notice netifd: Interface 'loopback' is now up
Sat May  3 08:47:40 2025 kern.info kernel: [ 6829.285432] qca8k 37000000.mdio-mii:10 wan: configuring for phy/internal link mode
Sat May  3 08:47:40 2025 daemon.notice netifd: Interface 'wan' is enabled
Sat May  3 08:47:40 2025 daemon.notice netifd: Interface 'wan6' is enabled
Sat May  3 08:47:40 2025 daemon.notice netifd: Network device 'eth0' link is up
Sat May  3 08:47:40 2025 daemon.notice netifd: Network device 'lo' link is up
Sat May  3 08:47:40 2025 daemon.notice netifd: Interface 'loopback' has link connectivity
Sat May  3 08:47:41 2025 daemon.info dnsmasq[1]: exiting on receipt of SIGTERM
Sat May  3 08:47:41 2025 daemon.err procd: Got unexpected signal 1
Sat May  3 08:47:41 2025 daemon.info dnsmasq[1]: started, version 2.90 cachesize 1000
Sat May  3 08:47:41 2025 daemon.info dnsmasq[1]: DNS service limited to local subnets
Sat May  3 08:47:41 2025 daemon.info dnsmasq[1]: compile time options: IPv6 GNU-getopt no-DBus UBus no-i18n no-IDN DHCP no-DHCPv6 no-Lua TFTP no-conntrack no-ipset no-nftset no-auth no-cryptohash no-DNSSEC no-ID loop-detect inotify dumpfile
Sat May  3 08:47:41 2025 daemon.info dnsmasq[1]: UBus support enabled: connected to system bus
Sat May  3 08:47:41 2025 daemon.info dnsmasq-dhcp[1]: DHCP, IP range 192.168.2.100 -- 192.168.2.249, lease time 12h
Sat May  3 08:47:41 2025 daemon.info dnsmasq[1]: using only locally-known addresses for test
Sat May  3 08:47:41 2025 daemon.info dnsmasq[1]: using only locally-known addresses for onion
Sat May  3 08:47:41 2025 daemon.info dnsmasq[1]: using only locally-known addresses for localhost
Sat May  3 08:47:41 2025 daemon.info dnsmasq[1]: using only locally-known addresses for local
Sat May  3 08:47:41 2025 daemon.info dnsmasq[1]: using only locally-known addresses for invalid
Sat May  3 08:47:41 2025 daemon.info dnsmasq[1]: using only locally-known addresses for bind
Sat May  3 08:47:41 2025 daemon.info dnsmasq[1]: using only locally-known addresses for lan
Sat May  3 08:47:41 2025 daemon.warn dnsmasq[1]: no servers found in /tmp/resolv.conf.d/resolv.conf.auto, will retry
Sat May  3 08:47:41 2025 daemon.info dnsmasq[1]: read /etc/hosts - 12 names
Sat May  3 08:47:41 2025 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 4 names
Sat May  3 08:47:41 2025 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 0 names
Sat May  3 08:47:41 2025 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Sat May  3 08:47:43 2025 daemon.notice netifd: Network device 'wan' link is up
Sat May  3 08:47:43 2025 daemon.notice netifd: Interface 'wan' has link connectivity
Sat May  3 08:47:43 2025 daemon.notice netifd: Interface 'wan' is setting up now
Sat May  3 08:47:43 2025 daemon.notice netifd: Interface 'wan6' has link connectivity
Sat May  3 08:47:43 2025 daemon.notice netifd: Interface 'wan6' is setting up now
Sat May  3 08:47:43 2025 kern.info kernel: [ 6832.505305] qca8k 37000000.mdio-mii:10 wan: Link is Up - 1Gbps/Full - flow control rx/tx
Sat May  3 08:47:43 2025 daemon.err odhcp6c[13361]: Failed to send RS (Address not available)
Sat May  3 08:47:43 2025 daemon.notice netifd: wan (13360): udhcpc: started, v1.36.1
Sat May  3 08:47:43 2025 daemon.notice netifd: wan (13360): udhcpc: broadcasting discover
Sat May  3 08:47:44 2025 daemon.err odhcp6c[13361]: Failed to send SOLICIT message to ff02::1:2 (Address not available)
Sat May  3 08:47:45 2025 daemon.err odhcp6c[13361]: Failed to send SOLICIT message to ff02::1:2 (Address not available)
Sat May  3 08:47:46 2025 daemon.notice netifd: wan (13360): udhcpc: broadcasting discover
Sat May  3 08:47:46 2025 daemon.notice netifd: wan (13360): udhcpc: broadcasting select for 192.168.1.2, server 192.168.1.1
Sat May  3 08:47:46 2025 daemon.notice netifd: wan (13360): udhcpc: lease of 192.168.1.2 obtained from 192.168.1.1, lease time 86400
Sat May  3 08:47:46 2025 daemon.notice netifd: Interface 'wan' is now up
Sat May  3 08:47:46 2025 daemon.info dnsmasq[1]: reading /tmp/resolv.conf.d/resolv.conf.auto
Sat May  3 08:47:46 2025 daemon.info dnsmasq[1]: using nameserver 192.168.1.1#53
Sat May  3 08:47:46 2025 daemon.info dnsmasq[1]: using only locally-known addresses for test
Sat May  3 08:47:46 2025 daemon.info dnsmasq[1]: using only locally-known addresses for onion
Sat May  3 08:47:46 2025 daemon.info dnsmasq[1]: using only locally-known addresses for localhost
Sat May  3 08:47:46 2025 daemon.info dnsmasq[1]: using only locally-known addresses for local
Sat May  3 08:47:46 2025 daemon.info dnsmasq[1]: using only locally-known addresses for invalid
Sat May  3 08:47:46 2025 daemon.info dnsmasq[1]: using only locally-known addresses for bind
Sat May  3 08:47:46 2025 daemon.info dnsmasq[1]: using only locally-known addresses for lan
Sat May  3 08:47:46 2025 kern.info kernel: [ 6835.475462] qca8k 37000000.mdio-mii:10 lan4: Link is Up - 1Gbps/Full - flow control rx/tx
Sat May  3 08:47:46 2025 kern.info kernel: [ 6835.475553] br-lan: port 4(lan4) entered blocking state
Sat May  3 08:47:46 2025 kern.info kernel: [ 6835.482705] br-lan: port 4(lan4) entered forwarding state
Sat May  3 08:47:46 2025 daemon.notice netifd: Network device 'lan4' link is up
Sat May  3 08:47:46 2025 daemon.notice netifd: bridge 'br-lan' link is up
Sat May  3 08:47:46 2025 daemon.notice netifd: Interface 'lan' has link connectivity
Sat May  3 08:47:46 2025 user.notice firewall: Reloading firewall due to ifup of wan (wan)
Sat May  3 08:47:47 2025 daemon.err odhcpd[1382]: Failed to send to fe80::e9ab:9fc7:7558:8d74%lan@br-lan (Address not available)
Sat May  3 08:47:47 2025 daemon.err odhcpd[10516]: Failed to send to fe80::e9ab:9fc7:7558:8d74%lan@br-lan (Address not available)
Sat May  3 08:47:48 2025 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) 192.168.2.241 30:e1:71:88:cb:1c
Sat May  3 08:47:48 2025 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan) 192.168.2.241 30:e1:71:88:cb:1c Laptop-van-Beau
Sat May  3 08:47:48 2025 daemon.info dnsmasq[1]: exiting on receipt of SIGTERM
Sat May  3 08:47:48 2025 daemon.info dnsmasq[1]: started, version 2.90 cachesize 1000
Sat May  3 08:47:48 2025 daemon.info dnsmasq[1]: DNS service limited to local subnets
Sat May  3 08:47:48 2025 daemon.info dnsmasq[1]: compile time options: IPv6 GNU-getopt no-DBus UBus no-i18n no-IDN DHCP no-DHCPv6 no-Lua TFTP no-conntrack no-ipset no-nftset no-auth no-cryptohash no-DNSSEC no-ID loop-detect inotify dumpfile
Sat May  3 08:47:48 2025 daemon.info dnsmasq[1]: UBus support enabled: connected to system bus
Sat May  3 08:47:48 2025 daemon.info dnsmasq-dhcp[1]: DHCP, IP range 192.168.2.100 -- 192.168.2.249, lease time 12h
Sat May  3 08:47:48 2025 daemon.info dnsmasq[1]: using only locally-known addresses for test
Sat May  3 08:47:48 2025 daemon.info dnsmasq[1]: using only locally-known addresses for onion
Sat May  3 08:47:48 2025 daemon.info dnsmasq[1]: using only locally-known addresses for localhost
Sat May  3 08:47:48 2025 daemon.info dnsmasq[1]: using only locally-known addresses for local
Sat May  3 08:47:48 2025 daemon.info dnsmasq[1]: using only locally-known addresses for invalid
Sat May  3 08:47:48 2025 daemon.info dnsmasq[1]: using only locally-known addresses for bind
Sat May  3 08:47:48 2025 daemon.info dnsmasq[1]: using only locally-known addresses for lan
Sat May  3 08:47:48 2025 daemon.info dnsmasq[1]: reading /tmp/resolv.conf.d/resolv.conf.auto
Sat May  3 08:47:48 2025 daemon.info dnsmasq[1]: using nameserver 192.168.1.1#53
Sat May  3 08:47:48 2025 daemon.info dnsmasq[1]: using only locally-known addresses for test
Sat May  3 08:47:48 2025 daemon.info dnsmasq[1]: using only locally-known addresses for onion
Sat May  3 08:47:48 2025 daemon.info dnsmasq[1]: using only locally-known addresses for localhost
Sat May  3 08:47:48 2025 daemon.info dnsmasq[1]: using only locally-known addresses for local
Sat May  3 08:47:48 2025 daemon.info dnsmasq[1]: using only locally-known addresses for invalid
Sat May  3 08:47:48 2025 daemon.info dnsmasq[1]: using only locally-known addresses for bind
Sat May  3 08:47:48 2025 daemon.info dnsmasq[1]: using only locally-known addresses for lan
Sat May  3 08:47:48 2025 daemon.info dnsmasq[1]: read /etc/hosts - 12 names
Sat May  3 08:47:48 2025 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 4 names
Sat May  3 08:47:48 2025 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 0 names
Sat May  3 08:47:48 2025 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Sat May  3 08:47:50 2025 daemon.info dnsmasq[1]: read /etc/hosts - 12 names
Sat May  3 08:47:50 2025 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 4 names
Sat May  3 08:47:50 2025 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 2 names
Sat May  3 08:47:50 2025 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Sat May  3 08:47:50 2025 daemon.info dnsmasq[1]: read /etc/hosts - 12 names
Sat May  3 08:47:50 2025 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 4 names
Sat May  3 08:47:50 2025 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 2 names
Sat May  3 08:47:50 2025 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Sat May  3 08:47:50 2025 daemon.warn odhcpd[10516]: No default route present, overriding ra_lifetime to 0!
Sat May  3 08:47:50 2025 daemon.warn odhcpd[1382]: No default route present, overriding ra_lifetime to 0!
Sat May  3 08:47:54 2025 daemon.warn odhcpd[1382]: No default route present, overriding ra_lifetime to 0!
Sat May  3 08:47:54 2025 daemon.warn odhcpd[10516]: No default route present, overriding ra_lifetime to 0!
Sat May  3 08:48:03 2025 daemon.warn odhcpd[1382]: No default route present, overriding ra_lifetime to 0!
Sat May  3 08:48:03 2025 daemon.warn odhcpd[10516]: No default route present, overriding ra_lifetime to 0!

I'm not undertaking any steps after that. I just start a www.speedtest.net and watch internet go down again.

No, the router is on modem LAN port 2 right now. I had it in port 1 (2.5GbE) before I upgraded openwrt, no problems. Also, when I now connect the router to port 1 it shows the same behavior.

1 Like

I meant logs of a failure. Apologies if that wasn't clear.

I can't tell if the link messages are related to your restart or not.

This occurs after high throughput?

Lastly, you can use 1 post to respond to mutiple people.

It seems to be 24.10.1 and 24.10.0 not working properly on my router. I downgraded to 23.05.5 and internet is stable now :slight_smile:

1 Like

Which one of them?

I have T-56 in the lab, no issues whatsoever, except for the LAN 2.5GbE port going up and down if connected to a 1GbE device.