No Internet from LAN

Hi,

had my network equipment powered off for a couple of days to find out that my network setup is not working anymore.

I can access the internet from the router directly. (ping 8.8.8.8 works), however the same command is not possibly from my client.

If I happen to be in the guest network, however, the connection works just fine.

Smells a lot like a firewall problem, but I haven't touched the configuration and I don't see the difference between the two networks LAN and MusicLAN.

Can you spot the error?

root@OpenWrt:~# cat /etc/config/firewall 

config defaults
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option synflood_protect '1'

config zone
	option name 'lan'
	list network 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'

config zone
	option name 'wan'
	list network 'wan'
	list network 'wan6'
	list network 'VIGOR_WAN'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option src_ip 'fc00::/6'
	option dest_ip 'fc00::/6'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config include
	option path '/etc/firewall.user'

config zone
	option network 'MusicLAN'
	option input 'ACCEPT'
	option name 'musiclan'
	option output 'ACCEPT'
	option forward 'ACCEPT'

config forwarding
	option dest 'wan'
	option src 'musiclan'

root@OpenWrt:~# unskilled+barcode+back^C
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'


config interface 'lan'
	option type 'bridge'
	option ifname 'eth1.1'
	option proto 'static'
	option ip6assign '60'
	list ipaddr '192.168.42.1/24'

config interface 'wan'
	option proto 'pppoe'
	option username xxx
	option password 'xxxxx'
	option ipv6 'auto'
	option peerdns '0'
	option ifname 'eth0.7'

config interface 'wan6'
	option proto 'dhcpv6'
	option auto '0'
	option peerdns '0'
	option reqprefix 'auto'
	option reqaddress 'try'
	option ifname 'eth0'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '6t 4 3 2 1'
	option vid '1'

config interface 'VIGOR_WAN'
	option proto 'static'
	option ipaddr '192.168.1.100'
	option netmask '255.255.255.0'
	option gateway '192.168.1.1'
	option ifname 'eth0.2'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '2'
	option ports '0t 5'

config interface 'guest_lan'
	option proto 'static'
	option ipaddr '192.168.43.1'
	option netmask '255.255.255.0'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option vid '7'
	option ports '0t 5t'

config switch_vlan
	option device 'switch0'
	option vlan '4'
	option vid '3'
	option ports '6t'

config interface 'MusicLAN'
	option proto 'static'
	option type 'bridge'
	list ipaddr '192.168.43.1/24'


root@OpenWrt:~# cat /etc/config/firewall 

config defaults
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option synflood_protect '1'

config zone
	option name 'lan'
	list network 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'

config zone
	option name 'wan'
	list network 'wan'
	list network 'wan6'
	list network 'VIGOR_WAN'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option src_ip 'fc00::/6'
	option dest_ip 'fc00::/6'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config include
	option path '/etc/firewall.user'

config zone
	option network 'MusicLAN'
	option input 'ACCEPT'
	option name 'musiclan'
	option output 'ACCEPT'
	option forward 'ACCEPT'

config forwarding
	option dest 'wan'
	option src 'musiclan'

Please run the following commands (copy-paste the whole block) and paste the output here, using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have

ubus call system board; \
uci export network; uci export wireless; \
uci export dhcp; uci export firewall; \
head -n -0 /etc/firewall.user; \
ip -4 addr ; ip -4 ro li tab all ; ip -4 ru; \
ip -6 addr ; ip -6 ro li tab all ; ip -6 ru; \
ls -l  /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/* ; head -n -0 /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/*
2 Likes

Here is the output.

{
	"kernel": "4.14.195",
	"hostname": "OpenWrt",
	"system": "ARMv7 Processor rev 0 (v7l)",
	"model": "Netgear Nighthawk X4S R7800",
	"board_name": "netgear,r7800",
	"release": {
		"distribution": "OpenWrt",
		"version": "19.07.4",
		"revision": "r11208-ce6496d796",
		"target": "ipq806x/generic",
		"description": "OpenWrt 19.07.4 r11208-ce6496d796"
	}
}
package network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix xxx

config interface 'lan'
	option type 'bridge'
	option ifname 'eth1.1'
	option proto 'static'
	option ip6assign '60'
	list ipaddr '192.168.42.1/24'

config interface 'wan'
	option proto 'pppoe'
	option ipv6 'auto'
	option peerdns '0'
	option ifname 'eth0.7'

config interface 'wan6'
	option proto 'dhcpv6'
	option auto '0'
	option peerdns '0'
	option reqprefix 'auto'
	option reqaddress 'try'
	option ifname 'eth0'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '6t 4 3 2 1'
	option vid '1'

config interface 'VIGOR_WAN'
	option proto 'static'
	option ipaddr '192.168.1.100'
	option netmask '255.255.255.0'
	option gateway '192.168.1.1'
	option ifname 'eth0.2'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '2'
	option ports '0t 5'

config interface 'guest_lan'
	option proto 'static'
	option ipaddr '192.168.43.1'
	option netmask '255.255.255.0'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option vid '7'
	option ports '0t 5t'

config switch_vlan
	option device 'switch0'
	option vlan '4'
	option vid '3'
	option ports '6t'

config interface 'MusicLAN'
	option proto 'static'
	option type 'bridge'
	list ipaddr '192.168.43.1/24'

package wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11a'
	option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
	option channel 'auto'
	option htmode 'VHT80'
	option country 'DE'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option encryption 'psk2'
	option wpa_disable_eapol_key_retries '1'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
	option htmode 'HT40'
	option channel 'auto'
	option country 'DE'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option encryption 'psk2'
	option wpa_disable_eapol_key_retries '1'

config wifi-iface 'wifinet2'
	option encryption 'psk-mixed'
	option device 'radio1'
	option mode 'ap'
	option ssid 'MusicNet'
	option network 'MusicLAN'

package dhcp

config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	option localservice '1'
	list server '192.168.42.10#5053'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv6 'server'
	option ra 'server'
	option ra_management '1'
	list dhcp_option '6,8.8.8.8'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

config host
	option dns '1'
	option ip '192.168.42.91'
	option mac 

config host
	option dns '1'
	option ip '192.168.42.92'
	option name 'daniel-think'


config dhcp 'guest_lan'
	option start '100'
	option leasetime '12h'
	option limit '150'
	option interface 'guest_lan'

config host
	option dns '1'
	option ip '192.168.42.10'

config domain
	option name 'vigor'
	option ip '192.168.1.1'

config dhcp 'MusicLAN'
	option start '100'
	option leasetime '12h'
	option limit '150'
	option interface 'MusicLAN'
	list dhcp_option '6,8.8.8.8'

package firewall

config defaults
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option synflood_protect '1'

config zone
	option name 'lan'
	list network 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'

config zone
	option name 'wan'
	list network 'wan'
	list network 'wan6'
	list network 'VIGOR_WAN'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option src_ip 'fc00::/6'
	option dest_ip 'fc00::/6'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config include
	option path '/etc/firewall.user'

config zone
	option network 'MusicLAN'
	option input 'ACCEPT'
	option name 'musiclan'
	option output 'ACCEPT'
	option forward 'ACCEPT'

config forwarding
	option dest 'wan'
	option src 'musiclan'

# This file is interpreted as shell script.
# Put your custom iptables rules here, they will
# be executed with each firewall (re-)start.

# Internal uci firewall chains are flushed and recreated on reload, so
# put custom rules into the root chains e.g. INPUT or FORWARD or into the
# special user chains, e.g. input_wan_rule or postrouting_lan_rule.
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
7: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 192.168.42.1/24 brd 192.168.42.255 scope global br-lan
       valid_lft forever preferred_lft forever
9: eth0.2@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 192.168.1.100/24 brd 192.168.1.255 scope global eth0.2
       valid_lft forever preferred_lft forever
11: br-MusicLAN: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 192.168.43.1/24 brd 192.168.43.255 scope global br-MusicLAN
       valid_lft forever preferred_lft forever
12: pppoe-wan: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1492 qdisc fq_codel state UNKNOWN qlen 3
    inet 46.94.156.16 peer 62.155.240.147/32 scope global pppoe-wan
       valid_lft forever preferred_lft forever
default via 62.155.240.147 dev pppoe-wan 
62.155.240.147 dev pppoe-wan scope link  src 46.94.156.16 
192.168.1.0/24 dev eth0.2 scope link  src 192.168.1.100 
192.168.42.0/24 dev br-lan scope link  src 192.168.42.1 
192.168.43.0/24 dev br-MusicLAN scope link  src 192.168.43.1 
local 46.94.156.16 dev pppoe-wan table local scope host  src 46.94.156.16 
broadcast 127.0.0.0 dev lo table local scope link  src 127.0.0.1 
local 127.0.0.0/8 dev lo table local scope host  src 127.0.0.1 
local 127.0.0.1 dev lo table local scope host  src 127.0.0.1 
broadcast 127.255.255.255 dev lo table local scope link  src 127.0.0.1 
broadcast 192.168.1.0 dev eth0.2 table local scope link  src 192.168.1.100 
local 192.168.1.100 dev eth0.2 table local scope host  src 192.168.1.100 
broadcast 192.168.1.255 dev eth0.2 table local scope link  src 192.168.1.100 
broadcast 192.168.42.0 dev br-lan table local scope link  src 192.168.42.1 
local 192.168.42.1 dev br-lan table local scope host  src 192.168.42.1 
broadcast 192.168.42.255 dev br-lan table local scope link  src 192.168.42.1 
broadcast 192.168.43.0 dev br-MusicLAN table local scope link  src 192.168.43.1 
local 192.168.43.1 dev br-MusicLAN table local scope host  src 192.168.43.1 
broadcast 192.168.43.255 dev br-MusicLAN table local scope link  src 192.168.43.1 
0:	from all lookup local 
32766:	from all lookup main 
32767:	from all lookup default 
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1000
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::46a5:6eff:fe5e:b4c4/64 scope link 
       valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::46a5:6eff:fe5e:b4c3/64 scope link 
       valid_lft forever preferred_lft forever
7: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 2003:ef:2f08:f200::1/60 scope global dynamic 
       valid_lft 13889sec preferred_lft 1289sec
    inet6 fda2:eb23:e043::1/60 scope global 
       valid_lft forever preferred_lft forever
    inet6 fe80::46a5:6eff:fe5e:b4c3/64 scope link 
       valid_lft forever preferred_lft forever
9: eth0.2@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::46a5:6eff:fe5e:b4c4/64 scope link 
       valid_lft forever preferred_lft forever
10: eth0.7@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::46a5:6eff:fe5e:b4c4/64 scope link 
       valid_lft forever preferred_lft forever
11: br-MusicLAN: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::44a5:6eff:fe5e:b4c6/64 scope link 
       valid_lft forever preferred_lft forever
12: pppoe-wan: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1492 state UNKNOWN qlen 3
    inet6 2003:ef:2fff:8ff:19e2:b92f:d74b:716a/64 scope global dynamic 
       valid_lft 13897sec preferred_lft 1297sec
    inet6 fe80::19e2:b92f:d74b:716a/10 scope link 
       valid_lft forever preferred_lft forever
13: wlan1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::46a5:6eff:fe5e:b4c6/64 scope link 
       valid_lft forever preferred_lft forever
14: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::46a5:6eff:fe5e:b4c5/64 scope link 
       valid_lft forever preferred_lft forever
15: wlan1-1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::44a5:6eff:fe5e:b4c6/64 scope link 
       valid_lft forever preferred_lft forever
default from 2003:ef:2f08:f200::/56 via fe80::2e21:31ff:fe25:8a46 dev pppoe-wan  metric 512 
default from 2003:ef:2fff:8ff::/64 via fe80::2e21:31ff:fe25:8a46 dev pppoe-wan  metric 512 
2003:ef:2f08:f200::/64 dev br-lan  metric 1024 
unreachable 2003:ef:2f08:f200::/56 dev lo  metric 2147483647  error -113
2003:ef:2fff:8ff::/64 dev pppoe-wan  metric 256 
fda2:eb23:e043::/64 dev br-lan  metric 1024 
unreachable fda2:eb23:e043::/48 dev lo  metric 2147483647  error -113
fe80::/64 dev eth1  metric 256 
fe80::/64 dev br-lan  metric 256 
fe80::/64 dev eth0  metric 256 
fe80::/64 dev eth0.2  metric 256 
fe80::/64 dev eth0.7  metric 256 
fe80::/64 dev wlan1  metric 256 
fe80::/64 dev br-MusicLAN  metric 256 
fe80::/64 dev wlan1-1  metric 256 
fe80::/64 dev wlan0  metric 256 
fe80::/10 dev pppoe-wan  metric 1 
fe80::/10 dev pppoe-wan  metric 256 
local ::1 dev lo table local  metric 0 
anycast 2003:ef:2f08:f200:: dev br-lan table local  metric 0 
local 2003:ef:2f08:f200::1 dev br-lan table local  metric 0 
anycast 2003:ef:2fff:8ff:: dev pppoe-wan table local  metric 0 
local 2003:ef:2fff:8ff:19e2:b92f:d74b:716a dev pppoe-wan table local  metric 0 
anycast fda2:eb23:e043:: dev br-lan table local  metric 0 
local fda2:eb23:e043::1 dev br-lan table local  metric 0 
anycast fe80:: dev pppoe-wan table local  metric 0 
anycast fe80:: dev eth0.2 table local  metric 0 
anycast fe80:: dev eth0.7 table local  metric 0 
anycast fe80:: dev br-lan table local  metric 0 
anycast fe80:: dev eth0 table local  metric 0 
anycast fe80:: dev eth1 table local  metric 0 
anycast fe80:: dev wlan1-1 table local  metric 0 
anycast fe80:: dev br-MusicLAN table local  metric 0 
anycast fe80:: dev wlan1 table local  metric 0 
anycast fe80:: dev wlan0 table local  metric 0 
local fe80::19e2:b92f:d74b:716a dev pppoe-wan table local  metric 0 
local fe80::44a5:6eff:fe5e:b4c6 dev wlan1-1 table local  metric 0 
local fe80::44a5:6eff:fe5e:b4c6 dev br-MusicLAN table local  metric 0 
local fe80::46a5:6eff:fe5e:b4c3 dev br-lan table local  metric 0 
local fe80::46a5:6eff:fe5e:b4c3 dev eth1 table local  metric 0 
local fe80::46a5:6eff:fe5e:b4c4 dev eth0.2 table local  metric 0 
local fe80::46a5:6eff:fe5e:b4c4 dev eth0.7 table local  metric 0 
local fe80::46a5:6eff:fe5e:b4c4 dev eth0 table local  metric 0 
local fe80::46a5:6eff:fe5e:b4c5 dev wlan0 table local  metric 0 
local fe80::46a5:6eff:fe5e:b4c6 dev wlan1 table local  metric 0 
ff00::/8 dev br-lan table local  metric 256 
ff00::/8 dev eth1 table local  metric 256 
ff00::/8 dev eth0 table local  metric 256 
ff00::/8 dev eth0.2 table local  metric 256 
ff00::/8 dev eth0.7 table local  metric 256 
ff00::/8 dev pppoe-wan table local  metric 256 
ff00::/8 dev wlan1 table local  metric 256 
ff00::/8 dev br-MusicLAN table local  metric 256 
ff00::/8 dev wlan1-1 table local  metric 256 
ff00::/8 dev wlan0 table local  metric 256 
0:	from all lookup local 
32766:	from all lookup main 
4200000000:	from 2003:ef:2f08:f200::1/60 iif br-lan lookup unspec unreachable
4200000001:	from all iif lo lookup unspec 12
4200000007:	from all iif br-lan lookup unspec 12
4200000009:	from all iif eth0.2 lookup unspec 12
4200000011:	from all iif br-MusicLAN lookup unspec 12
4200000012:	from all iif pppoe-wan lookup unspec 12
4200000012:	from all iif pppoe-wan lookup unspec 12
lrwxrwxrwx    1 root     root            16 Sep  6  2020 /etc/resolv.conf -> /tmp/resolv.conf
-rw-r--r--    1 root     root            32 Apr  5 19:25 /tmp/resolv.conf
-rw-r--r--    1 root     root            34 Mar 13 15:12 /tmp/resolv.conf.auto
-rw-r--r--    1 root     root            53 Mar 13 15:12 /tmp/resolv.conf.ppp
==> /etc/resolv.conf <==
search lan
nameserver 127.0.0.1

==> /tmp/resolv.conf <==
search lan
nameserver 127.0.0.1

==> /tmp/resolv.conf.auto <==
# Interface wan
# Interface wan_6

==> /tmp/resolv.conf.ppp <==
nameserver 217.237.151.51
nameserver 217.237.149.205

First of all you have defined twice the guest interface, once as guest_lan and second as MusicLAN.
Delete the guest_lan as there are no firewall rules anyway for it, nor is it assigned to any ports or wifi.
Then connect a client on the lan and verify it gets IP from dhcp.
Run a traceroute to the 8.8.8.8 and paste here the output.

2 Likes

Okay, I got it. I don't understand the details, but there must have been some device in lan that somehow confused the dhcp server of the router.

After unplugging all ethernet cables from the router and rebooting internet connection worked again as expected (same as for MusicLan). Pluggin all cables back to the router made those other devices work well, too.

I'm glad its all working again, but I still do not see what possibly went wrong here.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.