No internet connectivity (WRT1900ACS, docsis modem ES2251)

Hello,

I am attempting to get my internet to connect with the latest version of Open WRT. I previously had it working but had to do a factory reset due to the installation process stalling.

I am running OpenWrt 21.02.3 r16554-1d4dea6d4f / LuCI openwrt-21.02 branch git-22.083.69138-0a0ce2a.

It seems there is some setting that is preventing the modem from being recognized within the firmware. I am trying to get "luci-proto-wireguard" to install. Thanks.

What modrm, what router?

Router: Linksys WRT1900ACS
Modem: DOCSIS 3.1 (ES2251)

Try restarting your modem and your router. You may need to restart your modem multiple times, but that often resolves the issue if the MAC address changed (for example, if the LAN and WAN MAC addresses on your router were swapped in the previous version relative to the newest).

I still don't see any transmit or receive in the WAN.

Protocol: DHCP client
RX: 0 B (0 Pkts.)
TX: 0 B (0 Pkts.)

I now see activity on the WAN.

Protocol: DHCP client
RX: 802.52 KB (3860 Pkts.)
TX: 1.41 MB (3252 Pkts.)

However, there is still no internet connectivity via the router.

do you see an address on the WAN?

What's in the log?

logread -e udhcpc

There is a MAC address in the WAN, but no IP. How do I run that command? The SSH access seems incorrect.

@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@

@ WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED! @

@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@

IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!

Someone could be eavesdropping on you right now (man-in-the-middle attack)!

It is also possible that a host key has just been changed.

The fingerprint for the ED25519 key sent by the remote host is
...

When you flash the router, if you don't keep settings, a new ssh key will be generated. You simply need to remove the old key from your OS's stored ssh keys. On Mac OS, it is the following command:

ssh-keygen -R 192.168.1.1

(the above assumes your router is 192.168.1.1)

1 Like

The terminal now seems correct:

BusyBox v1.33.2 (2022-04-16 12:59:34 UTC) built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 21.02.3, r16554-1d4dea6d4f
 -----------------------------------------------------
root@OpenWrt:~#

Still NO internet connectivity via the router. I attempted to install opkg update && opkg install curl to test the connection from the modem to the router.

It still seems like something in the OpenWrt settings of the router is preventing an internet connection. When I initially setup the router (first openwrt flash) with the firmware I followed a set of directions to "add a modem". After doing that I did have wireless internet connectivity.

The OpenWrt default settings are designed for use with a cable modem. There is no need to install or configure anything to have a basic Internet connection through a cable modem.

So whatever you did to "add a modem" was unnecessary and seems to have broken things.

If you look at the router's route table, you should see a route leading through the wan interface to off site. When the cable modem is a pure modem (bridged), your default gateway is a router owned by the cable company at the other end of the cable. Try pinging that IP address.

2 Likes

Reset the router so you have the default configuration with no user added packages.

Does that fix the problem? If not, let’s see the output of the log as I requested earlier.

In this installation. I did not "add a modem". Presently (under interfaces) I have "LAN-- br-lan", "WAN--br-lan", and "WAN6-wan". I don't see a route leading through the WAN interface to off site. I am going to try a new firmware flash now.

This is your problem.
WAN should not be part of br-lan.

Reset your router to defaults... the default configuration should 'just work'

I just completed a reset of the router. I saw activity on the WAN again but there was no internet connectivity via ethernet or wireless.

wifi is disabled by default. Did you enable it?

Let's see your configuration and your logs.

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

and also post the results of logread

Yes, wifi was enabled after the router reset.
Which configuration are you referring to? The interfaces? Also, which logs?

Read my previous post. 4 files.

And the output of the logread command

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdd4:4ddd:31aa::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option name 'wan'
	option macaddr '32:23:03:11:79:1b'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'
[quote="psherman, post:16, topic:125916"]

cat /etc/config/wireless

[/quote]


root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
	option channel '36'
	option band '5g'
	option htmode 'VHT80'
	option country 'US'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'
	option macaddr '30:23:03:11:79:1d'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option country 'US'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'
	option macaddr '30:23:03:11:79:1c'

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
	option channel '36'
	option band '5g'
	option htmode 'VHT80'
	option country 'US'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'
	option macaddr '30:xx'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option country 'US'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'
	option macaddr '30:xxc'