No internet after installing OpenWrt

Hello there,

I just installed openwrt v 18.06.03 on my mikrotik Hap Lite TC after so many struggles.
The problem is no matter what I do i cannot get internet with my new device.
I already tried many solutions on forum and changed my internet source twice.
I can ping in ssh and LuCI but I dont have any internet when i plug my computer to one of the ethernet ports of HapLiteTC

root@OpenWrt:~# ping
PING ( 56 data bytes
64 bytes from seq=0 ttl=52 time=32.433 ms
64 bytes from seq=1 ttl=52 time=106.586 ms
--- ping statistics ---
2 packets transmitted, 2 packets received, 0% packet loss
round-trip min/avg/max = 32.433/69.509/106.586 ms
root@OpenWrt:~# ubus call system board
        "kernel": "4.9.182",
        "hostname": "OpenWrt",
        "system": "Qualcomm Atheros QCA9533 ver 2 rev 0",
        "model": "MikroTik RouterBOARD RB941-2nD",
        "board_name": "unknown",
        "release": {
                "distribution": "OpenWrt",
                "version": "18.06.3",
                "revision": "r7798-97ae9e0ccb",
                "target": "ar71xx\/mikrotik",
                "description": "OpenWrt 18.06.3 r7798-97ae9e0ccb"
root@OpenWrt:~# uci export network; uci export wireless
package network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr ''
        option netmask ''

config globals 'globals'
        option ula_prefix 'fd95:8b89:5ebc::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option netmask ''
        option ip6assign '60'
        option ipaddr ''
        option gateway ''
        option dns ''

config interface 'wan'
        option ifname 'eth1'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth1'
        option proto 'dhcpv6'

uci: Entry not found
root@OpenWrt:~# uci export dhcp
package dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/'
        option nonwildcard '1'
        option localservice '1'

config dhcp 'lan'
        option interface 'lan'
        option dhcpv6 'server'
        option ra 'server'
        option ra_management '1'
        option start '100'
        option limit '150'
        option leasetime '12h'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

This version is very old — EOL and unsupported now. It has many security vulnerabilities and is not suitable for use on the internet.

Please install 22.03 (current release). Do not keep settings when you run the upgrade.

Thank you for reply.
this is the latest version that my device with this little memory supports

Probably time to get a new device. Using an old version is not recommended since it may result in major security problems on your network.

I’m willing to help with ‘best effort’ with the old version, but there are major changes and I honestly don’t remember the nuances of the old config syntax.

For starters, your config seems unusual. Please provide a diagram of your network topology.

I really appreciate the help.
My network is really simple. I have a TP Link router/modem and this Openwrt device.

ISP Modem LAN port -> Openwrt WAN port
and from the Openwrt LAN -> My PC

also here is screenshot of my interface/firewall

WAN Interface

Firewall config

Is this an integrated modem + router?

It's a typical TP-LINK router that I have PPPOE connection setup on it for my Point to Point internet connection.
I also have an Huawei 4G modem at hand that I tested it and still no internet output from openwrt

Just reset your openwrt router to defaults to start.

What is the purpose of the openwrt device? Is it supposed to be a dumb ap or a router?

I just want to use openwrt for a specific VPN plugin.
I already tried resetting to default still no internet

Also, even if your device doesn’t support later versions, at least upgrade to 18.06.9

Edit: it appears your device can run 19.07. This would be recommended in general, but the 32mb ram issue is likely to be a limiting factor for anything you do with this device.

This is unlikely to work on your device with only 32mb ram, even with 18.06. Even if it does work, performance may not be good.

What vpn protocol are you using?

The wan and lan subnets must not overlap. I’m guessing they do right now.

Leave all settings default and then change the lan ip to a different subnet (such as

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.