No internet access on Xiaomi AX3200

I just installed OpenWrt on my Xiaomi AX3200 but I don't have internet access. I can connect to luci just fine, but I can't figure out how to make internet work. The router is plugged into an ONT (Chorus Model 200) that doesn't have any sort of interface to check settings. The blue Internet light on the router is on, and the relevant light on the ONT is also on.

When I first set up my Xiaomi router (with stock firmware) it was pretty much plug and play, and when I try it with my Deco X20 router there's nothing I have to do. My ISP has this page with details about what settings to use, but I can't see where I'm supposed to enter those into OpenWrt. I've tried a reset a couple of times to no avail.

I looked through the OpenWrt internet troubleshooting guide but honestly I'm stuck on step 2: I can't for the life of me see where I'm supposed to see an IP address for WAN under interfaces. That guide also said to ask here if I'm stuck, so here I am. I hope I've provided enough information, let me know if there's anything else that I've missed.

Thanks for helping a noob!

Here's my interfaces page in case it helps:

The link you sent suggests that the fiber service requires the wan to be on VLAN 10.

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
ifstatus wan
logread -e udhcpc

Yeah I think I did the VLAN thing with the stock firmware setup but couldn't figure out where to put it in in OpenWrt.

Here you go:

root@OpenWrt:~# ubus call system board
{
        "kernel": "5.15.162",
        "hostname": "OpenWrt",
        "system": "ARMv8 Processor rev 4",
        "model": "Xiaomi Redmi Router AX6S",
        "board_name": "xiaomi,redmi-router-ax6s",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.4",
                "revision": "r24012-d8dd03c46f",
                "target": "mediatek/mt7622",
                "description": "OpenWrt 23.05.4 r24012-d8dd03c46f"
        }
}
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix '${IPv6 address?}'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'wan'
        option macaddr '${MAC Address}'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'
root@OpenWrt:~# ifstatus wan
{
        "up": false,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "proto": "dhcp",
        "device": "wan",
        "data": {

        }
}
root@OpenWrt:~# logread -e udhcpc
Mon Jul 15 22:28:20 2024 daemon.notice netifd: wan (2970): udhcpc: started, v1.36.1
Mon Jul 15 22:28:21 2024 daemon.notice netifd: wan (2970): udhcpc: broadcasting discover
Mon Jul 15 22:28:24 2024 daemon.notice netifd: wan (2970): udhcpc: broadcasting discover
Mon Jul 15 22:28:26 2024 daemon.notice netifd: wan (2970): udhcpc: broadcasting discover
Mon Jul 15 22:29:47 2024 daemon.notice netifd: wan (2970): udhcpc: received SIGTERM
Mon Jul 15 22:29:47 2024 daemon.notice netifd: wan (2970): udhcpc: entering released state
Mon Jul 15 22:30:47 2024 daemon.notice netifd: wan (3264): udhcpc: started, v1.36.1
Mon Jul 15 22:30:47 2024 daemon.notice netifd: wan (3264): udhcpc: broadcasting discover
Mon Jul 15 22:30:50 2024 daemon.notice netifd: wan (3264): udhcpc: broadcasting discover
Mon Jul 15 22:30:53 2024 daemon.notice netifd: wan (3264): udhcpc: broadcasting discover
Mon Jul 15 22:32:20 2024 daemon.notice netifd: wan (3264): udhcpc: received SIGTERM
Mon Jul 15 22:32:20 2024 daemon.notice netifd: wan (3264): udhcpc: entering released state

Try simply editing the wan interfaces to use device wan.10

config interface 'wan'
        option device 'wan.10'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan.10'
        option proto 'dhcpv6'

Then reboot and see if it helps.

1 Like

It's not the biggest problem you have. Make sure to run following code or your router will brick after 6 reboots:

fw_setenv flag_try_sys1_failed 8
fw_setenv flag_try_sys2_failed 8

Official guide doesn't mention it for some reason.

Some explanation: UBI (bootloader) has been configured with two firmwares. When router tries to boot counter 'flag_try_sys1_failed' increases. If OS boots successfully it decreases those values. So, the logic is, if firmware fails to boot 6 times (OS doesn't decrease it), bootloader switches to firmware2. But there is no firmware2 at preset address... Router bricked, you need to learn how to work with TFTP.

I believe you forgot about VLAN 10.

OpenWrt comes with vi, when noobs open vi for editing... soon he will ask us "How do I type in this editor?" or "How do I leave this editor?". Usually it ends up with frustration and reboot.

Oh great that worked, tysm.

Just out of curiousity and for next time I have a problem, I did that following my nose in the web interface, but how would I enter in text commands like that with the indented bit and stuff? I tried it in the SSH but it said the command config was invalid. Is that what timur.davletshin is talking about?

Thank you for your help.

Wait sorry so do those two commands permanently remove that problem? Or does it make it 8 reboots instead? Sorry lol I'm just trying to guess what things do.

Thanks for the tip though.

It will remove problem permanently. That first counter will just grow. It was discussed here, I'm lazy to look for that thread.

Adding OpenWrt support for Xiaomi "Redmi Router AX6S"/"Xiaomi Router AX3200" - #1693 by dsouza - here you go. It specifies more commands, but the rest is optional. In fact I removed some lines with passwords (fw_printenv shows all lines) too. Those were set up by native firmware.

Oh cool ok, great.

Don't forget about it. Without it your router WILL brick. In fact you can check how soon by running fw_printenv | grep 'flag_try_sys1_failed'.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.