No internet access no wifi asscotiated etc Linksys EA8300

I installed openwrt 19.7 to Linksys EA8300, also mysetup is Sky uk broaband superfast 80/20. I have to use option 61 Dhcp client which i found instructions for, i setup per instructions on openwrt
but i am unable to get on internet, i tried turning on wifi and it gets disabled and i had a lot of client and master associations popping up,
after restarting there seem to be some connection but i couldnt access through wifi and internet,
The instructions and setup are not clear on openwrt,
I had to setup wan with dsl0.101 and enter client id, and left rest stuff to default, am i supposed to add anything in the etc/config/wireless. or leave as default,
I am getting no internet access, no wireless associated, scanning for wireless does not pickup my ssid. am i missing something
what to do?

I was going through the forum see what to do, am i supposed to enable stuff in the firewall or leave it default, theres no mention in openwrt basic setup, also after rebooting the system is picking up some addresses and connecting to sky system but not allowing me to go on internet and the wifi goes off. some weird stuff, ive twiddled around with the settings for a good while now and still nothing, I did a reset and got stuck logging back in and then the ssh didnt let me throughg saying key has been changed.

How is the EA8300 wired to Sky broadband as the linksys does not have a built in VDSL modem? Is it wired to an old Openreach VDSL2 modem, or have you just wired the EA8300 direct to your existing Sky Hub ?

Do not change the physical interface to dsl0.101. This VLAN setting is only modem-routers. That's partly why there is no internet acess.

If you have wired it direct to sky hub, remove the dhcp option 61 settings etc. This setting is only for use with VDSL bridge modems like the old Openreach boxes.

I can't explain why your wifi refuses to start unless you entered invalid settings (eg. password too short).

Only suggestion is go to LuCI and navigate to Backup/flash firmware menu, and click 'Factory Reset' and start from scratch.

If EA8300 with openwrt (, is wired to existing Sky hub (default, internet access via ethernet using DHCP should just work following the reset in theory. No need to fiddle with firewall or anything else.

ps. you may want to delete the WAN6 interface using LuCI, if you stumble across the issue where ethernet controller craps out when using IPv6 which Sky broadband supports.

Hello bill thanks for your reply, I want to run the Linksys in place of the sky sr102 router that i have, i am on sky vdsfl fibre superfast 80/20. Sky user MER encapsulation and requires option 61/client id to be used, so following instructions in another part of this forum and also sky forum, the only way to configure option 61 is to use wan set on the adsl0.101 which has setting for client id input.
so i got my password and input into field. then i tried enabling wifi and thats where i'm not sure of th correct procedure it i tried doing the settings but it doenst quite associate the interface and doesnt pickup my wifi ssid from sky or the settings that i try enabling.
after resetting it makes connection to sky but keep getting no internet access.

At present i have the linksys connected from wan to lan of sky and using it that way. Since the flash was available for this Linksys EA8300, i wanted to run it direct with internet going into linksys and i use wifi to connect laptops ipads etc.
The linksys is working fine through the sky router.

also i am following this topic to setup the router and using the final solution of johnboy

also the sky forum has all this infor as well and told to do this to get the client id through

The sky forum references are for modem-routers, or routers wired to FTTC/VDSL2 bridge modems. Your linksys is NOT a modem-router. Your SR102 is NOT a bridge modem.

If you want the EA8300 to REPLACE your SR102 hub, have you got a separate VDSL bridge modem? (eg. Openreach FTTC/VDSL2 modem, such as Huawei HG612, or alternatives like Netgear DM200, or TPlink TD-W9970)

Otherwise, if you want to use EA8300 with your existing SR102 and accept there is double-NAT firewall issues too, see my previous post. Do NOT use dhcp option 61 or dsl0.101 settings - they do NOT apply when using SR102 'router' which handles the VLAN 101 and MER connection for you.

Alternatively, you could configure EA8300 as a dumb access point in OpenWrt and let SR102 handle all routing and security, but you would be better off using original linksys firmware than using openwrt imho.

Hello i hav linksys conncted to sky sr102 wan to lan, and its working fine not done any settings,
i wa trying to connected the Linksys to run on its own in place of sky router, to become the main router and get rid of sky router, so i connected internet into wan of Linksys and after flashing open wrt latest i then did the settings recommended for client id like i mentioned from posts above, then tried the wifi setup procedure, then i restarted linksys and i get no internet access.

You have duplicated your post. Please see my previous 2 replies.

Can you confirm you have FTTC 80/20 fibre where the SR102 plugs into telephone socket?

ie. how does the incoming broadband connection wired into your SR102 ?

I thought i can use this Linksys EA8300 on its own its a router and i have sky fttc superfast 80/20. i need to input client id so how can i do that and will this Linksys work on its own, its got everything in this router wifi-router etc. yes i have fttc superfast 80/20 runniing working fine through the sr102.

grey internet cable gfoes straight into wan of sr102. i have master socket with one connection and i have microfilter with one phone connected only and wire going to back into wan of sr102.

You have FTTC VDSL service, the EA8300 is NOT a modem-router.

You cannot plug broadband cable (looks like a regular telephone cable with small RJ11 plug) into the EA8300's WAN RJ45 ethernet socket. It won't work. You need a 'bridge modem' to go between the incoming broadband connection and the WAN socket of your EA8300 'router'.

the grey cable fits into wan socket, i took it out of sky sr102 and put into linksys wan direct. i was getting ip address into openwrt showing ip address and some connections being made to devices
yes it is the small rj11 cable going into the wan socket, though it doesnt fully go in and click like the ethernet plugs

I'm confused.

Is the incoming broadband cable from master socket plugged into 'grey' coloured socket at top of the SR102, or into one of the yellow LAN sockets (bottom socket I think) ?

Its connected to wan input at top of sr102 and not using the other 4 ethenet ports.

The grey socket at the top is NOT a 'wan' port. It is a 'DSL' port.


The yellow LAN socket with green bar beneath also doubles as 'optional' WAN port for wiring to an external bridge modem.

You need to install a VDSL bridge modem if you wish to use the EA8300 properly. Used Openreach HG612 (type 3B) made up to 2015, or try TPlink TD-W9970 which offers Bridge mode

Hi yes i have internet from microfiler going to the DSL connction at top and not going to yellow port

see previous replies. You need to buy/install a bridge modem to be able to fully use EA8300, if you wish to retire the SR102 hub.

Thank you for your patience and clarifying this for me, its going to involve get another device, so i might as well carry on using the linksys wan connected to lan(wan) of sky sr102.
What system do u use on sky and will it be good to try getting another bridge modem

Also how cdme it was picking up ip address when connected on its own the linksys.

I don't have Sky broadband, but Sky used to supply Openreach bridge modems before introduction of SR102 in 2014.

TPlink TD-W9970 offers bridge mode.
Used Netgear DM200 offers bridge mode.
Any used 'BT Business Hub 5' or 'BT Smart Business Hub' offers bridge mode (Must be 'Business' version, not 'Home' version) should work with sky in theory.

No idea regarding rogue IP address. Software bug?

If you encounter firewall issues with some apps or devices. eg. games consoles. You will have to consider replacing the SR102 'router' with a 'bridge' modem.

Please mark thread as Solved.

1 Like

Thank you ever so much for replying , and fully claryfying the situation. I did revert back to stock Linksys and running as before. I did spend a good few hours trying all the different settings but the Linksys did not give internet access. I was wondering how come other people with this router are able to connect but have other issues and this router being new triband ac etc and having all the bells and whistles should work. Well like they say u learn a new thing everyday.
Thanks again bill !!!