No internet access after OpenWrt installation

So i install openwrt in my archer c6 v3 with oem easy install . Then tried to go but no connection. Then with help of putty can access the router tried okg update but it failed what to do now ?

Which firmware image did you download and install? Does your computer have an ip address? If so, what is it?

NOTE: you must be connected by Ethernet. WiFi is disabled by default.

22.03.3 . yes and . and I am currently connected by ethernet
tried opkg install & luci but it failed and wget returned 4

Which specific image (what was the file name)?

Do you have any other network connections? Make sure that WiFi is disabled on your computer and that there is a single Ethernet connection directly between the router and your computer, no other connections at all.

Can you ping What about ssh?

After ping command it showing 64 bytes from seq = 130 ttl=64 time=0.320 s

No other connection is at all
In ssh i tried to okpg update and install luci but failed and wget returned 4

What is the output of:

ubus call system board

How to find that ?

Login via ssh (which it seems you have already done) then issue the command.


You have installed a snapshot image. Read the link for instructions how to install Luci, which is not installed by default in snapshots.

You should install a stable release build. This is why I asked about the filename of the firmware you installed.

aaah.can u provide me a stable release build link?

i also tried to installed luci and here it is the prob

Download the sysupgrade image to your computer, then transfer it to your router and run the sysupgrade process. To be on the safe side, don't keep settings.

from your computer:

scp openwrt-22.03.3-ramips-mt7621-tplink_archer-c6-v3-squashfs-sysupgrade.bin root@

Then from the router:

sysupgrade -n /tmp/openwrt-22.03.3-ramips-mt7621-tplink_archer-c6-v3-squashfs-sysupgrade.bin root@

This won't necessarily fix your connectivity issue, but it will at least give you a stable release that has the LuCI web interface preinstalled.