No DNS over Open VPN - GL.iNET Mango

Noob here. I bought the GL.iNET Mango a year or so ago and have not been able to get it work properly.

At home, I have a TPLink Archer AX50 running the OpenVPN Server (stock firmware)

Remote, I have the GL.iNet running the OpenVPN Client.

When the VPN is active, I am able to ping hosts inside and outside.

The remote host connected to the Mango is unable to resolve DNS. Even if I run a NSLOOKUP and set the server to Level3 or Google- there is no response. Turn the VPN off, and DNS will work fine.

I have tried a number of the solutions to similar problems, but no success.


Are you using the GL-inet firmware, or have you installed an official version of OpenWrt?


Using the GL-inet firmware with hopes that their support would be able to help fix the problem. I must compliment them on how responsive they are, but have been unable to resolve the issue.

Work-around I found is to configure the Mango to use one of the cloud DNS services. I am guessing that option somehow bypasses the VPN for DNS traffic. I only tested it once, so don't know for sure if this will make the device usable for my needs.

I typically only use the Mango while traveling, so I won't know till next time I travel.

In the future then since you're not using OpenWrt, you may prefer to make a thread here: