No DHCP through Ethernet


my Turris Omnia updated to OS 5

Powered by LuCI branch (git-20.200.40954-91ac721) / TurrisOS 5.0.4 2ca5a386eeefb11de15a9b359ae2769f775d58c9

and it seems that devices connected via ethernet are not getting IP addresses anymore… I tried with a raspberry4 and with my laptop…

Any I dea where I should be looking to investigate?

Thank you so much!

Try this way:
[Workaround] GL-AR150: No DHCP if LAN cable is not plugged during boot

Your post does not appear to be related to an officially released OpenWrt version.

It is unlikely that you will receive useful input here.

Please seek advise from the relevant maintainer.


I wouldn't say it. Turris OS 5.0.4 is based on the latest OpenWrt 19.07 version. You can check hashes for Turris OS 5.0.4: . :wink:

Thanks for the info Pepe, but still not related to officially released OpenWrt version. We are not supposed to support in here every fork and custom build.

And where is written what is supported or not? Oh, I forget. This is not mention in documentation of OpenWrt. But of course, if you don't know the answer, you will complain about anything else without helping OP.


For this forum at least it is sort of is mentioned Installing and Using OpenWrt

Ask questions about installing, using, configuring, and troubleshooting already-built OpenWrt firmware

which implies modification of the OpenWrt code and that is likely beyond the knowledge of this forum's users. Is there some sort of comprehensive list that outlines which part of OpenWrt code gets patched downstream, for easy comparison?

1 Like