No DHCP for ISP if I change vlan 2 to 999

I have reverted back to old release as wifi is so bad on WRT3200ASM.

I changed wan vlan 2 to 999 and cannot get IP from DHCP

I need vlan 2 tagged on LAN for Ham Radio links.

How can I do this or fix it?

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd8d:5dfc:37b3::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option proto 'dhcp'
        option ifname 'eth1.999'

config interface 'wan6'
        option proto 'dhcpv6'
        option ifname 'eth1.999'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '5t 3 2 1 0'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '999'
        option ports '6t 4'
        option vid '999'

This should probably read eth0.999 in both cases, since eth0 is your switch (assuming it's a swconfig-based switch). The swconfig stanzas were already there in the default configuration, right?

1 Like

Was all read there just changed 2 to 999

Some older switch chips don't support high number VLANs... try <= 15.

Also, what version of OpenWrt are you using?

ubus call system board
1 Like

A lower number did not help.

{
        "kernel": "4.14.221",
        "hostname": "OpenWrt",
        "system": "ARMv7 Processor rev 1 (v7l)",
        "model": "Linksys WRT3200ACM",
        "board_name": "linksys,rango",
        "release": {
                "distribution": "OpenWrt",
                "version": "19.07.7",
                "revision": "r11306-c4a6851c72",
                "target": "mvebu/cortexa9",
                "descri
ption": "OpenWrt 19.07.7 r11306-c4a6851c72"
        }
}

Did you replace eth1 by eth0?

Fixed looks like luci does change vlan numbers correct in 19.07.7 change it in vi and all is working.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.