No DHCP/broadcast forwarding using client with relayd pseudobridge

Hi,
For about 2 weeks I'm trying to solve problem with relayd pseudobridge. I have configure router using this tutorial: https://openwrt.org/docs/guide-user/network/wifi/relay_configuration but still I am unable to receive DHCP response from client area of network (192.168.1.1/24). Static ip configuration works and in this case I can connect to Internet etc but dhcp responses are blocked somewhat on openwrt router.

My network topology:
192.168.1.1 - gateway to internet (upc router)
192.168.1.0/24 - home wifi network
192.168.2.0/24 - WT3020H network
192.168.1.11 - WT3020H bridge client ip (I can connect to router using 192.168.1.0/24 network)
192.168.1.2 - DHCP, DNS local server

Does anyone have idea what might be the cause of this problem?

router configuration:

root@Misza-LEDE:~# uci export
package dhcp

config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option authoritative '1'

config dhcp 'lan'
	option interface 'lan'
	option ignore '1'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

package dropbear

config dropbear
	option PasswordAuth 'on'
	option Interface 'lan'
	option Port '22'

config dropbear
	option Port '22'
	option Interface 'wwan'
	option RootPasswordAuth 'off'
	option PasswordAuth 'off'

package firewall

config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	option flow_offloading '1'
	option flow_offloading_hw '1'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	option log '1'
	option network 'bridge lan wwan'

config include
	option path '/etc/firewall.user'

package luci

config core 'main'
	option lang 'auto'
	option mediaurlbase '/luci-static/bootstrap'
	option resourcebase '/luci-static/resources'

config extern 'flash_keep'
	option uci '/etc/config/'
	option dropbear '/etc/dropbear/'
	option openvpn '/etc/openvpn/'
	option passwd '/etc/passwd'
	option opkg '/etc/opkg.conf'
	option firewall '/etc/firewall.user'
	option uploads '/lib/uci/upload/'

config internal 'languages'

config internal 'sauth'
	option sessionpath '/tmp/luci-sessions'
	option sessiontime '3600'

config internal 'ccache'
	option enable '1'

config internal 'themes'
	option Bootstrap '/luci-static/bootstrap'

config internal 'apply'
	option rollback '30'
	option holdoff '4'
	option timeout '5'
	option display '1.5'

config internal 'diag'
	option dns 'openwrt.org'
	option ping 'openwrt.org'
	option route 'openwrt.org'

config ifstate
	option interface 'lan'
	option ifname 'eth0.1'
	option bridge 'true'

package network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdb0:15c6:fe3f::/48'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option ip6assign '60'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'
	option ifname 'eth0.1 eth0.2'
	option broadcast '255.255.255.255'
	option gateway '192.168.1.1'
	option dns '192.168.1.2 208.67.222.222 8.8.8.8'

config device 'lan_dev'
	option name 'eth0.1'
	option macaddr '20:28:18:a1:56:e6'

config device 'wan_dev'
	option name 'eth0.2'
	option macaddr '20:28:18:a1:56:e7'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '4 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0 6t'

config interface 'wwan'
	option proto 'dhcp'
	option hostname 'Misza-LEDE'

config interface 'bridge'
	option proto 'relay'
	option ipaddr '192.168.1.11'
	list network 'lan'
	list network 'wwan'

package rpcd

config login
	option username 'root'
	option password '$p$root'
	list read '*'
	list write '*'

package system

config system
	option ttylogin '0'
	option log_size '64'
	option urandom_seed '0'
	option log_port '514'
	option log_proto 'udp'
	option conloglevel '8'
	option cronloglevel '8'
	option log_ip '192.168.1.2'
	option hostname 'Misza-LEDE'
	option zonename 'Europe/Warsaw'
	option timezone 'CET-1CEST,M3.5.0,M10.5.0/3'

config timeserver 'ntp'
	option enabled '1'
	list server '0.openwrt.pool.ntp.org'
	list server '1.openwrt.pool.ntp.org'
	list server '2.openwrt.pool.ntp.org'
	list server '3.openwrt.pool.ntp.org'
	option enable_server '1'

config led
	option name 'poweron'
	option sysfs 'wt3020:blue:power'
	option default '0'
	option trigger 'none'

package ucitrack

config network
	option init 'network'
	list affects 'dhcp'
	list affects 'radvd'

config wireless
	list affects 'network'

config firewall
	option init 'firewall'
	list affects 'luci-splash'
	list affects 'qos'
	list affects 'miniupnpd'

config olsr
	option init 'olsrd'

config dhcp
	option init 'dnsmasq'
	list affects 'odhcpd'

config odhcpd
	option init 'odhcpd'

config dropbear
	option init 'dropbear'

config httpd
	option init 'httpd'

config fstab
	option exec '/sbin/block mount'

config qos
	option init 'qos'

config system
	option init 'led'
	option exec '/etc/init.d/log reload'
	list affects 'luci_statistics'
	list affects 'dhcp'

config luci_splash
	option init 'luci_splash'

config upnpd
	option init 'miniupnpd'

config ntpclient
	option init 'ntpclient'

config samba
	option init 'samba'

config tinyproxy
	option init 'tinyproxy'

package uhttpd

config uhttpd 'main'
	list listen_http '0.0.0.0:80'
	list listen_http '[::]:80'
	list listen_https '0.0.0.0:443'
	list listen_https '192.168.1.10:443'
	list listen_https '192.168.2.1:443'
	list listen_https '192.168.1.11:443'
	list listen_https '[::]:443'
	option redirect_https '0'
	option home '/www'
	option rfc1918_filter '1'
	option max_requests '5'
	option max_connections '100'
	option cert '/etc/uhttpd.crt'
	option key '/etc/uhttpd.key'
	option cgi_prefix '/cgi-bin'
	option lua_prefix '/luci'
	option lua_handler '/usr/lib/lua/luci/sgi/uhttpd.lua'
	option script_timeout '60'
	option network_timeout '30'
	option http_keepalive '20'
	option tcp_keepalive '1'

config cert 'defaults'
	option days '730'
	option bits '2048'
	option country 'ZZ'
	option state 'Somewhere'
	option location 'Unknown'

package wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/10180000.wmac'
	option htmode 'HT20'
	option disabled '0'
	option channel '6'
	option legacy_rates '1'
	option country 'PL'

config wifi-iface
	option network 'wwan'
	option ssid 'UPC'
	option encryption 'psk2'
	option device 'radio0'
	option mode 'sta'
	option bssid '00:36:76:B5:54:FE'
	option key '********'

config wifi-iface
	option device 'radio0'
	option mode 'ap'
	option ssid 'Misza-LEDE'
	option encryption 'psk2'
	option key '********'
	option network 'lan'

I have similar problems with a bridge and DHCP. Countless experiments with relayd did not lead to success. What works is the package kmod-trelay. The module is simple but tricky. I suggest, do not start trelay automatically - rather manually. Maybe I should write a guide.

Thanks for reply :slight_smile:
I'll try configure bridge using kmod-trelay. Can I download it using opkg or I have to compile it on my own?

It is a kernel module - provided by opkg.

Update and look for kmod-trelay:

opkg update && opkg list |grep trelay

kmod-trelay - 4.14.78+0.1-2 - trelay relays ethernet packets between two devices (similar to a bridge), but
without any MAC address checks. This makes it possible to bridge client mode or ad-hoc mode wifi devices
to ethernet VLANs, assuming the remote end uses the same source MAC address as the device that packets
are supposed to exit from.

Install it and edit /etc/config/trelay.

Ok thanks. After reboot kmod-trelay magically shows up in opkg list :stuck_out_tongue:

Avoid trelay to start automatically - a misconfiguration can ruin your access to your router and you need to reset it.

Here is a quick & dirty setup - if I remember correctly;).
Simple bridge wifi client radio1 to AP radio0.

  1. Setup your interfaces and leave it unconfigured.
  2. config trelay /etc/config/trelay
config trelay
	option enabled	1
	option dev1	wwan
	option dev2	wlan0

I'm doing something wrong. I need to create 2 interfaces WWAN and WLAN and attach to them interface wlan0 (home network client) and wlan0-1 (openwrt wifi)? These interfaces have static blank addresses?

You can use wlan0and wlan0-1. I like to give the interface a name i my case is wlan1-1 now wwan.

config wifi-iface 'default_radio1'
        option device 'radio1'
        option mode 'sta'
        option ifname 'wwan'
        option network 'wwan'

Setup a fake network for your AP and use it in your wireless config.

config interface 'fakenet'
        option proto 'none'

So this configuration should work? Because it doesn't works :frowning:

root@Misza-LEDE:/etc/config# cat wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/10180000.wmac'
	option htmode 'HT20'
	option channel '6'
	option legacy_rates '1'
	option country 'PL'

config wifi-iface
	option ssid 'UPC249250565'
	option encryption 'psk2'
	option device 'radio0'
	option mode 'sta'
	option bssid '00:36:76:B5:54:FE'
	option key '********'
	option ifname 'wwan'

config wifi-iface
	option device 'radio0'
	option mode 'ap'
	option ssid 'Misza-LEDE'
	option encryption 'psk2'
	option key '********'
	option network 'wlan'
	option ifname 'wlan'

root@Misza-LEDE:/etc/config# cat network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdb0:15c6:fe3f::/48'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option ip6assign '60'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'
	option broadcast '255.255.255.255'
	option gateway '192.168.1.1'
	option dns '192.168.1.2 208.67.222.222 8.8.8.8'
	option ifname 'eth0.1 eth0.2'

config device 'lan_dev'
	option name 'eth0.1'
	option macaddr '20:28:18:a1:56:e6'

config device 'wan_dev'
	option name 'eth0.2'
	option macaddr '20:28:18:a1:56:e7'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '4 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0 6t'

config interface 'wlan'
	option proto 'none'

root@Misza-LEDE:/etc/config# cat trelay

config trelay
	option enabled	1
	option dev1	wlan
	option dev2	wwan

I cannot find process named trelay despite I have started /etc/init.d/trelay service. Is that good?
In addition ssh freezes when I'm trying restart/stop trelay.

You config files are ok but missing the wwan network.

# Set `wwan` network for your client wifi interface:
uci set wireless.@wifi-iface[0].network='wwan'
# Add `wwan` to your network config:
uci set network.wwan='interface'
uci set network.wwan.proto='none' # use none or dhcp

uci commit

Check interfaces are available with ifconfig -a. Then try to start trelay.

trelay is a kernel module and is set up via the sys interface.
How it works: https://github.com/openwrt/openwrt/blob/master/package/kernel/trelay/files/trelay.init#L16-L18

That's why I said "Do not start trelay automatically" :wink: .
If you're connected via Wi-Fi, that's normal. Reconnect and this time you should get an IP over the bridge.

Hmmm, previously I had added iface wwan and had attached to this UPC network radio but it didn't work :frowning:

Ok I've created wwan interface for UPC network:
root@Misza-LEDE:/etc/config# cat network

[...]
config interface 'wwan'
	option proto 'dhcp'
	option hostname 'Misza-lede-wt3020'

Interface wwan is up and have ip address. I'm able to connect to router through UPC network.
Trelay is disabled at start, after reboot I start it using "/etc/init.d/trelay start".

I'm using ethernet connection for ssh so "service trelay stop" in my view should not hang ssh (cannot terminate process using ctrl+c). Furthermore I still can connect to router over https or ssh in new console.

This is "ifconfig -a" after start of trelay:
root@Misza-LEDE:~# ifconfig -a > before.log
root@Misza-LEDE:~# service trelay start
root@Misza-LEDE:~# ifconfig -a > after.log

root@Misza-LEDE:~# cat before.log

br-lan    Link encap:Ethernet  HWaddr 20:28:18:A1:56:E6  
          inet addr:192.168.2.1  Bcast:255.255.255.255  Mask:255.255.255.0
          inet6 addr: fdb0:15c6:fe3f::1/60 Scope:Global
          inet6 addr: fe80::2228:18ff:fea1:56e6/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:524 errors:0 dropped:0 overruns:0 frame:0
          TX packets:421 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:47180 (46.0 KiB)  TX bytes:88149 (86.0 KiB)

eth0      Link encap:Ethernet  HWaddr 20:28:18:A1:56:E6  
          inet6 addr: fe80::2228:18ff:fea1:56e6/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:575 errors:0 dropped:0 overruns:0 frame:0
          TX packets:451 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:62049 (60.5 KiB)  TX bytes:93929 (91.7 KiB)
          Interrupt:5 

eth0.1    Link encap:Ethernet  HWaddr 20:28:18:A1:56:E6  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:524 errors:0 dropped:0 overruns:0 frame:0
          TX packets:421 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:47180 (46.0 KiB)  TX bytes:88149 (86.0 KiB)

eth0.2    Link encap:Ethernet  HWaddr 20:28:18:A1:56:E7  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:1625 (1.5 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:38 errors:0 dropped:0 overruns:0 frame:0
          TX packets:38 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:4987 (4.8 KiB)  TX bytes:4987 (4.8 KiB)

wlan      Link encap:Ethernet  HWaddr 20:28:18:A1:56:E7  
          inet6 addr: fe80::2228:18ff:fea1:56e7/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:872 (872.0 B)

wwan      Link encap:Ethernet  HWaddr 20:28:18:A1:56:E6  
          inet addr:192.168.1.10  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::2228:18ff:fea1:56e6/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:43 errors:0 dropped:0 overruns:0 frame:0
          TX packets:63 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:8415 (8.2 KiB)  TX bytes:8403 (8.2 KiB)


root@Misza-LEDE:~# cat after.log

br-lan    Link encap:Ethernet  HWaddr 20:28:18:A1:56:E6  
          inet addr:192.168.2.1  Bcast:255.255.255.255  Mask:255.255.255.0
          inet6 addr: fdb0:15c6:fe3f::1/60 Scope:Global
          inet6 addr: fe80::2228:18ff:fea1:56e6/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:778 errors:0 dropped:0 overruns:0 frame:0
          TX packets:603 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:67460 (65.8 KiB)  TX bytes:126625 (123.6 KiB)

eth0      Link encap:Ethernet  HWaddr 20:28:18:A1:56:E6  
          inet6 addr: fe80::2228:18ff:fea1:56e6/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:829 errors:0 dropped:0 overruns:0 frame:0
          TX packets:633 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:86901 (84.8 KiB)  TX bytes:133133 (130.0 KiB)
          Interrupt:5 

eth0.1    Link encap:Ethernet  HWaddr 20:28:18:A1:56:E6  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:778 errors:0 dropped:0 overruns:0 frame:0
          TX packets:603 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:67460 (65.8 KiB)  TX bytes:126625 (123.6 KiB)

eth0.2    Link encap:Ethernet  HWaddr 20:28:18:A1:56:E7  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:1625 (1.5 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:38 errors:0 dropped:0 overruns:0 frame:0
          TX packets:38 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:4987 (4.8 KiB)  TX bytes:4987 (4.8 KiB)

wlan      Link encap:Ethernet  HWaddr 20:28:18:A1:56:E7  
          inet6 addr: fe80::2228:18ff:fea1:56e7/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:872 (872.0 B)

wwan      Link encap:Ethernet  HWaddr 20:28:18:A1:56:E6  
          inet addr:192.168.1.10  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::2228:18ff:fea1:56e6/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:43 errors:0 dropped:0 overruns:0 frame:0
          TX packets:65 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:8415 (8.2 KiB)  TX bytes:8623 (8.4 KiB)

root@Misza-LEDE:~# diff after.log before.log

6,7c6,7
<           RX packets:778 errors:0 dropped:0 overruns:0 frame:0
<           TX packets:603 errors:0 dropped:0 overruns:0 carrier:0
---
>           RX packets:524 errors:0 dropped:0 overruns:0 frame:0
>           TX packets:421 errors:0 dropped:0 overruns:0 carrier:0
9c9
<           RX bytes:67460 (65.8 KiB)  TX bytes:126625 (123.6 KiB)
---
>           RX bytes:47180 (46.0 KiB)  TX bytes:88149 (86.0 KiB)
14,15c14,15
<           RX packets:829 errors:0 dropped:0 overruns:0 frame:0
<           TX packets:633 errors:0 dropped:0 overruns:0 carrier:0
---
>           RX packets:575 errors:0 dropped:0 overruns:0 frame:0
>           TX packets:451 errors:0 dropped:0 overruns:0 carrier:0
17c17
<           RX bytes:86901 (84.8 KiB)  TX bytes:133133 (130.0 KiB)
---
>           RX bytes:62049 (60.5 KiB)  TX bytes:93929 (91.7 KiB)
22,23c22,23
<           RX packets:778 errors:0 dropped:0 overruns:0 frame:0
<           TX packets:603 errors:0 dropped:0 overruns:0 carrier:0
---
>           RX packets:524 errors:0 dropped:0 overruns:0 frame:0
>           TX packets:421 errors:0 dropped:0 overruns:0 carrier:0
25c25
<           RX bytes:67460 (65.8 KiB)  TX bytes:126625 (123.6 KiB)
---
>           RX bytes:47180 (46.0 KiB)  TX bytes:88149 (86.0 KiB)
56c56
<           TX packets:65 errors:0 dropped:0 overruns:0 carrier:0
---
>           TX packets:63 errors:0 dropped:0 overruns:0 carrier:0
58c58
<           RX bytes:8415 (8.2 KiB)  TX bytes:8623 (8.4 KiB)
---
>           RX bytes:8415 (8.2 KiB)  TX bytes:8403 (8.2 KiB)

I'm still unable to get ip in wlan network through dhcp. In addition device with static ip in wlan cannot ping anyone in wwan, even router client ip (192.168.1.10).

UPDATE:
I'm unable to get arp response from router from wlan side (UPC network). Arp requests don't reach router according to wireshark dump. In addition arp requests after 1-2 minutes reach router and there is generated response. But I cannot determine why this is happening and now I can't replicate this situation - no arp requests are delivered to router. :frowning:

After using arping tool table is updated and there are single arp responses from router. (about 1% of excepted responses) And only this requests/responses are visible on tcp dump from router.

tcpdump from received arp requests and responses:

"No.","Time","Source","Destination","Protocol","Length","Info"
"2","66.349160","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","Who has 192.168.1.5? Tell 192.168.1.10"
"3","66.412819","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","192.168.1.5 is at 00:e1:8c:46:4e:bb"
"4","66.534399","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","Who has 192.168.1.10? Tell 192.168.1.5"
"5","66.534479","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","192.168.1.10 is at 20:28:18:a1:56:e6"
"6","131.709186","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","Who has 192.168.1.5? Tell 192.168.1.10"
"7","131.819426","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","Who has 192.168.1.10? Tell 192.168.1.5"
"8","131.819506","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","192.168.1.10 is at 20:28:18:a1:56:e6"
"9","132.749203","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","Who has 192.168.1.5? Tell 192.168.1.10"
"10","133.789139","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","Who has 192.168.1.5? Tell 192.168.1.10"
"11","133.894279","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","192.168.1.5 is at 00:e1:8c:46:4e:bb"
"14","187.069146","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","Who has 192.168.1.5? Tell 192.168.1.10"
"15","187.069286","20:28:18:a1:56:e6","ArrisGro_b4:06:88","ARP","42","Who has 192.168.1.1? Tell 192.168.1.10"
"16","187.079366","ArrisGro_b4:06:88","20:28:18:a1:56:e6","ARP","60","192.168.1.1 is at 00:36:76:b4:06:88"
"17","187.120626","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","Who has 192.168.1.10? Tell 192.168.1.5"
"18","187.120706","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","192.168.1.10 is at 20:28:18:a1:56:e6"
"19","187.133606","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","192.168.1.5 is at 00:e1:8c:46:4e:bb"
"24","285.709197","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","Who has 192.168.1.5? Tell 192.168.1.10"
"25","285.752416","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","192.168.1.5 is at 00:e1:8c:46:4e:bb"
"26","285.929276","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","Who has 192.168.1.10? Tell 192.168.1.5"
"27","285.929356","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","192.168.1.10 is at 20:28:18:a1:56:e6"
"28","351.069163","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","Who has 192.168.1.5? Tell 192.168.1.10"
"29","351.209383","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","Who has 192.168.1.10? Tell 192.168.1.5"
"30","351.209463","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","192.168.1.10 is at 20:28:18:a1:56:e6"
"31","351.217243","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","192.168.1.5 is at 00:e1:8c:46:4e:bb"
"32","416.589182","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","Who has 192.168.1.5? Tell 192.168.1.10"
"33","416.629822","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","192.168.1.5 is at 00:e1:8c:46:4e:bb"
"34","416.751582","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","Who has 192.168.1.10? Tell 192.168.1.5"
"35","416.751662","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","192.168.1.10 is at 20:28:18:a1:56:e6"
"38","444.189151","20:28:18:a1:56:e6","ArrisGro_b4:06:88","ARP","42","Who has 192.168.1.1? Tell 192.168.1.10"
"39","444.197891","ArrisGro_b4:06:88","20:28:18:a1:56:e6","ARP","60","192.168.1.1 is at 00:36:76:b4:06:88"
"44","482.539931","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","Who has 192.168.1.10? Tell 192.168.1.5"
"45","482.540011","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","192.168.1.10 is at 20:28:18:a1:56:e6"
"46","547.709200","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","Who has 192.168.1.5? Tell 192.168.1.10"
"47","547.770361","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","192.168.1.5 is at 00:e1:8c:46:4e:bb"
"48","547.821802","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","Who has 192.168.1.10? Tell 192.168.1.5"
"49","547.821882","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","192.168.1.10 is at 20:28:18:a1:56:e6"
"50","613.549159","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","Who has 192.168.1.5? Tell 192.168.1.10"
"51","613.622720","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","Who has 192.168.1.10? Tell 192.168.1.5"
"52","613.622800","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","192.168.1.10 is at 20:28:18:a1:56:e6"
"53","613.623220","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","192.168.1.5 is at 00:e1:8c:46:4e:bb"
"54","680.945129","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","Who has 192.168.1.10? Tell 192.168.1.5"
"55","680.945209","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","192.168.1.10 is at 20:28:18:a1:56:e6"
"56","680.989150","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","Who has 192.168.1.5? Tell 192.168.1.10"
"57","682.029170","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","Who has 192.168.1.5? Tell 192.168.1.10"
"58","682.173993","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","192.168.1.5 is at 00:e1:8c:46:4e:bb"
"61","712.429161","20:28:18:a1:56:e6","ArrisGro_b4:06:88","ARP","42","Who has 192.168.1.1? Tell 192.168.1.10"
"62","712.444461","ArrisGro_b4:06:88","20:28:18:a1:56:e6","ARP","60","192.168.1.1 is at 00:36:76:b4:06:88"
"67","752.509177","20:28:18:a1:56:e6","ArrisGro_b4:06:88","ARP","42","Who has 192.168.1.1? Tell 192.168.1.10"
"68","752.525177","ArrisGro_b4:06:88","20:28:18:a1:56:e6","ARP","60","192.168.1.1 is at 00:36:76:b4:06:88"
"69","753.134435","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","Who has 192.168.1.10? Tell 192.168.1.5"
"70","753.134515","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","192.168.1.10 is at 20:28:18:a1:56:e6"
"71","819.069191","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","Who has 192.168.1.5? Tell 192.168.1.10"
"72","819.087151","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","192.168.1.5 is at 00:e1:8c:46:4e:bb"
"73","819.184430","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","Who has 192.168.1.10? Tell 192.168.1.5"
"74","819.184510","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","192.168.1.10 is at 20:28:18:a1:56:e6"
"75","884.723402","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","Who has 192.168.1.10? Tell 192.168.1.5"
"76","884.723482","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","192.168.1.10 is at 20:28:18:a1:56:e6"
"77","884.749162","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","Who has 192.168.1.5? Tell 192.168.1.10"
"78","884.764302","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","192.168.1.5 is at 00:e1:8c:46:4e:bb"
"79","950.189149","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","Who has 192.168.1.5? Tell 192.168.1.10"
"80","950.204589","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","192.168.1.5 is at 00:e1:8c:46:4e:bb"
"81","950.251689","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","Who has 192.168.1.10? Tell 192.168.1.5"
"82","950.251769","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","192.168.1.10 is at 20:28:18:a1:56:e6"
"85","974.749196","20:28:18:a1:56:e6","ArrisGro_b4:06:88","ARP","42","Who has 192.168.1.1? Tell 192.168.1.10"
"86","974.764416","ArrisGro_b4:06:88","20:28:18:a1:56:e6","ARP","60","192.168.1.1 is at 00:36:76:b4:06:88"
"89","1014.004427","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","Who has 192.168.1.10? Tell 192.168.1.5"
"90","1014.004507","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","192.168.1.10 is at 20:28:18:a1:56:e6"
"93","1019.869177","20:28:18:a1:56:e6","ArrisGro_b4:06:88","ARP","42","Who has 192.168.1.1? Tell 192.168.1.10"
"94","1019.884437","ArrisGro_b4:06:88","20:28:18:a1:56:e6","ARP","60","192.168.1.1 is at 00:36:76:b4:06:88"
"95","1085.389175","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","Who has 192.168.1.5? Tell 192.168.1.10"
"96","1085.401175","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","192.168.1.5 is at 00:e1:8c:46:4e:bb"
"97","1085.426275","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","Who has 192.168.1.10? Tell 192.168.1.5"
"98","1085.426355","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","192.168.1.10 is at 20:28:18:a1:56:e6"
"99","1151.149188","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","Who has 192.168.1.5? Tell 192.168.1.10"
"100","1151.214867","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","Who has 192.168.1.10? Tell 192.168.1.5"
"101","1151.214947","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","192.168.1.10 is at 20:28:18:a1:56:e6"
"102","1151.218547","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","192.168.1.5 is at 00:e1:8c:46:4e:bb"
"103","1216.429174","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","Who has 192.168.1.5? Tell 192.168.1.10"
"104","1216.482774","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","192.168.1.5 is at 00:e1:8c:46:4e:bb"
"105","1216.494514","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","Who has 192.168.1.10? Tell 192.168.1.5"
"106","1216.494574","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","192.168.1.10 is at 20:28:18:a1:56:e6"
"109","1235.949154","20:28:18:a1:56:e6","ArrisGro_b4:06:88","ARP","42","Who has 192.168.1.1? Tell 192.168.1.10"
"110","1235.964614","ArrisGro_b4:06:88","20:28:18:a1:56:e6","ARP","60","192.168.1.1 is at 00:36:76:b4:06:88"
"113","1272.055904","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","Who has 192.168.1.10? Tell 192.168.1.5"
"114","1272.055984","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","192.168.1.10 is at 20:28:18:a1:56:e6"
"117","1339.389158","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","Who has 192.168.1.5? Tell 192.168.1.10"
"118","1339.469438","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","192.168.1.5 is at 00:e1:8c:46:4e:bb"
"119","1339.636937","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","Who has 192.168.1.10? Tell 192.168.1.5"
"120","1339.637017","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","192.168.1.10 is at 20:28:18:a1:56:e6"
"121","1405.678162","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","Who has 192.168.1.10? Tell 192.168.1.5"
"122","1405.678242","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","192.168.1.10 is at 20:28:18:a1:56:e6"
"123","1405.709202","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","Who has 192.168.1.5? Tell 192.168.1.10"
"124","1406.749202","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","Who has 192.168.1.5? Tell 192.168.1.10"
"125","1406.759102","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","192.168.1.5 is at 00:e1:8c:46:4e:bb"
"126","1472.429177","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","Who has 192.168.1.5? Tell 192.168.1.10"
"127","1472.488797","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","192.168.1.5 is at 00:e1:8c:46:4e:bb"
"128","1472.494917","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","Who has 192.168.1.10? Tell 192.168.1.5"
"129","1472.494997","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","192.168.1.10 is at 20:28:18:a1:56:e6"
"132","1500.189150","20:28:18:a1:56:e6","ArrisGro_b4:06:88","ARP","42","Who has 192.168.1.1? Tell 192.168.1.10"
"133","1500.205510","ArrisGro_b4:06:88","20:28:18:a1:56:e6","ARP","60","192.168.1.1 is at 00:36:76:b4:06:88"
"134","1506.036969","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","Who has 192.168.1.10? Tell 192.168.1.5"
"135","1506.037049","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","192.168.1.10 is at 20:28:18:a1:56:e6"
"140","1542.386386","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","Who has 192.168.1.10? Tell 192.168.1.5"
"141","1542.386466","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","192.168.1.10 is at 20:28:18:a1:56:e6"
"142","1544.269186","20:28:18:a1:56:e6","ArrisGro_b4:06:88","ARP","42","Who has 192.168.1.1? Tell 192.168.1.10"
"143","1544.280766","ArrisGro_b4:06:88","20:28:18:a1:56:e6","ARP","60","192.168.1.1 is at 00:36:76:b4:06:88"
"144","1609.709148","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","Who has 192.168.1.5? Tell 192.168.1.10"
"145","1609.718248","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","Who has 192.168.1.10? Tell 192.168.1.5"
"146","1609.718328","20:28:18:a1:56:e6","IntelCor_46:4e:bb","ARP","42","192.168.1.10 is at 20:28:18:a1:56:e6"
"147","1609.721908","IntelCor_46:4e:bb","20:28:18:a1:56:e6","ARP","42","192.168.1.5 is at 00:e1:8c:46:4e:bb"