No arp on 2.4GHz network

Hi all,

on my Edimax RA21S I have two wireless networks (2.4GHz and 5GHz). Firewall is disabled, setup is quite default.
Now I found that I was unable to connect to devices that are connected via 2.4GHz regardless which network (2.4GHz or 5GHz) I am located in. My client sends arp requests that don't get answered. When talking to devices located in the 5GHz network, it works flawlessly. The strange thing is that even the OpenWrt AP cannot talk to the 2.4GHz-connected devices. At least unless these devices talk to the AP first, because the mac address is learned from the device's arp request then.
tcpdump shows that the arp requests are sent to all wlan interfaces (wlan0 for 2.4GHz and wlan1 for 5GHz).
As said, firewall is off (even though iptables would not affect arp). Both interfaces, wlan0 and wlan1 have the same kernel settings (sysctl).
Does anyone have a clue on what could be wrong here?

Under Network/Wireless/ Interface Configuration/Advanced Settings is a button:
Isolate Clients (Prevents client-to-client communication)
Is it checked in the 2.4 IF?

It's disabled on both networks. Also turning it on on both networks didn't help.

edit: wait! Enabling it on both network at least made the 2.4GHz devices available for the AP and other devices in the 2.4GHz network. Not for the devices in the 5GHz network, though. I'll play around with this setting a bit.

Looks like it just took some time.
So the solution is enabling Isolate Clients on both networks.

Strange thing, Isolate Clients should do the opposite!?
So it should be disabled.

Yes, that's what I expected the setting to do, too. But if enabling the setting resolves my problem, I'm fine with it. Maybe it's a bug ¯\_(ツ)_/¯

Welp, it suddenly stopped working. This setting has probably nothing to do with the problem, as I re-disabled it and it worked. The "network restart" did the thing. For a while (it stopped working again after 2-3 hours). Guess I'll have to press "Restart" every now and then.